升级xserver-xorg-core后X启不来了

系统错误报告和讨论
qchem
帖子: 106
注册时间: 2005-09-04 21:03
送出感谢: 0
接收感谢: 0

升级xserver-xorg-core后X启不来了

#1

帖子 qchem » 2006-08-22 12:19

升级到.3(前面一串记不住)的xorg-core后,X就启不来了
大家注意
cnhzcy14
帖子: 30
注册时间: 2006-04-06 16:40
送出感谢: 0
接收感谢: 0

#2

帖子 cnhzcy14 » 2006-08-22 12:36

有同样的问题!好像是个大bug!
cnhzcy14
帖子: 30
注册时间: 2006-04-06 16:40
送出感谢: 0
接收感谢: 0

#3

帖子 cnhzcy14 » 2006-08-22 12:54

这里有个缓兵之计:
sudo apt-get install xserver-xorg-core=1:1.0.2-0ubuntu10

When finnish, reboot or just type startx. To reboot type:
sudo shutdown -r now

全球ubuntu都出问题了!
ubuntu team正在全力抢险中!
zhoushijie
帖子: 28
注册时间: 2006-08-06 8:37
送出感谢: 0
接收感谢: 0

#4

帖子 zhoushijie » 2006-08-22 17:00

No devices detected
qiziyh
帖子: 89
注册时间: 2006-05-31 1:52
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 qiziyh » 2006-08-22 18:12

是啊,我的也是这样了,这下要怎么办哦,3楼的老兄,现在进不了X,怎么APT-GET哦,我连在命令下怎么上网都不知道,你可以说详细点吗
goudou
帖子: 1
注册时间: 2006-08-22 18:10
送出感谢: 0
接收感谢: 0

#6

帖子 goudou » 2006-08-22 18:25

Me too!!! I have suffered this for a whole day!

You can use "aptitude" to install the older version forcely, just press "/" and input "xserver-xorg-core" to find that package, and press "enter", move your cursor down to the end of the page then you can see the older version and newer version something like:

p 1.0.2-0ubuntu2
i 1.0.2-0ubuntu3

just move the cursor to the "p 1.0.2-..." line and press "+", you can see the hint to tell you old version is selected. And press "g" and "g" and "g"...Reboot, ok!

This is fine by me and I think it's also good for you.

I was just reinstall Dapper and haven't got my fcitx work. Sorry for my English.
zn12345678
帖子: 4
注册时间: 2006-07-16 2:46
送出感谢: 0
接收感谢: 0

#7

帖子 zn12345678 » 2006-08-22 22:39

好大个BUG啊~~~~~~~
头像
reshine
帖子: 91
注册时间: 2006-04-29 1:43
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 reshine » 2006-08-22 23:04

viewtopic.php?t=22603


根據以下指令動作

wget -c http://people.ubuntu.com/~rodarvus/pack ... 4_i386.deb

wget -c http://people.ubuntu.com/~rodarvus/pack ... 4_i386.deb

抓完後,請下
dpkg -i xserver-xorg*
如果說,xserver-xorg-dev安裝失敗也沒關係
我想應該沒有什麼影響
然後裝好後就可以
sudo /etc/init.d/gdm restart
接著就可以進去X了!



我也遇到同样问题,等下有空了去解决。。。。
baic
帖子: 166
注册时间: 2006-08-22 23:10
送出感谢: 0
接收感谢: 0

#9

帖子 baic » 2006-08-22 23:16

我的降级处理

$ls /var/cache/apt/archives/ | grep xorg

xserver-xorg-core_1%3a1.0.2-0ubuntu10.1_i386.deb
xserver-xorg-core_1%3a1.0.2-0ubuntu10.3_i386.deb
xserver-xorg-input-mouse_1%3a1.0.3.1+cvs.20060109-0ubuntu1.1_i386.deb

$cd /var/cache/apt/archives
$sudo dpkg -i xserver-xorg-core_1%3a1.0.2-0ubuntu10.1_i386.deb
$sudo reboot
头像
xpoint
帖子: 20
注册时间: 2006-08-19 0:26
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 xpoint » 2006-08-22 23:23

我用3楼的办法不行,后来参考英文论坛上的方法,也就是8楼的办法,现在已经恢复了。
yvmu
帖子: 54
注册时间: 2006-05-04 20:04
送出感谢: 0
接收感谢: 0

#11

帖子 yvmu » 2006-08-23 8:01

哎,我本来已经设置成一个月自动升级一次的。

昨天犯贱,心血来潮在命令行里敲了个apt-get update;apt-get upgrade。
wangguanpu
帖子: 35
注册时间: 2006-08-05 6:44
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 wangguanpu » 2006-08-23 10:25

我的也是这个现象 桌面也进不去了
这是怎么回事?
qchem
帖子: 106
注册时间: 2005-09-04 21:03
送出感谢: 0
接收感谢: 0

#13

帖子 qchem » 2006-08-23 10:51

因为这个bug,我昨天装了三次系统
ft

现在我在新得立里把xserver-xorg-core的版本锁定了
ahlongxp
帖子: 209
注册时间: 2006-03-06 19:16
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 ahlongxp » 2006-08-23 11:34

I sufferred the same problem.
ahlongxp
帖子: 209
注册时间: 2006-03-06 19:16
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 ahlongxp » 2006-08-23 11:54

goudou 写了:Me too!!! I have suffered this for a whole day!

You can use "aptitude" to install the older version forcely, just press "/" and input "xserver-xorg-core" to find that package, and press "enter", move your cursor down to the end of the page then you can see the older version and newer version something like:

p 1.0.2-0ubuntu2
i 1.0.2-0ubuntu3

just move the cursor to the "p 1.0.2-..." line and press "+", you can see the hint to tell you old version is selected. And press "g" and "g" and "g"...Reboot, ok!

This is fine by me and I think it's also good for you.

I was just reinstall Dapper and haven't got my fcitx work. Sorry for my English.
thanks for sharing.I'll have a try.

I reinstalled the lovely ubuntu minutes ago,and found the problem was still there. It really drove me crazy.

I believe the workround from ubuntu forum will really solve the problem.but the point is I am on China Education NetWork(?), not able to get through ubuntu.com.

btw,thanks to the ubuntu LIVE-CD,or I can even know it's not my fault.
回复

回到 “Ubuntu错误报告”