当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : (已解决)无线网卡能够ping通网关,却ping不通外网,edge
帖子发表于 : 2006-10-29 6:50 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
edge正式版出来后安装了edge。可是进入图形界面的显卡管理程序却不要求输入密码了(以前版本都需要,例如breezy和dapper)。然后默认的是启用了以太网卡,无线网卡和调制解调器都是禁用的(选择启用无线网卡,会发现关闭设置窗口无线网卡还是禁用状态)。虽然显示是禁用状态,但是无线网卡还是活跃的,能够通过无线网卡ping通内网网关(192.168.1.1那个路由器)。纳闷为何能够ping通网关却不能够ping通网外呢?该如何设置呢?(需要通过命令行么)。 惭愧 :oops: 用到如今的Linux,命令行都不太熟悉(还基本停留在照搬硬套阶段)。 :cry:

最近会计考试即近(我竟然从学雅思到现在都没有看过教材 -_-! ),然后还有雅思。英语好重要哇,用Linux的应该都是深有感触的,还有玩PS2游戏也需要。


最后由 oliver 编辑于 2007-02-22 1:05,总共编辑了 4 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-29 17:02 
头像

注册: 2006-09-24 22:43
帖子: 710
送出感谢: 0 次
接收感谢: 0 次
我也是无线,没碰到你的问题,帮不了你了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-29 17:06 

注册: 2006-10-12 20:23
帖子: 35
地址: xmu
送出感谢: 0 次
接收感谢: 0 次
能ping通网关???太假了吧???


网络名称有没有设对?就是那个Essid,如果你的AP是DHCP的话,ip都可以不用设,直接DHCP,然后重启就可以了


最后由 jerrywoo 编辑于 2006-10-29 17:11,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-29 17:08 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
edgy?
无线的,一般是设置essid和ip,mask,那个网关不要设置。
有时候设置以后,你sudo ifdown eth1,再ifup一次才有效。

/etc/network/interfaces
ifconfig
这些信息你都不提供一点?


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-29 17:09 

注册: 2006-10-12 20:23
帖子: 35
地址: xmu
送出感谢: 0 次
接收感谢: 0 次
我因为无线网卡没设置好,重启后就出现什么Gnome守护程序出错,后来无线网卡设置对了,重启之后就好了,个人认为你也是没设置正确!呵呵


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-29 19:39 
头像

注册: 2006-05-12 0:52
帖子: 781
地址: Chongqing China
送出感谢: 0 次
接收感谢: 0 次
我是局域网,WINDOWS机子做路由,我PING 不通网关和做路由的机子,能PING通网内其他机子。在WIN下同样的设置能上网,在EDGY就不行,换了KUBUNTU还是不行。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-31 16:36 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
ifconfig:
代码:
eth1      Link encap:Ethernet  HWaddr 00:04:23:97:CE:38 
          inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::204:23ff:fe97:ce38/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:116 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:36006 (35.1 KiB)  TX bytes:2646 (2.5 KiB)
          Interrupt:11 Base address:0x4000 Memory:d0204000-d0204fff

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 b)  TX bytes:100 (100.0 b)

/etc/network/interfaces :
代码:
auto lo
iface lo inet loopback

auto eth1
iface eth1 inet static
address 192.168.1.3
network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp


我在使用电信ADSL,Modem不带路由功能,网线从Modem接入一个路由器(192.168.1.1,用该路由器拨号并且一直连线),然后再从该路由器接入我房间的无线路由(192.168.1.2)的WLan口,然后我的计算机就通过该路由接入该网段局域网(我将我的计算机IP设置为192.168.1.3,默认网关设置为192.168.1.1,DNS设置为192.168.1.1,子网掩码设置为255.255.255.0)。
我想既然我能够ping通192.168.1.1就应该能够ping通外网啊,如果是DNS的问题,应该只是适用域名才会出错。纳闷...... :?
BTW: 以前版本图形配置界面基本上都需要输入密码,但是Edge的网卡配置图形界面程序就没有要求输入密码。各位安装了Edge的朋友,你们的情况也是这样么?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-31 16:46 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你骂网管去吧。网关那里的机器也有关系的阿。


_________________
● 鸣学


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-31 16:58 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
你骂网管去吧。网关那里的机器也有关系的阿。

不懂。 :lol: 我就是“网管”啦 , 路由器都是我设置的,计算机也是...... 您是指电信那边?可是在Dapper的时候没问题哦。我想还是我没有设置好的缘故吧 :cry:


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-10-31 19:00 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
你的dns怎么能设置1。无线的网关也一般省略掉的。路由器里面也看看,是不是设置了什么规则和你的要求冲突的。


_________________
● 鸣学


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-10-31 19:23 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
你的dns怎么能设置1。无线的网关也一般省略掉的。路由器里面也看看,是不是设置了什么规则和你的要求冲突的。

我想路由器记录路由表,链接电信路由器太浪费时间,所以DNS server我都填写“192.168.1.1”,原来也是如此,一直用得好好的 :( (我想过填192.168.1.2,因为该路由性能更好,离我的电脑更近,可是这样就会不能够上网了,我也不解) 纳闷。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-11-01 16:15 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
为了准备解决这个问题(我准备打持久战 :twisted: ,也就是不急于解决)然后我在另外一个论坛发帖子问些网络基础知识:http://bbs.net130.com/showpost.php?p=1346173&postcount=3 如此贴中我所述
引用:
这个结论貌似和我在ubuntu平台下不能够上网一个症状,该不会就是这个原因吧
事实证明就是这个原因。网关和DNS server都应该设置为192.168.1.1(也就是离我远的普通路由器),而我却设置成了192.168.1.2(网关的设置修改/etc/network/interfaces这个文件,DNS的设置修改/etc/resolv.conf文件)
然后就搞定了 :) 我想图形界面配置工具不要求输入密码应该是个bug(难道就我的机器上如此么?) 然后按照这位网友 http://karronqiu.spaces.live.com/ 写的Edgy配置脚本进行配置。一切顺利。唯独字体没有配置好。然后我打开firefox浏览器(资源占用率显示100%),再启用fcitx输入法,于是gnome就崩溃了。然后我重启X,再次重复该操作。gnome再次崩溃。看来我是无法在浏览器里面输入中文了 -_-!
或许我该老老实实的用Dapper的(慢一些就慢一些,毕竟稳定而且是LTS),当初听说Edgy增加了许多特性,而且有许多网友在beta的时候都使用了(当时我考虑谨慎起见还是等到正式版释放再升级,我是对于特性和稳定性兼而有之的用户 :) ) ,所以我想别人用beta都没问题,到正式版释放我大可放心了。 现在感觉计算机真的是好复杂的工具哦 :cry:


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-11-01 18:36 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
终于还是换回了Dapper......


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-11-01 18:40 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
Edge平台fcitx和firefox冲突导致gnome-panel崩溃,系统收集的信息如下:
引用:
Memory status: size: 83755008 vsize: 0 resident: 83755008 share: 0 rss: 22458368 rss_rlim: 0
CPU usage: start_time: 1162369560 rtime: 0 utime: 182 stime: 0 cutime:168 cstime: 0 timeout: 14 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/gnome-panel'

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1225304400 (LWP 4478)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb762b323 in __waitpid_nocancel ()
from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7f231b6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3 <signal handler called>
#4 0xb35054f0 in ?? ()
#5 0xb34f3891 in _XimServerDestroy ()
from /usr/lib/X11/locale/common/ximcp.so.2
#6 0xb34e93a4 in _XimUnregisterFilter ()
from /usr/lib/X11/locale/common/ximcp.so.2
#7 0xb764ad44 in XFilterEvent () from /usr/lib/libX11.so.6
#8 0xb79b136d in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#9 0xb79b17bf in _gdk_events_init () from /usr/lib/libgdk-x11-2.0.so.0
#10 0xb7726802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#11 0xb77297df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#12 0xb7729b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#13 0xb7b28574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x08061d8c in main ()

Thread 1 (Thread -1225304400 (LWP 4478)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb762b323 in __waitpid_nocancel ()
from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7f231b6 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3 <signal handler called>
No symbol table info available.
#4 0xb35054f0 in ?? ()
No symbol table info available.
#5 0xb34f3891 in _XimServerDestroy ()
from /usr/lib/X11/locale/common/ximcp.so.2
No symbol table info available.
#6 0xb34e93a4 in _XimUnregisterFilter ()
from /usr/lib/X11/locale/common/ximcp.so.2
No symbol table info available.
#7 0xb764ad44 in XFilterEvent () from /usr/lib/libX11.so.6
No symbol table info available.
#8 0xb79b136d in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#9 0xb79b17bf in _gdk_events_init () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#10 0xb7726802 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#11 0xb77297df in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#12 0xb7729b89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#13 0xb7b28574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#14 0x08061d8c in main ()
No symbol table info available.
#0 0xffffe410 in __kernel_vsyscall ()


附件:
文件注释: 崩溃截图
6.10 crashed -_-!.png
6.10 crashed -_-!.png [ 84.32 KiB | 被浏览 5209 次 ]

页首
 用户资料  
 
15 楼 
 文章标题 : fcitx输入法问题已解决
帖子发表于 : 2007-02-22 1:04 
头像

注册: 2005-10-05 11:31
帖子: 775
送出感谢: 0 次
接收感谢: 0 次
这次升级到Edgy成功了 :D
Palm同步的问题也得到了解决。
fcitx输入法的问题依旧,换成使用SCIM输入法后好俄。
:D

参见: http://fengluu.blogspot.com/2007/02/dapperedgy.html

update: fcitx输入法问题已解决,参见 http://forum.ubuntu.org.cn/viewtopic.php?p=239341#239341


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译