[问题]升级到6.10之后的若干问题

系统错误报告和讨论
回复
if
帖子: 62
注册时间: 2006-09-12 1:25
送出感谢: 0
接收感谢: 0

[问题]升级到6.10之后的若干问题

#1

帖子 if » 2006-10-30 18:48

照着某置顶精华贴做的,升级失败,症状如下:
1.grub异常,root=/dev/sd* 那里变成了root=UUID=XXXXXXXX (X是乱码) 手工改回来后,启动成功
2.X不能启动
3.bash不正常,$前应该有东西的,更新后没了,而且不能sudo,没有命令历史,有时解析命令不正常,例如ls,有时会报告找不到该命令,有时正常
4.想重新装回6.06也不成了,用硬盘安装,安装程序识别不到分区,显示的是一个没有内容的空盘。用dubuntu的盘引导,毛病还是一样。换成gentoo的盘也看不到,用diskgen看,还是看不到分区。但是windows可以正常启动,在livecd里可以mount,可以用fdisk。我就搞不明白这到底是怎么了?!升个级也能生成这样!!
:em92
本人用tcl的K40笔记本,sata硬盘,915GM集成显卡
望达人指点
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-10-30 20:59

换了血阿。xinit都被换了。1,2,3都是可以搞好的。1不是问题,可能和你的分区问题有关。2可以卸载xorg,再重新安装,可以先试试只卸载重装显卡驱动。3。找个.bashrc就是。
● 鸣学
头像
sysnotdown
帖子: 710
注册时间: 2006-09-24 22:43
送出感谢: 0
接收感谢: 0

#3

帖子 sysnotdown » 2006-10-30 22:42

从来不敢直接升级,也不敢硬盘装,这种偏门的东西相信ubuntu也没有精力去详细测试,老实点,刻盘重装最稳妥,但是,这样我也是装了2次。
if
帖子: 62
注册时间: 2006-09-12 1:25
送出感谢: 0
接收感谢: 0

#4

帖子 if » 2006-10-31 23:32

楼上所言极是!不该直接升级的。
我已经重装了,123的解决方案没机会试了。4其实是因为分区过多所致,sda1-sda8都用上了,升级触发了问题,导致livecd不识别硬盘分区。用fdisk删掉若干分区后恢复正常。现在已经回到6.06了。
顺便赞一个,这个版现在好热闹呀 :em06
头像
jarlyyn
论坛版主
帖子: 4671
注册时间: 2006-04-12 18:54
送出感谢: 0
接收感谢: 6 次
联系:

#5

帖子 jarlyyn » 2006-11-01 0:37

硬盘装还是不错的

升级……我是不敢
dajian0509
帖子: 397
注册时间: 2006-10-13 18:53
来自: 湖南农业大学
送出感谢: 0
接收感谢: 0

#6

帖子 dajian0509 » 2006-11-01 9:56

那等比较稳定的版本出来再升级吧 !
头像
守望伊人
帖子: 189
注册时间: 2006-05-18 18:24
来自: 四川广安
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 守望伊人 » 2006-12-12 17:43

没什么啊,我是菜乌,一路从5.10升级过来的。不过每次升级前都要多看看论坛里的帖子。
回复

回到 “Ubuntu错误报告”