6.10下vmware安装问题

系统错误报告和讨论
回复
yrp
帖子: 32
注册时间: 2006-10-02 13:47
送出感谢: 0
接收感谢: 0
联系:

6.10下vmware安装问题

#1

帖子 yrp » 2006-10-31 12:24

在一些准备工作完了之后,即运行 sudo apt-get install build-essential linux-headers-`uname -r` xinetd gcc-4.0 g++-4.0
后,再装vm,装到最后,,出现
Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config2/vmmon-only'
make -C /lib/modules/2.6.17-10-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.17-10-generic'
CC [M] /tmp/vmware-config2/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config2/vmmon-only/linux/driver.h:20,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:49:
/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /tmp/vmware-config2/vmmon-only/linux/driver.h:20,
from /tmp/vmware-config2/vmmon-only/linux/driver.c:49:
/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:60: error: conflicting types for ‘poll_initwait’
include/linux/poll.h:62: error: previous declaration of ‘poll_initwait’ was here
/tmp/vmware-config2/vmmon-only/linux/driver.c:145: warning: initialization from incompatible pointer type
/tmp/vmware-config2/vmmon-only/linux/driver.c:149: warning: initialization from incompatible pointer type
make[2]: *** [/tmp/vmware-config2/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config2/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.17-10-generic'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config2/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.

没装成功,在终端下运行vmware,
b$ vmware
vmware is installed, but it has not been (correctly) configured
for this system. To (re-)configure it, invoke the following command:
/usr/bin/vmware-config.pl.

请问有人已经在6.10下成功装好vm了么
iakuf
帖子: 227
注册时间: 2006-10-23 7:58
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 iakuf » 2006-10-31 12:31

可能要下最新的那个vm才可以
xki
帖子: 15
注册时间: 2007-01-11 16:41
送出感谢: 0
接收感谢: 0

#3

帖子 xki » 2007-01-15 22:11

顶一下,我也遇到这样的问题了
dajian0509
帖子: 397
注册时间: 2006-10-13 18:53
来自: 湖南农业大学
送出感谢: 0
接收感谢: 0

#4

帖子 dajian0509 » 2007-01-16 9:51

偶的水平太差了
装了两个月了
都装不上啊 !
sanz
帖子: 1008
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

#5

帖子 sanz » 2007-01-18 20:10

偶是装的D版的WS,也是千辛万苦,最后还是成功了。楼主不要气馁啊!总归会解决的
回复

回到 “Ubuntu错误报告”