当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 键盘识别错误
帖子发表于 : 2006-11-08 14:23 

注册: 2006-06-13 21:30
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我的单引号键识别有问题,单引号每次都必须按两下,在telnet后无法识别,双引号按出来的是¨,似乎在很多编辑器中都无法识别出来。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-11-08 16:31 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
所有输入的地方都这样?键盘设置那里是什么型号啊。
xev测试下看看,如果按这个键的时候,可以看到正常键值以及正常的字符不。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-11-08 18:52 
头像

注册: 2006-05-12 0:52
帖子: 781
地址: Chongqing China
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题,DAPPER就没这个问题。我选的是US ENGLISH INTERNATINAL WITH DEAD KEY。
不知道楼选的哪个,我选了很多个似乎都一样。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-11-08 19:47 

注册: 2006-06-13 21:30
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我也选的是US ENGLISH INTERNATINAL WITH DEAD KEY
之前以为是scim的问题,后来发现卸载了scim问题依旧。
请教一下xev是什么?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-11-08 20:07 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
测试键盘鼠标的。


_________________
● 鸣学


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-11-10 12:04 

注册: 2006-06-13 21:30
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
这个是我用xev的输出,我只点了一下¨´¨键
KeyPress event, serial 29, synthetic NO, window 0x2800001,
root 0x50, subw 0x0, time 3490036934, (120,128), root:(125,177),
state 0x0, keycode 48 (keysym 0xfe51, dead_acute), same_screen YES,
XLookupString gives 2 bytes: (c2 b4) "´"
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

KeyRelease event, serial 29, synthetic NO, window 0x2800001,
root 0x50, subw 0x0, time 3490036977, (120,128), root:(125,177),
state 0x0, keycode 48 (keysym 0xfe51, dead_acute), same_screen YES,
XLookupString gives 2 bytes: (c2 b4)"´"
XFilterEvent returns: False

我只按了一下



这是双引号的输出:

KeyPress event, serial 29, synthetic NO, window 0x2c00001,
root 0x50, subw 0x0, time 3490207231, (379,112), root:(389,209),
state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
XLookupString gives 0 bytes:
XmbLookupString gives 0 bytes:
XFilterEvent returns: False

KeyPress event, serial 29, synthetic NO, window 0x2c00001,
root 0x50, subw 0x0, time 3490211492, (379,112), root:(389,209),
state 0x1, keycode 48 (keysym 0xfe57, dead_diaeresis), same_screen YES,
XLookupString gives 2 bytes: (c2 a8) "¨"
XmbLookupString gives 0 bytes:
XFilterEvent returns: False
注意我用红色标注的部分,我的双引号输出和系统的明显不一样


这是为什么??


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-11-10 12:30 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
'的是对的,一次按下,一次松开,2个事件。如果软件里面要按2次,可能是系统的问题,就像吃掉了第一个键码。这个,我没办法帮忙。

"和你1楼的说明一样。看来这个按键在xmodmap的配置文件里面就不对了。可以换键盘测试吗。如果不能,就只能看man xmodmap了。里面提到是配置文件比较罗嗦。不过,就是修改一个文件。如下链接。

http://forum.ubuntu.org.cn/viewtopic.ph ... ht=xmodmap 这是我以前的笔记。


_________________
● 鸣学


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-11-10 13:31 

注册: 2006-06-13 21:30
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
感谢你的帮助,另外在提供一点线索,“的ascii码应该是22(HEX),而我的打出来尽然是A8(HEX),oh my god


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-11-10 22:04 
头像

注册: 2006-05-12 0:52
帖子: 781
地址: Chongqing China
送出感谢: 0 次
接收感谢: 0 次
这个问题不能解决吗


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-11-10 23:13 
头像

注册: 2005-10-25 11:15
帖子: 1016
送出感谢: 0 次
接收感谢: 1
肯定是键盘配置的问题,估计不应该选US ENGLISH INTERNATINAL WITH DEAD KEY,试试别的。
看看这个能搞定不
代码:
xmodmap -e "keycode 48 = apostrophe quotedbl"

另外可以试试把/etc/xorg.conf中键盘配置一段改成这样
代码:
Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"
        Option          "XkbOptions"    "lv3:ralt_switch"
EndSection


12/20注:经我朋友测试,上面xmodmap可以解决这个问题,如果要重启之后依然保留这个设定,可以用
代码:
echo "keycode 48 = apostrophe quotedbl" >~/.Xmodmap


_________________
hreiser@oakland:~$ killall -9 wife
police@oakland:~$ sudo find / -user hreiser
court@oakland:~$ sudo mv /home/hreiser /jail/
court@oakland:~$ sudo usermod -d /jail/hreiser -s "/usr/sbin/chroot /jail/" hreiser


最后由 laborer 编辑于 2006-12-20 15:07,总共编辑了 1 次

页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-11-11 11:12 
头像

注册: 2006-05-12 0:52
帖子: 781
地址: Chongqing China
送出感谢: 0 次
接收感谢: 0 次
xorg.conf里的设置是一样的。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-11-11 11:25 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
系统-首选项-键盘,找到合适的布局,某些键的映射不要弄错。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 键盘识别错误
帖子发表于 : 2006-11-11 13:01 

注册: 2006-05-17 18:40
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我的也是这样,奇怪了,以前的6.06里面没有这样啊。
Reeves1016 写道:
我的单引号键识别有问题,单引号每次都必须按两下,在telnet后无法识别,双引号按出来的是¨,似乎在很多编辑器中都无法识别出来。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-10-30 13:52 

注册: 2007-09-14 17:45
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的也遇到过这样的问题,后来自己摸索着解决了,我的是SCIM的问题,如果在 SCIM中全局设置没有选对键盘类型的话,就会出这个问题,改成英语(美国)就好了些,不过有时候还会出现,不知道怎么回事


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-03-29 11:17 
头像

注册: 2007-06-11 0:21
帖子: 27
地址: Shenzhen
送出感谢: 0 次
接收感谢: 0 次
zhuqin_83 写道:
系统-首选项-键盘,找到合适的布局,某些键的映射不要弄错。


我用的是kubuntu,scim和fcitx一起装着,之前也是不能正常输入的,后来这么做就搞定了:


K菜单——>系统设置——>Regional & Language——>键盘布局——>启用键盘布局——>选择“美式英语”


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译