ubuntu 6.10 没有apt-get 怎么办?

系统错误报告和讨论
回复
seygogo
帖子: 3
注册时间: 2013-01-22 12:17
系统: windows xp
送出感谢: 0
接收感谢: 0

ubuntu 6.10 没有apt-get 怎么办?

#1

帖子 seygogo » 2013-02-01 22:00

单位一台网络存储服务器,系统是ubuntu 6.10 server ,但是厂商做了简化,缺省很多命令包括apt-get dpkg 等常用命令,现在想安装软件应该如何操作,请各位大侠支招

我试了下从12.04系统中拷贝apt-get dpkg 到/usr/bin中,但是运行会出错
用root登录
1.执行:sudo apt-get update
错误:apt-get: error while loading shared libraries: libapt-pkg.so.4.12: cannot open shared object file:No such file or directory
2.执行 dpkg
错误:dpkg: /lib/tls/i686/cmov/libc.so.6: version 'GLIBC_2.11 dpkg)
dpkg: /lib/tls/i686/cmov/libc.so.6: version 'GLIBC_2.8 dpkg)
dpkg: /lib/tls/i686/cmov/libc.so.6: version 'GLIBC_2.6 dpkg)
头像
475929257
帖子: 171
注册时间: 2009-01-12 20:26
送出感谢: 1 次
接收感谢: 0

Re: ubuntu 6.10 没有apt-get 怎么办?

#2

帖子 475929257 » 2013-02-01 22:11

我去,现在还有6.10的源么……
seygogo
帖子: 3
注册时间: 2013-01-22 12:17
系统: windows xp
送出感谢: 0
接收感谢: 0

Re: ubuntu 6.10 没有apt-get 怎么办?

#3

帖子 seygogo » 2013-02-04 0:08

475929257 写了:我去,现在还有6.10的源么……
有没有源不是问题,关键是怎么把那些命令装进去
libreoffice3writer
帖子: 128
注册时间: 2012-12-20 15:39
系统: Debian sid
送出感谢: 0
接收感谢: 4 次

Re: ubuntu 6.10 没有apt-get 怎么办?

#4

帖子 libreoffice3writer » 2013-02-04 0:19

要安装apt-get的话(尤其是那么老的), 你需要很旧的apt-get的源码, 还有编译这个源码的很旧的工具链(比如gcc, libc等).
当然, 假如你万幸之中, 编译成功了, 但你从哪儿找6.10的软件源呢???
6.10是7 年前的产品了吧.
当时的linux kernel还是2.4吧.
我个人认为, 楼主目前掌握的知识还不能完全解决编译程序时遇到的诸多问题.

建议楼主还是算了吧 :em20

网络服务器不是网络文件存储的吗? 还要安装其它软件??
当然, 如果服务器性能还可以的话(不要太差就行), 可以直接为它更换新的linux系统, 比较现代的系统. 比如Debian stable或者CentOS的, 当然, UI界面是没必要安装的, 这样的话, 维护起来也方便.
seygogo
帖子: 3
注册时间: 2013-01-22 12:17
系统: windows xp
送出感谢: 0
接收感谢: 0

Re: ubuntu 6.10 没有apt-get 怎么办?

#5

帖子 seygogo » 2013-02-06 20:44

libreoffice3writer 写了:要安装apt-get的话(尤其是那么老的), 你需要很旧的apt-get的源码, 还有编译这个源码的很旧的工具链(比如gcc, libc等).
当然, 假如你万幸之中, 编译成功了, 但你从哪儿找6.10的软件源呢???
6.10是7 年前的产品了吧.
当时的linux kernel还是2.4吧.
我个人认为, 楼主目前掌握的知识还不能完全解决编译程序时遇到的诸多问题.

建议楼主还是算了吧 :em20

网络服务器不是网络文件存储的吗? 还要安装其它软件??
当然, 如果服务器性能还可以的话(不要太差就行), 可以直接为它更换新的linux系统, 比较现代的系统. 比如Debian stable或者CentOS的, 当然, UI界面是没必要安装的, 这样的话, 维护起来也方便.
谢谢
回复

回到 “Ubuntu错误报告”