当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : dpkg:依赖关系问题使得 libtinfo-dev:i386 的配置工作不能继续
帖子发表于 : 2013-05-09 0:01 

注册: 2010-09-29 18:47
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
dpkg:处理 libtinfo-dev:i386 (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 libncurses5-dev:i386 的配置工作不能继续:
libncurses5-dev:i386 依赖于 libncurses5 (= 5.9-1ubuntu5.1);然而:
系统中 libncurses5:i386 的版本为 5.9-4。
libncurses5-dev:i386 依赖于 libtinfo-dev (= 5.9-1ubuntu5.1);然而:
软件包 libtinfo-dev:i386 尚未配置。
libncurses5-dev:i386 依赖于 ncurses-bin (= 5.9-1ubuntu5.1);然而:
系统中 ncurses-bin 的版本为 5.9-4。
未安装软件包 ncurses-bin:i386。
dpkg:处理 libncurses5-dev:i386 (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openssh-server:i386 的配置工作不能继续:
openssh-server:i386 依赖于 openssh-client (= 1:5.8p1-7ubuntu1);然而:
系统中 openssh-client 的版本为 1:5.9p1-5ubuntu1.1。
libssl1.0.0:i386 (1.0.1-4ubuntu5.9)破坏 openssh-server (<< 1:5.9p1-4) 并且 已安装。
将被配置的 openssh-server:i386 的版本为 1:5.8p1-7ubuntu1。
libssl1.0.0 (1.0.1-4ubuntu5.9)破坏 openssh-server (<< 1:5.9p1-4) 并且 已安装。
将被配置的 openssh-server:i386 的版本为 1:5.8p1-7ubuntu1。
dpkg:处理 openssh-server:i386 (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libtinfo-dev:i386
libncurses5-dev:i386
openssh-server:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ubuntu12.04 x64安装如下i386的软件包后出现的如上情况
libncurses5_5.9-1ubuntu5.1_i386.deb
libncurses5-dev_5.9-1ubuntu5.1_i386.deb
libncursesw5_5.9-1ubuntu5.1_i386.deb
libtinfo5_5.9-1ubuntu5.1_i386.deb
libtinfo-dev_5.9-1ubuntu5.1_i386.deb
ncurses-bin_5.9-1ubuntu5.1_i386.deb
openssh-server_1%3a5.8p1-7ubuntu1_i386.deb
ssh-import-id_2.5-0ubuntu2_all.deb

尝试了apt-get -f install及update都无效,且一进入“Ubuntu软件中心“就提示修复软件包,但又无法修复,卸载及安装其他软件时报错。请问该这种情况该如何解决?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译