当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : ??升级7.04后普遍的启动问题,烦高手出招??
帖子发表于 : 2007-04-22 8:13 

注册: 2007-04-22 7:54
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
很早以前就常听说ubuntu升级问题多,昨天真的体验了……

6.10官方网络升级7.04以后启动就不行了,grub仍然可以引导,但每次选择ubuntu kernel 2.6.20-15-generic以后都会跳出:

/bin/sh:can't access tty;job control turned off

中英文bbs上都查过,有成功解决之人士说是因为"root=UUID="指向的是交换区,但是我自己改成"root=/dev/hda?"(我的是hda8……)以后倒是解决了该错误信息问题,不过启动画面就永远停留在第一个橙色格,然后便没反应了……甚是奇特。

后来发现小弟遇到的问题仿佛还困扰着全球各地亿万的ubuntu同胞,所以请高手/ubuntu论坛技术人员务必出山,写一个比较全面、详细的解答,造福亿万狂搜Google无果的劳苦大众啊!!!!!!!!!!!!!!

在此先谢过哪!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-22 9:29 

注册: 2007-04-22 7:54
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
另外如需要任何log都请讲,小弟全力配合


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-22 19:22 
头像

注册: 2006-11-25 13:54
帖子: 27
地址: 福建
送出感谢: 0 次
接收感谢: 0 次
取消启动参数"splash",看看具体是卡在哪里了


_________________
满天相思雨
--------------------------
AMD 4400+
NVIDIA 8600 gs
DDR2 4G
SUMSUNG 20'
SATA 200G
UBUNTU 9.04
一点浩然气@夏天


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-22 19:50 
头像

注册: 2006-05-10 16:01
帖子: 259
地址: 安徽合肥
送出感谢: 0 次
接收感谢: 0 次
我也是同样的问题,折腾了半天,还是没有办法解决,请高人尽快指点,焦急等待。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-22 19:55 
头像

注册: 2006-05-10 16:01
帖子: 259
地址: 安徽合肥
送出感谢: 0 次
接收感谢: 0 次
这个bug,我在全互联网搜了个底朝天,未见可行的解决办法,发狂怒骂无人理,悲哀,ubuntu的悲剧真在上演。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-22 20:32 
头像

注册: 2007-03-01 21:04
帖子: 283
地址: 福建
送出感谢: 0 次
接收感谢: 0 次
将/boot/grub/menu.lst中的启动项splash 和quiet 都取消掉,就可以看到启动过程了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-22 20:32 
头像

注册: 2007-03-01 21:04
帖子: 283
地址: 福建
送出感谢: 0 次
接收感谢: 0 次
将/boot/grub/menu.lst中的启动项splash 和quiet 都取消掉,就可以看到启动过程了。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-22 21:00 
头像

注册: 2006-05-10 16:01
帖子: 259
地址: 安徽合肥
送出感谢: 0 次
接收感谢: 0 次
现在连系统都进不去,怎么修改/boot/grub/menu.lst中的启动项,是这样吗:

grub>cat /boot/grub/menu.lst


??????


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-22 21:50 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
wangguangping 写道:
现在连系统都进不去,怎么修改/boot/grub/menu.lst中的启动项,是这样吗:

grub>cat /boot/grub/menu.lst


??????


recovery mode


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-22 22:19 
头像

注册: 2006-05-10 16:01
帖子: 259
地址: 安徽合肥
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
wangguangping 写道:
现在连系统都进不去,怎么修改/boot/grub/menu.lst中的启动项,是这样吗:

grub>cat /boot/grub/menu.lst


??????


recovery mode


呵呵,这个早试过啦,不行,中途也卡住了,我换了个ps/2鼠标重装了一次,问题依旧,基本可以排除原先使用usb鼠标的问题,还有什么可能吗?我几乎全试过了,唉----

看来再找个live cd版安装一下,不知运气如何?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-23 14:25 

注册: 2007-04-17 0:42
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
wangguangping 写道:
现在连系统都进不去,怎么修改/boot/grub/menu.lst中的启动项,是这样吗:

grub>cat /boot/grub/menu.lst


??????

grub启动时可以直接修改启动命令项,应该是按e键的(我没仔细看)。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-04-23 18:18 

注册: 2006-10-30 0:08
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
在grub中选择启动项时,按ESC键(键盘上左上角)。弹出对话框,选YES,进入字符模式。
将光标移动到你需要的启动的系统上,按‘e‘键(edit,中文是编辑的意思)。
在新出现的页面上将光标停在有boot那一项上,按‘e'键,然后在新的页面里编辑文本,也就是将splash quiet那段去掉,然后按‘Enter‘键结束编辑,并回到上层页面(即选择boot那一页)。
按‘b'键(boot,中文是启动的意思),即可启动。
此时可以看到启动的具体信息。

如果启动后出现提示
引用:
/bin/sh:can't access tty;job control turned off

你可以利用上述方法将boot那一项中的,root=/dev/sda类似的那一段改成root=UUID=(等号后接你的boot分区的UUID值)。如果不知道UUID值,可以在启动出现提示/bin/sh:can't access tty;job control turned off 后,用命令
代码:
fdisk -l

或者
代码:
ls -l /dev/disk/by-uuid

查看boot分区的UUID值。

如果出现和磁盘有关的提示,例如读地址超出磁盘空间(具体的英文提示信息不记得了)。那是因为2.6.20-15.25内核(我是从6.10升级到7.04的,对于用光盘安装的7.04是什么样的内核不了解)对某些磁盘控制器支持不完善,我的JMiron磁盘控制器就有这个问题,可以更新到2.6.20-15.27内核或者将硬盘接到其他的磁盘控制器控制的接口上,或许可以解决这个问题。至于在你所处的情况下如何安装新的内核,我不了解(我当时除了2.6.20-15.25内核外,还有一个老内核)。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-04-24 20:33 

注册: 2006-12-16 13:07
帖子: 53
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
出现splash时,按ALT+F1。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-05-09 22:02 

注册: 2006-08-16 17:04
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
这里解决的很好 http://forum.ubuntu.org.cn/about52574.html


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-06-02 17:29 

注册: 2006-02-12 22:04
帖子: 39
地址: 武汉
送出感谢: 0 次
接收感谢: 0 次
我也出现同样的问题了,去掉参数看到的是
cp:unable open '/root/var/log':no such file or dir. 这个是第一行的错误,后面还有类似的访问/root路径报错的问题。
ls了一下,root下面是空的
有人知道到底怎么解决这个问题么,ubuntu用了三四个版本了,第一次遇到这么让人郁闷的问题!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译