当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [分享]解决7.04不出声和耳机不出声问题
帖子发表于 : 2007-04-29 15:34 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
我是COMPAQ V3159AU的本本,在6.10下完全正常,但是现在用7.04却死不出声~~~偶滴天~~~声卡都认出来了 HD AUDIO,但就是没声~~~还有个巨神奇的现象,昨天的某次开机后,居然有声因了,但是重启一下又没声了~~~
我看到论坛上也有不少人用和我一个型号的本本~~有把声卡问题解决了的么?出来支一声啊。 :cry:

-----------------------------------------------------------------------------------------------------------------------------------------------------------
So far problem has been solved~~If you have met the same problem as me~~Please do as follows【PS:the RC2 pakage has also solved the problem that ear-phone can't work well on some PCs】:

*

Install the required tools

sudo apt-get install build-essential ncurses-dev

*

Install your kernel headers

sudo apt-get install linux-headers-`uname -r`

*

Download the latest version of alsa from [WWW] Alsa project (driver, library, and utils) to a directory (eg. /home/naaman/installers/alsa)
o

[WWW] alsa-driver:http://www.alsa-project.org/alsa/ftp/driver/
o

[WWW] alsa-lib:http://www.alsa-project.org/alsa/ftp/lib/
o

[WWW] alsa-utils:http://www.alsa-project.org/alsa/ftp/utils/
*

Setup installation directories

sudo mkdir -p /usr/src/alsa
cd /usr/src/alsa
sudo cp /home/naaman/installers/alsa/* .
sudo tar xjf alsa-driver-1.0.14rc2.tar.bz2
sudo tar xjf alsa-lib-1.0.14rc2.tar.bz2
sudo tar xjf alsa-utils-1.0.14rc2.tar.bz2

*

Compile and install alsa-driver

cd alsa-driver-1.0.14rc2
sudo ./configure --with-cards=hda-intel
sudo make
sudo make install

*

Compile and install alsa-lib

cd ../alsa-lib-1.0.14rc2
sudo ./configure
sudo make
sudo make install

*

Compile and install alsa-utils

cd ../alsa-utils-1.0.14rc2
sudo ./configure
sudo make
sudo make install

*

Reboot

Manually specify which flavor you are using

If your sound still doesn't work after installing the latest alsa, it is likely that it was unable to autodetect your flavour.

*

Edit the file /etc/modprobe.d/alsa-base

gksudo gedit /etc/modprobe.d/alsa-base

*

Add the following line to the file, replacing '3stack' with your flavor (see below)

options snd-hda-intel model=3stack

*

Reboot


Good Luck to u all!!


_________________
Nanjing University of Post&Telecom.
----------------------------------------------
Powered by Compaq V3159AU
--------------------------------
Home Page:www.alexgao.com
Mail:mail@alexgao.com


最后由 alexgao 编辑于 2007-05-15 12:59,总共编辑了 4 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-04-29 15:42 

注册: 2005-12-14 4:37
帖子: 176
地址: 十堰
送出感谢: 0 次
接收感谢: 0 次
1:打开音量控制,看看Front最下边那个喇叭是不是断开了(也就有个红色的X,如果有X,就点一下把它去掉)。
2:再看看PCM是不是断开了(同上)。
3:在右上角喇叭处点右键-首选项,换成REALTEK再试试。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-04-29 15:47 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
一切都正常~~~所有的迹象貌似都表明声卡正努力的工作着~~~可是丫就是不哼声


_________________
Nanjing University of Post&Telecom.
----------------------------------------------
Powered by Compaq V3159AU
--------------------------------
Home Page:www.alexgao.com
Mail:mail@alexgao.com


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:00 

注册: 2005-12-14 4:37
帖子: 176
地址: 十堰
送出感谢: 0 次
接收感谢: 0 次
那我能想到的只能试试这个办法了:
代码:
sudo killall esd
sudo cp /etc/esound/esd.conf /etc/esound/esd.conf_backup
sudo gedit /etc/esound/esd.conf

找到此段叙述

...
auto_spawn=0
spawn_options=-terminate -nobeeps -as 5
...

修改成

auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
保存修改,然后:
sudo apt-get install libesd-alsa0
sudo gedit /etc/asound.conf

将一下叙述加入新文档内:

pcm.card0 { type hw card 0 }

pcm.!default { type plug slave.pcm "dmixer" }

pcm.dmixer { type dmix ipc_key 1025 slave { pcm "hw:0,0" period_time 0 period_size 2048 buffer_size 32768 rate 48000 } bindings { 0 0 1 1 } }


最后一步:
sudo ln -fs /usr/lib/libesd.so.0 /usr/lib/libesd.so.1


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:03 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
貌似我已经干过这事了~~~~~还是么用


_________________
Nanjing University of Post&Telecom.
----------------------------------------------
Powered by Compaq V3159AU
--------------------------------
Home Page:www.alexgao.com
Mail:mail@alexgao.com


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:06 

注册: 2005-12-14 4:37
帖子: 176
地址: 十堰
送出感谢: 0 次
接收感谢: 0 次
你要这样干过那就安我开始说的第三个就能解决(只要你开始杀过声音,那之能按下边我说的办法才可以有声音,相当年我就是这样,其实现在的7.04不需要再设定GNOME声音为优先级了)。
就是在喇叭那里点右键----首先项,更换一下设备,然后再看PCM和FRONT,之要没有红X就应该应该有声音了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:15 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
我把设备换成了oss mixer 就一个volume选项~~是满的~~原来的HDA NVIdia设备所有的我也都是调成最高~~可是都没用~~~我怀疑是驱动不稳定~~~在beta版的时候,先开始也是没声音,后来重启了几次就一直有声音了。不过换成正是版后就一直没声音,但是昨天突然发神经的有了声音,重启后就再也没声了~~~~郁闷 :oops:


_________________
Nanjing University of Post&Telecom.
----------------------------------------------
Powered by Compaq V3159AU
--------------------------------
Home Page:www.alexgao.com
Mail:mail@alexgao.com


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:18 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
原来我的esd.conf是空的~~我后来加上auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
spawn_wait_ms=100
# default options are used in spawned and non-spawned mode
default_options=


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:22 

注册: 2005-12-14 4:37
帖子: 176
地址: 十堰
送出感谢: 0 次
接收感谢: 0 次
有volume就对了!然后你再双击右上角的喇叭,这时就出来音量控制了,你点“编辑----首选项,然后你找PCM和RONT,把这两个打上勾。这样你就可以在音量控制那里看到PCM和RONT了,看下边是不是有红色的X了!如果没X就调那两项。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:36 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
我后来照你的二楼的代码重新修改了一遍~~怎么原来的HDA NVdia设备找不到了~~只剩下OSS Mixer~~而且打开音乐时,播放器提示:Couldn't open audio.

Please check that:
1. You have the correct output plugin selected.
2. No other programs is blocking the soundcard.
3. Your soundcard is configured properly.

汗~~怎么办啊???


_________________
Nanjing University of Post&Telecom.
----------------------------------------------
Powered by Compaq V3159AU
--------------------------------
Home Page:www.alexgao.com
Mail:mail@alexgao.com


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:40 

注册: 2005-12-14 4:37
帖子: 176
地址: 十堰
送出感谢: 0 次
接收感谢: 0 次
晕了!那我也没办法了!要不就文文别人,是在没人回答不如重装一遍系统。下次不要再设定GNOME为优先级了,7.04和6.10有点不同。就像文泉驿字体,我自己重装了6遍系统才摸清楚怎样不让系统像蜗牛一样慢。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:41 

注册: 2007-04-09 10:20
帖子: 71
送出感谢: 0 次
接收感谢: 0 次
http://forum.ubuntu.org.cn/viewtopic.php?t=50865

按照这个帖子里面的做,没有一点问题。安装完后默认设置是静音的,要自己打开声音。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:45 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
偶滴系统7.04截至今天已经是第十六次重装了


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-04-29 16:51 

注册: 2005-12-14 4:37
帖子: 176
地址: 十堰
送出感谢: 0 次
接收感谢: 0 次
严重同情! :wink:
不过下此装好系统之后你就现调声音,别的软件别急着安装,因为我也不敢排除会不会与别的什么有冲突。你装好后按我开始说的方法还是没声音就再来论坛上发帖说一声。记住,这次别杀掉默然的声音了!!!


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-04-29 17:04 
头像

注册: 2007-04-12 16:47
帖子: 47
地址: Nanjing University of Post&Telecommunication
送出感谢: 0 次
接收感谢: 0 次
pcm.card0 { type hw card 0 }

pcm.!default { type plug slave.pcm "dmixer" }

pcm.dmixer { type dmix ipc_key 1025 slave { pcm "hw:0,0" period_time 0 period_size 2048 buffer_size 32768 rate 48000 } bindings { 0 0 1 1 } }

最后一步:
sudo ln -fs /usr/lib/libesd.so.0 /usr/lib/libesd.so.1



-------------这一段是通用的么?貌似我就是用了这一段后导致原来的声卡认不出来了~~有没有什么补救方法?我原来
pcm.dmixer { type dmix ipc_key 1025 slave { pcm "hw:0,0" period_time 0 period_size 2048 buffer_size 32768 rate 48000 }这一段和你的代码不完全相同的。 这一段是干什么用的?


_________________
Nanjing University of Post&Telecom.
----------------------------------------------
Powered by Compaq V3159AU
--------------------------------
Home Page:www.alexgao.com
Mail:mail@alexgao.com


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译