当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享][问题]7.04中新出现的某些eps文件无法打开的问题及解决方案
帖子发表于 : 2007-05-10 12:19 
头像

注册: 2005-06-30 15:46
帖子: 2245
地址: 成都
送出感谢: 0 次
接收感谢: 0 次
一个叫jalview的java程序生成的eps文件, 6.10 时打开毫无问题。升级后,无论用gv、evince、xdvi等软件打开都是cpu 100%,内存、swap狂升,系统狂慢

查了一下,这几个软件后台用的都是gs,而又是gs-esp版,直接在命令行用gs-esp打开这个文件显示

引用:
ESP Ghostscript 815.04 (2007-03-14)
Copyright (C) 2004 artofcode LLC, Benicia, CA. All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Can't find (or can't open) font file /usr/share/gs-esp/8.15/Resource/Font/sansserif.plain.
Can't find (or can't open) font file sansserif.plain.
Querying operating system for font files...


搜了一下,的确存在bug
https://bugs.launchpad.net/ubuntu/+source/gs-esp/+bug/75894

https://bugs.launchpad.net/ubuntu/+source/gs-esp/+bug/98526

解决方案也找到了,换gpl版的gs

代码:
sudo apt-get install gs-gpl
sudo update-alternatives --cofngi gs


选择gpl就ok了。

直接删除gs-esp大概是不行的。


_________________
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译