当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu7.04为何总会自动挂载win分区?
帖子发表于 : 2007-05-10 18:41 

注册: 2007-03-12 13:48
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我已经修改fstab文件,把win分区的mount项删了,但系统开机后却还是会在/media目录下建立一些以win分区的label名为名的目录,然后将win分区分别挂载上。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-10 19:45 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
这个不太可能吧

你确定fstab里面的都删了??


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-10 20:21 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
gconf-editor里面的nautilus里面找。搜索mount也可以


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-11 9:25 

注册: 2007-03-12 13:48
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
这是我的fstab内容:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda11
UUID=259db0f8-9e7f-4d6c-9935-69f7610fb3d9 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda9
UUID=22357c6b-63c5-4ba7-bc4a-e945ddd2b1a2 /boot ext3 defaults 0 2
# /dev/sda7
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=zh_CN.utf8,umask=007,gid=46 0 0
# /dev/sda10
UUID=a7fabbd2-1621-4ee1-b3f0-a37b8eef6347 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0


这是开机后mtab内容:
/dev/sda11 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-15-generic/volatile tmpfs rw 0 0
/dev/sda9 /boot ext3 rw 0 0
/dev/sda7 /media/sda7 fuseblk rw,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sda6 /media/DATA vfat rw,nosuid,nodev,shortname=mixed,uid=0,utf8,umask=077 0 0
/dev/sda8 /media/DRIVER vfat rw,nosuid,nodev,shortname=mixed,uid=0,utf8,umask=077 0 0
/dev/sda5 /media/TOOL vfat rw,nosuid,nodev,shortname=mixed,uid=0,utf8,umask=077 0 0
/dev/sda1 /media/WINXP vfat rw,nosuid,nodev,shortname=mixed,uid=0,utf8,umask=077 0 0


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-05-11 18:11 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
引用:
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=zh_CN.utf8,umask=007,gid=46 0 0


这行不是在么? 当然要mount


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-05-12 9:28 

注册: 2007-03-12 13:48
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
iblicf 写道:
引用:
/dev/sda7 /media/sda7 ntfs-3g defaults,locale=zh_CN.utf8,umask=007,gid=46 0 0


这行不是在么? 当然要mount

这行我是留着的
我说的是mtab中那几行用红色字体标出的,我在fstab中并没有相应的项啊。
这怎们回事啊?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-05-12 10:00 

注册: 2007-01-31 9:05
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
我在fstab里边把不想加载的隐藏分区注释掉后,启动后打开“计算机”有该隐藏分区图标,但未加载,不知同一版本为何存在这样的问题


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-05-12 18:59 
头像

注册: 2007-05-06 18:11
帖子: 578
送出感谢: 0 次
接收感谢: 0 次
我的也是, 已经在gconf-editor里设置成不在桌面显示了, 可是每次开机那该死的WINDOWS分区还是蹦到桌面上...


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-05-12 19:01 

注册: 2007-01-15 23:14
帖子: 60
送出感谢: 0 次
接收感谢: 0 次
8) 昨天晚上截了几张图放在桌面上,今早起来一看,桌面上什么也没有了,包括LS说的这些所有图标。我没动它的,呵呵


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-05-12 19:04 
头像

注册: 2007-05-06 18:11
帖子: 578
送出感谢: 0 次
接收感谢: 0 次
还有个问题就是, 我现在自动加载的所有分区都没法卸载了... 顺便把我的/etc/fstab贴出来...

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda13
UUID=44a4f458-8015-4723-b1c5-8baf6a8e47d9 / ext3 defaults,errors=remount-ro,noatime,data=writeback 0 1
# /dev/sda14
UUID=2811c751-f1f2-4d4c-8f80-ca0d79e9acd6 /home ext3 defaults 0 2
# /dev/sda1
#UUID=94A03A66A03A4F4C /media/sda1 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda10
UUID=FA30A7C230A7846B /media/sda10 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda11
UUID=11F72B60E80F1109 /media/sda11 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda5
#UUID=6A9C790E9C78D653 /media/sda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda6
UUID=5AE4A082E4A0624D /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda7
UUID=8628F7F328F7E05B /media/sda7 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda8
UUID=4658F63858F62679 /media/sda8 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda9
UUID=5ABC7D62BC7D3999 /media/sda9 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
# /dev/sda12
UUID=a6cc872e-f0ef-4a38-a623-770ed4c1a038 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,iocharset=utf8,noauto 0 0


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-09-12 0:05 

注册: 2007-06-22 14:48
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
我一直都在找Ubuntu7.04每次都自动挂载的原因,一般说分区的挂载跟mount、fstab、mtab等有关吧,但找了那么久还没有发现问题!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-09-12 0:10 
头像

注册: 2007-02-25 22:55
帖子: 185
送出感谢: 0 次
接收感谢: 0 次
IdiotBenBen 写道:
我一直都在找Ubuntu7.04每次都自动挂载的原因,一般说分区的挂载跟mount、fstab、mtab等有关吧,但找了那么久还没有发现问题!



说不定在initrd.gz 中就有自动挂win分区的代码。

自动挂也不是什么bug ,别的发行版不自动挂,ubuntu自动挂居然就是bug 了。 自动挂的分区一般要root才可访问。我对win 的c 盘就是让它自动挂,这样反而安全。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-09-12 15:44 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
你把那些分区都写到fstab文件里去 ,,加上noatuo 参数


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-09-13 9:15 

注册: 2006-11-19 18:45
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
windwiny 写道:
你把那些分区都写到fstab文件里去 ,,加上noatuo 参数


具体怎样?谢谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译