当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于libc6版本问题
帖子发表于 : 2007-05-31 10:31 
头像

注册: 2007-05-07 8:21
帖子: 170
送出感谢: 0 次
接收感谢: 0 次
代码:
jervis@jervis-desktop:~$ sudo apt-get remove 任意软件
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
  libc6: 依赖: tzdata 但却无法安装它
  libc6-i686: 预依赖: libc6 (= 2.3.6-0ubuntu20.4) 但是 2.3.6.ds1-13 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


代码:
jervis@jervis-desktop:~/Desktop$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
  libc6: 依赖: tzdata 但却无法安装它
  libc6-i686: 预依赖: libc6 (= 2.3.6-0ubuntu20.4) 但是 2.3.6.ds1-13 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的 缘故。
E: 无法更正依赖关系


是libc版本装错了,我事先用了netselect-apt stable来选择最快源到/etc/apt/sources.list
后来才发现那个是给debian用的,糟糕,现在貌似装上了不该装的,fix不行,卸载不行,依赖他的贼多

我该怎么办 阿[/code]


最后由 jervis0211 编辑于 2007-06-01 12:34,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-06-01 12:32 
头像

注册: 2007-05-07 8:21
帖子: 170
送出感谢: 0 次
接收感谢: 0 次
:oops: 这个怎么办那


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译