当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件索引被破坏,不能 添加删除文件,这是怎么回事 啊?
帖子发表于 : 2007-07-16 0:19 

注册: 2007-07-16 0:09
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我打开软件更新管理器就会显示软件索引已被破坏,然后运行添加删除程序的时候就显示检查已安装的和可应用程序失败.这是怎么回事啊?拜托高手进来帮帮我 !谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-16 11:36 

注册: 2007-07-16 11:34
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
试试这个

sudo apt-get -f install

我之前遇到同样问题,用这个就解决了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-01 23:16 

注册: 2007-09-01 19:01
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
不行


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-01 23:46 

注册: 2007-01-09 11:09
帖子: 557
地址: 廣州
送出感谢: 0 次
接收感谢: 2
终端下输入:
sudo apt-get update
然后把输出的结果贴出来让大家看看。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-09-22 21:35 

注册: 2007-05-08 17:05
帖子: 53
送出感谢: 0 次
接收感谢: 0 次
caoxn@caomm:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
compiz: 依赖: compiz-decorator
compiz-gnome: 依赖: compiz-gtk (= 1:0.3.6-1ubuntu13) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
caoxn@caomm:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
compiz-gnome
下列的软件包将被升级:
compiz-gnome
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/161kB 的软件包。
解压缩后会消耗掉 893kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
compiz-gnome
不经验证就安装这些软件包么?[y/N] y
(正在读取数据库 ... 系统当前总共安装有 136920 个文件和目录。)
正预备替换 compiz-gnome 1:0.3.6-1ubuntu13 (使用 .../compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb) ...
正在解压缩将用于更替的包文件 compiz-gnome ...
dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins
在处理时有错误发生:
/var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-09-23 19:17 

注册: 2006-01-25 21:27
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
到/var/lib/dpkg/info 目录里面去,把compiz-plugins.list里面报冲突文件的行删掉,或者干脆把这个文件清空,再apt-get -f install 就好了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-06 2:56 

注册: 2007-05-19 16:36
帖子: 541
送出感谢: 0 次
接收感谢: 0 次
caoxuenian 写道:
caoxn@caomm:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
compiz: 依赖: compiz-decorator
compiz-gnome: 依赖: compiz-gtk (= 1:0.3.6-1ubuntu13) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
caoxn@caomm:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
compiz-gnome
下列的软件包将被升级:
compiz-gnome
共升级了 1 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 4 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/161kB 的软件包。
解压缩后会消耗掉 893kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
compiz-gnome
不经验证就安装这些软件包么?[y/N] y
(正在读取数据库 ... 系统当前总共安装有 136920 个文件和目录。)
正预备替换 compiz-gnome 1:0.3.6-1ubuntu13 (使用 .../compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb) ...
正在解压缩将用于更替的包文件 compiz-gnome ...
dpkg:处理 /var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/compiz/libgconf.so”,它属于软件包 compiz-plugins
在处理时有错误发生:
/var/cache/apt/archives/compiz-gnome_1%3a0.5.5~git20070828+3v1ubuntu0_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


ls的方法我试过,没弄成。用下面的步骤成了:
sudo apt-get remove compiz-plugins
sudo apt-get upgrade


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译