T22 安装7.04,在第二次重启后停顿了

系统错误报告和讨论
回复
ivan.zheng
帖子: 5
注册时间: 2007-08-12 21:17
送出感谢: 0
接收感谢: 0

T22 安装7.04,在第二次重启后停顿了

#1

帖子 ivan.zheng » 2007-08-12 21:46

按照 about40930.html 介绍的方法安装ubuntu 7.04,
但在第二次重启后停顿,只剩下一横标于左下方闪烁,问如何解决?
界面显示
Booting `Ubuntu, kernel 2.6.20-15-generic`
(hd0,0)
Filesystem type is ntfs, partition type 0X7
[Linux-bzimage, setup=0x1c00, size=0x1a82cc]
[Linux-initrd @ 0xf898000,0x7372d7 bytes]
_

另,在第一次重启的安装过程中出现装到36%即弹出对话框, 安装无法继续,安装选择xp下的D盘
但再次安装时选择安装于xp下的c盘则没有此问题!
问 此问题时候是否是wubi对分区定位的不准,导致配置文件中记录有误?

ibm T22 P3 900 256M 80G
磁盘分区c ntfs , d fat32 ,e ntfs
上次由 ivan.zheng 在 2007-08-14 11:42,总共编辑 2 次。
ivan.zheng
帖子: 5
注册时间: 2007-08-12 21:17
送出感谢: 0
接收感谢: 0

#2

帖子 ivan.zheng » 2007-08-13 14:35

那位大侠知道怎么解决.?? 提供点思路也万分感谢!
头像
skyx
论坛版主
帖子: 9203
注册时间: 2006-12-23 13:46
来自: Azores Islands
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 skyx » 2007-08-13 14:56

1 这个东东来自第三方,不是ubuntu官方发布的,所以安装不成功,也不是ubuntu的错误报告

2 安装windows时,是否用过第三方分区工具?


3 ntfs分区是否开启了压缩?
no security measure is worth anything if an attacker has physical access to the machine
ivan.zheng
帖子: 5
注册时间: 2007-08-12 21:17
送出感谢: 0
接收感谢: 0

#4

帖子 ivan.zheng » 2007-08-13 22:51

多谢skyx提供思路, 由于xp安装已久, 记不清是使用何种分区工具操作的.
但依我的理解分区工具导致的应该是第二个问题(即第一次启动装到36%的问题),不知是否是这样?

但对于第二次启动停顿, 使用single 模式 发现应该是ubuntu对T22硬件(显卡S3)的兼容问题,
请教是否知晓对应的解决方案?
附件
Image(263).jpg
ivan.zheng
帖子: 5
注册时间: 2007-08-12 21:17
送出感谢: 0
接收感谢: 0

#5

帖子 ivan.zheng » 2007-08-14 11:59

实在是令人沮丧, 折腾了几天还是没能把ubuntu给装上(光盘安装,硬盘安装,wubi安装..),虽然查阅了大量资料(中文的资料确实少),但到目前为止还是无任何进展.

疑惑的是,在这么多次的启动,为什么前后只有两次能够通过ACPI 检测(上一层附件的图片界面),为何能进入?为何又停顿不动? 难道是因为换过主板电源控制IC芯片? 可在xp系统下可是非常稳定!
[edit] Suspend and Hibernate with ACPI
ACPI is a newer and preferred alternative to APM. On the T20 it necessary to force the use of ACPI, using the following instructions.

gksudo gedit /boot/grub/menu.lst
Look for an uncommented line starting with "kernel" and add "acpi=force" to the end of the line. There should be a "title" line above describing the default kernel that usually boots. Making the change for just the default kernel should be sufficient.

Once the file has been re-saved, you can re-install the bootloader. The command for that is:

sudo grub-install /dev/hda
NOTE: This assumes your hard drive is at /dev/hda. Use "df" to see your hard drive names if you are not sure. This operation can potentially make your computer unbootable if there are mistakes, so be careful! (Of course, even if the hard drive became unbootable, you could most likely boot off a CD and fix it. )
edit] Blank Screen when booting Live CD
There is an issue with the Savage driver which makes the initial boot into X hang.

1. Hit F6 on the boot menu, delete "quiet splash" from the boot parameter line, and add "break=bottom".

2. After a while you will get a prompt (initramfs), type "chroot /root nano -w /etc/X11/xorg.conf".

3. Find your video card, and change driver "savage" to "vesa".

4. Save (ctrl+w), exit nano (ctrl+x), then press ctrl+d.

5. After that the live cd will work

This is most likely the same issue as gdm hanging on start. See Video section below for a fix that is known to work (at least on one T20 model).
ivan.zheng
帖子: 5
注册时间: 2007-08-12 21:17
送出感谢: 0
接收感谢: 0

#6

帖子 ivan.zheng » 2007-08-17 2:35

竟然沉得这么快........稍稍郁闷....

一阵狂google之后,终于在一英文论坛上发现线索,在T21 ,T22 所配置mini pci网卡存在严重兼容问题.直接导致启动静默,而最直接的解决方案就是开壳将mini pci卡取出.

特记录于此,希望对拥有T21 T22的朋友有所帮助
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#7

帖子 join330 » 2007-08-17 21:24

赞楼主一个,
搞定了问题,呵呵,
可能国内ubuntu的玩家还是比较少,
linux 的用户也被各种 linux分化了.
lenson_cn
帖子: 8
注册时间: 2007-09-04 9:56
送出感谢: 0
接收感谢: 0

#8

帖子 lenson_cn » 2007-09-04 10:03

我也是T22,安装的ubuntu-7.04-alternate-i386.iso,安装一切正常,重启后显示进度条,之后就是高亮黑屏了。
照你说的“T22 所配置mini pci网卡存在严重兼容问题.直接导致启动静默,而最直接的解决方案就是开壳将mini pci卡取出”那还怎么上网了????
springlarry
帖子: 286
注册时间: 2006-06-08 8:53
送出感谢: 0
接收感谢: 0

#9

帖子 springlarry » 2007-09-04 10:23

那么T??的安装没问题?有人知道吗?我打算进个2手的T43,操,就时候太贵
howo
帖子: 3
注册时间: 2007-09-04 11:46
送出感谢: 0
接收感谢: 0

Re: T22 安装7.04,在第二次重启后停顿了

#10

帖子 howo » 2007-09-04 11:50

呵呵,我也遇到这种情况了,现在已解决了!!!!!

要将安装的盘整个格化掉再安装就行啦!!!

我安装的过程,原来用迅雷找到及下载了ubuntu-7.04-alternate-i386.iso文件,安装后就在36%停顿了,还以为是文件下载出错,结果让wubi自动下载,等了一个多小时,然后安装也不行。最后在磁盘管理器中将整个分区删除了,再用NTFS格式化,然后安装就行了,FAT32没试,应该也没问题的。
lenson_cn
帖子: 8
注册时间: 2007-09-04 9:56
送出感谢: 0
接收感谢: 0

#11

帖子 lenson_cn » 2007-09-04 13:54

不知道为什么,今天中午重新启动居然进去了。一切显示正常,就是字体难看了点。
lenson_cn
帖子: 8
注册时间: 2007-09-04 9:56
送出感谢: 0
接收感谢: 0

#12

帖子 lenson_cn » 2007-09-05 8:35

全部搞定,没问题了。
edit] Blank Screen when booting Live CD
There is an issue with the Savage driver which makes the initial boot into X hang.

1. Hit F6 on the boot menu, delete "quiet splash" from the boot parameter line, and add "break=bottom".

2. After a while you will get a prompt (initramfs), type "chroot /root nano -w /etc/X11/xorg.conf".

3. Find your video card, and change driver "savage" to "vesa".

4. Save (ctrl+w), exit nano (ctrl+x), then press ctrl+d.

5. After that the live cd will work

This is most likely the same issue as gdm hanging on start. See Video section below for a fix that is known to work (at least on one T20 model).
回复

回到 “Ubuntu错误报告”