如何解决软件包的依赖问题???

系统错误报告和讨论
回复
YONGQUANYANG
帖子: 63
注册时间: 2007-07-26 23:49
来自: 中国广州
送出感谢: 0
接收感谢: 0
联系:

如何解决软件包的依赖问题???

#1

帖子 YONGQUANYANG » 2007-08-16 16:09

root@ubuntu-desktop:~/Downloads/eva# apt-get install libiconv.so.2
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
E: 无法找到软件包 libiconv.so.2
root@ubuntu-desktop:~/Downloads/eva# apt-get install gcc libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
gcc 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.4-1ubuntu12.3) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
root@ubuntu-desktop:~/Downloads/eva# apt-get install libc6-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.4-1ubuntu12.3) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包


如何解决上述问题?????xi谢谢
我是个刚刚接触ubuntu的人,很多东西都还是一团雾水,希望在以后的日子里能与大家建立一种互帮互助的气氛,谢谢大家的支持
回复

回到 “Ubuntu错误报告”