当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 发觉ubuntu不是很稳定
帖子发表于 : 2007-09-01 17:02 

注册: 2007-08-28 9:38
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我装得是7.04版,先是在虚拟机下安装,没问题,后来就双系统xp和ubuntu,安装过程没什么问题,经过简单得试用也没问题,可是第一个问题出现在无线网卡安装不上,看了好多文章基本试过,我反正是死活用不了,我的无线网卡是bcm4318的,这个还好不算什么大的问题,可恶的是出现无法登录的情况,分两种:
第一种,用了一天,进行了很多升级,突然一次重启后就是根本不出现图形界面,就是连用户名和密码也没有要求你输入,当文字的启动部分结束后就是黑屏,中间就出现一个锁住的鼠标其他什么也没有,机器长时间不相应,分析日志怀疑是分辩率设置的问题,我的本本是915的集成显卡,以前能进入系统的时候分辩率是1024x768,而我的本本是宽屏的,这个分辩率很不舒服,由于当时主要问题是无法进入图形界面,求救一段时间无果干脆重装。

第二种,系统重装好后用了半天,期间分辩率问题得到解决,由于下载915relution的工具软件,后来升级了中文的支持,好像第一次重启是正常了,后来一次在登录时突发奇想,改变了一下语言很登录session,结果密码输完后就是只出现背景而欢迎音乐、菜单条和图标就不出现了,如此一来什么都操作不来,有时在屏幕左上角出现一块灰色的区域,把鼠标移到上面鼠标变成了可以输入的那种图形,可是还是不能输任何东西,无奈重启多次,改变登录时的语言和session,结果绝大多数的情况是输完密码后就如同死机一般,偶尔有一两次出现了那个动听的登录成功的音乐,后来有一次用recovery mode登录后再startx进入了系统,听到了登录音乐,一会又弹出一个错误,如下图
从图上看似乎是背景主题声音系统出问题,可看日志,xorg.o.log的最后几行是:
Synaptics DeviceInit called
SynapticsCtrl called.
(II) Configured Mouse: ps2EnableDataReporting: succeeded
Synaptics DeviceOn called
(--) Synaptics Touchpad auto-dev sets device to /dev/input/event3
(**) Option "Device" "/dev/input/event3"
(--) Synaptics Touchpad touchpad found
Could not init font path element /usr/X11R6/lib/X11/fonts/misc, removing from list!
Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/Type1, removing from list!
ProcXCloseDevice to close or not ?
SetGrabKeysState - disabled
SetGrabKeysState - enabled

而syslog的最后几行是这样的
Aug 31 09:41:54 ubuntu avahi: Avahi disabled itself. If you want to use Avahi in this network, please
Aug 31 09:41:54 ubuntu avahi: contact your administrator and convince him to use a different DNS domain,
Aug 31 09:41:54 ubuntu avahi: since .local should be used exclusively for Zeroconf technology.
Aug 31 09:41:54 ubuntu avahi: For more information, see http://avahi.org/wiki/AvahiAndUnicastDotLocal
Aug 31 09:41:56 ubuntu ntpdate[5384]: step time server 82.211.81.145 offset -0.751835 sec
Aug 31 09:42:04 ubuntu kernel: [ 88.308000] eth0: no IPv6 routers present
Aug 31 09:42:13 ubuntu firmware_helper[5389]: main: error loading '/lib/firmware/bcm43xx_microcode5.fw' for device '/class/firmware/0000:05:02.0' with driver '(unknown)'
Aug 31 09:42:13 ubuntu kernel: [ 97.284000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
Aug 31 09:42:17 ubuntu NetworkManager: <WARNING>^I nm_device_802_11_wireless_scan (): could not trigger wireless scan on device eth1: No such device
Aug 31 09:42:37 ubuntu firmware_helper[5392]: main: error loading '/lib/firmware/bcm43xx_microcode5.fw' for device '/class/firmware/0000:05:02.0' with driver '(unknown)'
Aug 31 09:42:37 ubuntu kernel: [ 121.616000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
Aug 31 09:42:41 ubuntu NetworkManager: <WARNING>^I nm_device_802_11_wireless_scan (): could not trigger wireless scan on device eth1: No such device
Aug 31 09:43:02 ubuntu firmware_helper[5395]: main: error loading '/lib/firmware/bcm43xx_microcode5.fw' for device '/class/firmware/0000:05:02.0' with driver '(unknown)'
Aug 31 09:43:02 ubuntu kernel: [ 145.912000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
Aug 31 09:43:06 ubuntu NetworkManager: <WARNING>^I nm_device_802_11_wireless_scan (): could not trigger wireless scan on device eth1: No such device
Aug 31 09:43:10 ubuntu gconfd (blues-5446): starting (version 2.18.0.1), pid 5446 user 'blues'
Aug 31 09:43:11 ubuntu gconfd (blues-5446): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Aug 31 09:43:11 ubuntu gconfd (blues-5446): Resolved address "xml:readwrite:/home/blues/.gconf" to a writable configuration source at position 1
Aug 31 09:43:11 ubuntu gconfd (blues-5446): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Aug 31 09:43:11 ubuntu gconfd (blues-5446): Resolved address "xml:readonly:/var/lib/gconf/debian.defaults" to a read-only configuration source at position 3
Aug 31 09:43:11 ubuntu gconfd (blues-5446): Resolved address "xml:readonly:/var/lib/gconf/defaults" to a read-only configuration source at position 4
Aug 31 09:43:26 ubuntu firmware_helper[5466]: main: error loading '/lib/firmware/bcm43xx_microcode5.fw' for device '/class/firmware/0000:05:02.0' with driver '(unknown)'
Aug 31 09:43:26 ubuntu kernel: [ 170.092000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
Aug 31 09:43:30 ubuntu NetworkManager: <WARNING>^I nm_device_802_11_wireless_scan (): could not trigger wireless scan on device eth1: No such device
Aug 31 09:43:50 ubuntu firmware_helper[5469]: main: error loading '/lib/firmware/bcm43xx_microcode5.fw' for device '/class/firmware/0000:05:02.0' with driver '(unknown)'
Aug 31 09:43:50 ubuntu kernel: [ 194.420000] bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
Aug 31 09:43:54 ubuntu NetworkManager: <WARNING>^I nm_device_802_11_wireless_scan (): could not trigger wireless scan on device eth1: No such device
Aug 31 09:44:48 ubuntu gconfd (blues-5446): Received signal 15, shutting down cleanly
Aug 31 09:44:48 ubuntu gconfd (blues-5446): Exiting
Aug 31 09:44:48 ubuntu gdm[4910]: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
Aug 31 09:45:01 ubuntu gdm[4909]: Restarting computer...
Aug 31 09:45:02 ubuntu init: tty4 main process (4264) killed by TERM signal
Aug 31 09:45:02 ubuntu init: tty5 main process (4265) killed by TERM signal
Aug 31 09:45:02 ubuntu init: tty2 main process (4269) killed by TERM signal
Aug 31 09:45:02 ubuntu init: tty3 main process (4270) killed by TERM signal
Aug 31 09:45:02 ubuntu init: tty1 main process (4271) killed by TERM signal
Aug 31 09:45:02 ubuntu init: tty6 main process (4272) killed by TERM signal
Aug 31 09:45:06 ubuntu exiting on signal 15
看了上面的日志好像是字体设置或是gdm方面出了问题,不过我对这个系统没什么经验不知道如何去改正,希望大家给我出出主意,不然又只能重装了。


附件:
文件注释: recovery mode进入后startx进入系统后弹出的错误
Screenshot-gnome-session.png
Screenshot-gnome-session.png [ 27.88 KiB | 被浏览 1004 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-02 17:34 

注册: 2007-08-28 9:38
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
自己顶一下


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-02 18:57 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
1。xorg.conf里面的字体路径都正确吗?

2。gdm依赖1,2种特定字体,没删除过字体吧

3。从recovery进去,修改下theme这些。登录窗口,那里的配置。

不清楚动了些什么。似乎/etc/下配置有问题了。dpkg-reconfigure xserver-xorg? 试试。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-04 22:22 

注册: 2007-09-03 16:01
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我是新手,本本也是915集成的,无线能搜索到但也上不了网……郁闷中,现在是用XP在学习相关的知识,唉


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译