为何开启network-admin,services-admin等,窗口无法显示内容

系统错误报告和讨论
回复
lionkingfly
帖子: 34
注册时间: 2007-09-14 15:58
送出感谢: 0
接收感谢: 0

为何开启network-admin,services-admin等,窗口无法显示内容

#1

帖子 lionkingfly » 2007-09-16 4:52

我的系统是Ubuntu6.10升级到7.04. NVIDIA显卡
开启network-admin,services-admin等需要输入密码来认证的软件,窗口里无法显示内容(空白)或者点击里面的按钮后不响应,可以进行窗口的移动等,但是点击关闭按钮,不响应,再点,出来一个提示窗口,问是否强制退出?我点是。
在.xsessionerrors文件里报错信息是Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.
如果这时候我点击退出登录系统,通常不响应,我ctrl+alt+F1进终端,停止gdm,再启动gdm,出来登录界面,输入用户名,密码后,进入,只有屏幕上方白色正方形一块,以及其余蓝色背景(背景颜色是自己设置的),鼠标倒是可以移动,可是再也没有让它有其他用武的余地了(^_^)!
再ctrl+alt+F1进终端,停止gdm,再启动gdm,使用其他用户登录(包括使用root(我开启了)),情况一样。
只好重启,又可以正常使用了,只要不开启图形界面的需要密码认证的软件,就没什么问题。可是为什么会这样呢?
还有在登录界面的时候有声音,登录进去后就没有声音了,这使得Mplayer等播放软件也是没有响应。
看了些资料,就把内核升级到7.10版本的内核,还有alsa升级了,其他软件没有升级。然后重新编译安装nvidia官方最新驱动。重启进去,什么问题都看起来解决了,Mplayer可以播放,有声音。要认证的图形软件可以正常使用。
可是当我再次重启的时候,问题又全部回来了,这是怎么回事啊?这几天累死我了,真有些烦了,可是还不想放弃。
毕竟使用linux系统,可以让我们知道(windows很傻瓜但是确实好用)许多系统底层运作的知识,我自己对这就挺感兴趣的。
lionkingfly
帖子: 34
注册时间: 2007-09-14 15:58
送出感谢: 0
接收感谢: 0

各位麻烦你们贴出初始(刚刚安装完系统)没有改变的/etc/hosts文件

#2

帖子 lionkingfly » 2007-09-16 19:23

各位麻烦你们贴出初始(或刚刚安装完系统)没有改变的/etc/hosts文件,我想看看。
lionkingfly
帖子: 34
注册时间: 2007-09-14 15:58
送出感谢: 0
接收感谢: 0

没有哪位朋友给些提示帮助吗,大家都没有遇到这个问题吗?

#3

帖子 lionkingfly » 2007-09-16 22:42

没有哪位朋友给些提示帮助吗,大家都没有遇到这个问题吗?
lionkingfly
帖子: 34
注册时间: 2007-09-14 15:58
送出感谢: 0
接收感谢: 0

自己解决了这个问题

#4

帖子 lionkingfly » 2007-09-22 21:12

通过好多天的操作,反操作,终于将此问题解决了。
不过,由于太多的操作,所以自己也不是很确定哪些操作是完全的答案。

我先升级内核到gutsy版本,还有一部分软件也升级了,然后删除好些软件包。将network-admin等所在的包gnome-system-tools删除,主要是看见它就烦,害苦我了阿。有些包我又强制它使用edgy或feisty的版本。

将/etc/modprobe.d/aliases文件中有关ipv6的那行最后off掉,将/etc/hostsipv6相关的那些行#掉,更改
127.0.0.1 主机名 改成 127.0.0.1 localhost 主机名。这部分是关键!

重新装回了gnome-system-tool,哈哈,总算不出问题了。
不过,挺奇怪怎么都没人有相同的问题呢,就自己记录一下。
回复

回到 “Ubuntu错误报告”