当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [问题]谁能帮忙解决ATI X300显卡的问题。
帖子发表于 : 2007-10-19 9:53 
头像

注册: 2006-10-22 18:45
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
好像7.10自带的显卡驱动,对ATI X300有点问题。每次启动会黑屏5-6分钟,然后进入后很容易死机。通过受限驱动选项安装自带驱动之后,重启就花屏了,再也进不去了。这些现象都可以联想到是ATI X300显卡的兼容问题。
有没有办法在7.10安装的时候不使用自带的显卡驱动。


最后由 cema0110 编辑于 2007-10-19 16:36,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-19 11:07 

注册: 2007-10-19 10:51
帖子: 11
地址: 哈尔滨
送出感谢: 0 次
接收感谢: 0 次
是不是 7.10 对ATI显卡支持有问题阿 我的IBM T41 一样是这个问题 启动前黑很久 但进入一切正常


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-19 12:07 
头像

注册: 2006-10-22 18:45
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
:cry: 问题是我现在进去就不正常了,再说了,每次等5-6分钟,会疯的。。。
不知道有高手解决了没有!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-19 13:45 

注册: 2007-05-06 9:49
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
察看 /etc/usplash.conf 文件内容是否为:
代码:
xres=1024
yres=768


不是就改成如上这样。此时在关机时应该能够看到ubuntu徽标和进度条了。
如此说明应该是usplash的默认设置问题。

接着只要让usplash开机也使用此设置即可:
代码:
sudo dpkg-reconfigure usplash-theme-ubuntu


重起后应该能解决此问题。至少我是这样解决的。。。。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-19 13:59 
头像

注册: 2006-10-22 18:45
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
:shock: 谢谢楼上的。我先试下看看!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-19 16:25 
头像

注册: 2006-10-22 18:45
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
:cry: 关机和启动的画面是看到了。。但好像是显卡驱动的不支持。导致一段时间就卡死,死机。。。结果想换回以前用过显卡驱动fglrx+XGL。结果在配置fglrx的时候画面弹跳几下就死机了。郁闷啊!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-19 16:38 
头像

注册: 2006-10-22 18:45
帖子: 72
送出感谢: 0 次
接收感谢: 0 次
:cry: 静静的等待消息。。。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-19 16:56 

注册: 2005-10-05 23:03
帖子: 144
送出感谢: 0 次
接收感谢: 0 次
我的X550用开源驱动,默认开启桌面效果没什么问题。(以前是用fglrx+xgl)
你关掉桌面效果试试。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-20 4:22 
头像

注册: 2007-01-30 8:18
帖子: 46
地址: 哥本哈根
送出感谢: 0 次
接收感谢: 0 次
原来不是只有我才有这个问题,我用的华硕本本M2C,是镭9000显卡,而且散热片掉了,所以经常花屏- -!我以为死机是我显卡自身的问题,现在看来是很general的嘛

我已经装7.10 三次了,第一次装完没有开机时的漫长等待(因为老死机所以重装),第二次(不知怎么彻底挂了,无限黑屏),第三次(黑屏良久,很久很久)

我还外接了一个19寸的宽屏显示器,十分搞笑,我无法选择切换显示器,也不能设置secondary screen,只能俩一起用,一起使用1440×900的分辨率,但是更夸张的是上边那个工具栏长度是1024×760分辨率下的(宽度不可调),正好本本能显示,下边那个可以调宽到宽屏,本本上就显示不到,呵呵,我无可奈何了

当我看到7.10的介绍时,默认3d效果,默认读写ntfs,这些都然给我很心动,现在是很心冻。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-20 18:53 
头像

注册: 2007-01-30 8:18
帖子: 46
地址: 哥本哈根
送出感谢: 0 次
接收感谢: 0 次
在论坛上找到一个连接 http://ilovemac.cn/articles/instruction ... tions.html
解决了开机黑屏的问题

目前我关闭了3d特效,还未发生死机的现象,开机速度正常,但我不知道是不是这个方法解觉得(按理说应该不是)


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-10-20 19:07 
头像

注册: 2007-05-20 10:59
帖子: 23
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
不是7.10对A卡的支持有问题阿,我的9550也默认开不了3D效果。


_________________
Show自己
走自己的路,让别人去说吧!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-10-20 21:10 

注册: 2006-10-20 14:04
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
不是说AMD开放了ATI芯片的规范么,ATI开源驱动应该会好起来吧。
希望不久之后,在Linux中再也没有显卡的问题。
我觉得如果旧版本用的很好的话,安装或升级到新版之前,先用LiveCD试试。
如果启动和关机顺利,风扇,显卡,声卡,ACPI都没问题,再考虑安装或升级到新版本。
如果有问题,可以等解决了问题后再安装或升级到新版本。
这样的话,不会耽误事。


_________________
http://www.sanhex.cn


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-10-22 9:09 

注册: 2007-10-22 9:00
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
小淘兄,我的也是9550的卡,前两天刚装完系统的时候,启用受限驱动也不能开启3D效果,重装了最新的驱动之后,就可以了
http://www.ubfchina.cn/article/view.asp?id=31
我就是参照这个里面做的,不过这里面还有一点点没说清楚,是要先启用受限驱动后再安装最新的驱动程序的,我之前不知道,试了好多遍才发现的


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-10-22 14:58 

注册: 2006-09-03 20:53
帖子: 196
送出感谢: 0 次
接收感谢: 0 次
我是Thinkpad t43 44U的,以前不管是7.04还是7.10,这个问题在我的机子也常出现,在网上goole了很多,发现问题很多的时候还是显卡问题,用源里自带驱动直接安装一直有问题,我现在安装官方驱动 8.40,在/etc/X11/xorg.conf 里你直接写上芯片ID 如: Section "Device"
Identifier "ATI Technologies Inc M22 [Mobility Radeon X300]"
Driver "fglrx"
ChipID 0x5460
Option "AGPMode" "8"
Option "AGPFastWrite" "True"
Option "EnablePageFlip" "True"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
还有把 /etc/X11/xinit/xinput.d/scim 里GTK_IM_MODULE=xim
QT_IM_MODULE=xim 改成scim 。我现在用XGL+compiz fusio也未发现系统假死现象了,这是我一点应用,你可以参考试试,(一定要保证显卡安装成功),同时论坛里所提到的系统优化方法,在自己不太熟悉的情况下尽量不要照章而改。 附我的xorg.conf:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "通用显示器"
HorizSync 28.0 - 51.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "ATI Technologies Inc M22 [Mobility Radeon X300]"
Driver "fglrx"
ChipID 0x5460
Option "AGPMode" "8"
Option "AGPFastWrite" "True"
Option "EnablePageFlip" "True"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc M22 [Mobility Radeon X300]"
Monitor "通用显示器"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-10-23 18:30 

注册: 2007-10-22 18:07
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我的也是X550显卡啊..那我还装不装ubuntua 啊?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译