求助:升级7.10出错

系统错误报告和讨论
回复
armeria
帖子: 123
注册时间: 2007-05-29 5:20
送出感谢: 0
接收感谢: 0

求助:升级7.10出错

#1

帖子 armeria » 2007-10-20 20:21

刚刚升级到了7.10,使用的方式是系统->管理->更新里面的升级到7.10的选项,按照系统提示进行的。升级过程中报告ubuntu- keyring出错,后来升级中断。重启机器后无法进入图形界面,使用sudo dpkg-reconfigure xserver-xorg恢复后,终于进入了图形界面。但是发现之前的fcitx无法继续使用。

尝试重新安装fcitx,系统提示如下错误信息:

Setting up ubuntu-keyring (2007.06.11) ...
gpg: symbol lookup error: /usr/local/lib/libreadline.so.5: undefined symbol: PC
gpg: symbol lookup error: /usr/local/lib/libreadline.so.5: undefined symbol: PC
dpkg: error processing ubuntu-keyring (--configure):
subprocess post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of ubuntu-minimal:
ubuntu-minimal depends on ubuntu-keyring; however:
Package ubuntu-keyring is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ubuntu-keyring
ubuntu-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)

重新安装ubuntu-keyring,系统提示和上面相同的错误信息。

怎么能把上面的错误修正好呢?请大家帮帮忙,多谢了!
lb_bn
帖子: 1261
注册时间: 2007-02-25 16:56
送出感谢: 0
接收感谢: 0

#2

帖子 lb_bn » 2007-10-20 20:42

换成gutsy的源,update, dist-upgrade。。。
armeria
帖子: 123
注册时间: 2007-05-29 5:20
送出感谢: 0
接收感谢: 0

#3

帖子 armeria » 2007-10-20 20:48

谢谢,我试了一下您说的办法,还是不行,错误提示信息是和上面一样,那个ubuntu-keyring和/usr/local/lib/libreadline.so.5里面出了问题。
armeria
帖子: 123
注册时间: 2007-05-29 5:20
送出感谢: 0
接收感谢: 0

#4

帖子 armeria » 2007-10-21 3:22

目前的解决方法:删除ubuntu-keyring。也向ubuntu提供了bug的报告。
头像
fengluo
帖子: 11
注册时间: 2007-04-09 21:35
送出感谢: 0
接收感谢: 0
联系:

Re: 求助:升级7.10出错

#5

帖子 fengluo » 2007-11-02 11:16

armeria 写了:刚刚升级到了7.10,使用的方式是系统->管理->更新里面的升级到7.10的选项,按照系统提示进行的。升级过程中报告ubuntu- keyring出错,后来升级中断。重启机器后无法进入图形界面,使用sudo dpkg-reconfigure xserver-xorg恢复后,终于进入了图形界面。但是发现之前的fcitx无法继续使用。

尝试重新安装fcitx,系统提示如下错误信息:

Setting up ubuntu-keyring (2007.06.11) ...
gpg: symbol lookup error: /usr/local/lib/libreadline.so.5: undefined symbol: PC
gpg: symbol lookup error: /usr/local/lib/libreadline.so.5: undefined symbol: PC
dpkg: error processing ubuntu-keyring (--configure):
subprocess post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of ubuntu-minimal:
ubuntu-minimal depends on ubuntu-keyring; however:
Package ubuntu-keyring is not configured yet.
dpkg: error processing ubuntu-minimal (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ubuntu-keyring
ubuntu-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)

重新安装ubuntu-keyring,系统提示和上面相同的错误信息。

怎么能把上面的错误修正好呢?请大家帮帮忙,多谢了!
引用回复
sudo fc-cache -fv 2>&1 | grep failed | cut -f1 -d":" | xargs -i sudo touch {} && sudo fc-cache -fv
timothy_huo
帖子: 1
注册时间: 2008-12-11 17:02
送出感谢: 0
接收感谢: 0

Re: 求助:升级7.10出错

#6

帖子 timothy_huo » 2008-12-11 17:04

$cd /usr/local/lib/
$ sudo rm /usr/local/lib/libreadline.so.5
$ sudo rm libreadline.so
$ sudo apt-get install -f
$ sudo apt-get autoclean
试试 !!
回复

回到 “Ubuntu错误报告”