当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我的c61集成6100主板不能安装nvidia驱动(问题基本解决)
帖子发表于 : 2007-11-15 20:01 

注册: 2006-06-18 16:10
帖子: 82
送出感谢: 0 次
接收感谢: 1
我的机子是c61的主板,集成geforce6100显卡,754接口的闪龙64cpu。今天安了ubuntu 7.10,安装很顺利,也能进入桌面,可从仓库里安装nvidia却没有功,装完以后执行nvdiia-xconfig后重启就X启动出错,只能以低分辨率进入桌面,根本没有驱动nv的驱动,将xorg.conf改回去后也没有正常启动X了,到nvidia网站上下载了稳定版 驱动后,执行sudo /etc/init.d/gdm stop后,编译安装驱动,再执行sudo /etc/init.d/gdm start后能驱动显卡,能正常进入桌面并启动了compiz效果。重启X也仍正常,但是重新开机后就不能驱动显卡,其表现与安装库里的驱动一样。
那位大虾帮帮忙看有什么解决办法没有。
我现在是每次开机都得重新装驱动,真的好烦。


最后由 unliang 编辑于 2007-11-22 9:09,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-18 16:58 
头像

注册: 2007-09-04 13:51
帖子: 296
地址: LC @ eastasia
送出感谢: 3
接收感谢: 1
在系统-管理-受限程序管理里把那个驱动装上就好了吧。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-18 17:02 

注册: 2006-01-10 19:09
帖子: 1334
送出感谢: 0 次
接收感谢: 0 次
用sudo配置然后保存


页首
 用户资料  
 
4 楼 
 文章标题 : 我以前也遇到过这外问题,而且我的显卡也是6100
帖子发表于 : 2007-11-18 17:21 
头像

注册: 2007-11-17 18:18
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
我重新安装了系统。然后使用系统自带的驱动。也就是在System->administrators->restricted drivers manager里勾中显卡驱动。选择apply后,会下载并安装驱动。完毕后,就能开桌面特效了。如果显示分辨不对,就更改xorg.conf里的HorizSync(水平刷新频率)和VertRefresh(垂直刷新频率)。这样,应该没有问题了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 我以前也遇到过这外问题,而且我的显卡也是6100
帖子发表于 : 2007-11-20 20:46 

注册: 2006-06-18 16:10
帖子: 82
送出感谢: 0 次
接收感谢: 1
lenovan 写道:
我重新安装了系统。然后使用系统自带的驱动。也就是在System->administrators->restricted drivers manager里勾中显卡驱动。选择apply后,会下载并安装驱动。完毕后,就能开桌面特效了。如果显示分辨不对,就更改xorg.conf里的HorizSync(水平刷新频率)和VertRefresh(垂直刷新频率)。这样,应该没有问题了。

谢谢您 ,可我的问题是在System->administrators->restricted drivers manager里勾中显卡驱动安装后装的总是那较新的驱动,这个还是测试版 本,在我的机子上有问题,具体表现为mplayer及其他播放在非compiz界面下常出现无图像,也不是没有,就是些条条。我现在是把所有的restrict软件包全删了,这样就可以装官方的9643版的驱动了。
但是还是有问题,就是打开3D桌面后无边框了,刚才始还是有的,就今天突然就没有了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-20 21:05 
头像

注册: 2007-04-28 21:38
帖子: 1026
送出感谢: 0 次
接收感谢: 0 次
nvidia-glx-new
你的源里面没有吗?

我的就是这样装的。
还要装内核头文件和build-essencial,nvidia-kernel-common


附件:
Screenshot-新立得软件包管理器 .png
Screenshot-新立得软件包管理器 .png [ 47.81 KiB | 被浏览 2613 次 ]



_________________
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料
页首
 用户资料  
 
7 楼 
 文章标题 : Re: 我以前也遇到过这外问题,而且我的显卡也是6100
帖子发表于 : 2007-11-20 21:06 
头像

注册: 2007-04-28 21:38
帖子: 1026
送出感谢: 0 次
接收感谢: 0 次
unliang 写道:
lenovan 写道:
我重新安装了系统。然后使用系统自带的驱动。也就是在System->administrators->restricted drivers manager里勾中显卡驱动。选择apply后,会下载并安装驱动。完毕后,就能开桌面特效了。如果显示分辨不对,就更改xorg.conf里的HorizSync(水平刷新频率)和VertRefresh(垂直刷新频率)。这样,应该没有问题了。

谢谢您 ,可我的问题是在System->administrators->restricted drivers manager里勾中显卡驱动安装后装的总是那较新的驱动,这个还是测试版 本,在我的机子上有问题,具体表现为mplayer及其他播放在非compiz界面下常出现无图像,也不是没有,就是些条条。我现在是把所有的restrict软件包全删了,这样就可以装官方的9643版的驱动了。
但是还是有问题,就是打开3D桌面后无边框了,刚才始还是有的,就今天突然就没有了。


xorg.conf里面有没有
代码:
Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"     "True"
Section "Extensions"
                Option "Composite" "Enable"
EndSection


_________________
thinkpad x61 2G DDR no cdrom
--------------------------------------------
ABS学习中
sed学习中
awk学习中
perl学习中
新手描述不清,老手猜测不到,胡乱指挥一通,后果难以预料


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 我以前也遇到过这外问题,而且我的显卡也是6100
帖子发表于 : 2007-11-21 21:11 

注册: 2006-06-18 16:10
帖子: 82
送出感谢: 0 次
接收感谢: 1
aitilang 写道:
unliang 写道:
lenovan 写道:
我重新安装了系统。然后使用系统自带的驱动。也就是在System->administrators->restricted drivers manager里勾中显卡驱动。选择apply后,会下载并安装驱动。完毕后,就能开桌面特效了。如果显示分辨不对,就更改xorg.conf里的HorizSync(水平刷新频率)和VertRefresh(垂直刷新频率)。这样,应该没有问题了。

谢谢您 ,可我的问题是在System->administrators->restricted drivers manager里勾中显卡驱动安装后装的总是那较新的驱动,这个还是测试版 本,在我的机子上有问题,具体表现为mplayer及其他播放在非compiz界面下常出现无图像,也不是没有,就是些条条。我现在是把所有的restrict软件包全删了,这样就可以装官方的9643版的驱动了。
但是还是有问题,就是打开3D桌面后无边框了,刚才始还是有的,就今天突然就没有了。


xorg.conf里面有没有
代码:
Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"     "True"
Section "Extensions"
                Option "Composite" "Enable"
EndSection


这个我都是按照compiz官方的说法去做了的,加的还不止这几项,问题是前几天都好好的啊。

问题解决了,把compiz的设置恢复初始状态就好了,可能是我开了2个桌面的原因,我看初始设置里只有一个桌面,两个水平虚拟桌面。


最后由 unliang 编辑于 2007-11-22 9:08,总共编辑了 1 次

页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-22 9:05 

注册: 2006-06-18 16:10
帖子: 82
送出感谢: 0 次
接收感谢: 1
aitilang 写道:
nvidia-glx-new
你的源里面没有吗?

我的就是这样装的。
还要装内核头文件和build-essencial,nvidia-kernel-common


您好的,我不喜欢这个太新的驱动,它在我的机器上工作不稳定,我想装那个老一点的。也就是那个glx的那个。可装了那个就无法驱动显卡。系统自动切换回初始模式。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-23 9:44 

注册: 2007-04-27 12:52
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我的问题是这样的:

执行sudo /etc/init.d/gdm stop后,编译安装驱动,再执行sudo /etc/init.d/gdm start后还是不能驱动显卡,受限驱动显示已安装并打勾,但是只有640X480和800X600两种低分辨率可选,每次重启都这样,花了好长时间都搞不定

主板为刚出的nvidia MCP73 (GeForce 7100/nForce 630i),会不会是芯片组太新的缘故?各位大大帮帮我啊!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译