amd64一直好好的flashplugin-nonfree出问题了!!大家帮帮忙好吗?(已解决)

包含64位CPU、PPC、龙芯等所有非i386芯片
回复
头像
geoff
帖子: 22
注册时间: 2008-02-03 21:16
送出感谢: 0
接收感谢: 0

amd64一直好好的flashplugin-nonfree出问题了!!大家帮帮忙好吗?(已解决)

#1

帖子 geoff » 2008-10-05 18:02

情况是这样的:
我的是8.04+amd64

原本一直很好用的flashplugin-nonfree都没有什么大问题的,

系统也没有修改什么,前天想更新QQ preview2,从http://ftp.ubuntu.org.cn下了QQ重新安装的。

用着用着,,发现FF里的含有FLASH的网页都打不开。假死。

就上网找资料,执行以下后

sudo apt-get remove --purge flashplugin-nonfree
sudo apt-get install flashplugin-nonfree

发现flashplugin-nonfree已经更新到10的版本了。结果还是不能打开有FLASH的网页。

网上很多资料都是说有音频或者视频的FLASH才会假死。但我的情况是什么FLASH都不能打开。

之后试试看是不是FF的问题,就整个FF删除了,包括nspluginwrapper、flashplugin-nonfree都一起删除。

再重新安装,,还是不行!!!

看看是不是源的问题,更新了cn99的源,再删除,再安装!!还是不行!!!!

试过所有方法,如:nspluginwrapper + flashplugin-nonfree 降版本安装不行,把FF中修改FIREFOX_DSP=aoss也不行。

最后,我试试假死到一段时间让它超时,看看有什么提示,
*** NSPlugin Wrapper *** ERROR: NPP_SetWindow() invoke: Message timeout

超时后,FF能动了,但FLASH的内容是空白,但FLASH右键菜单是可以的。
看样子好像是远程数据一点也读取不了,,我再试试把 ~/ 改变权限 chmod -R 777 ~/
还是不行呀,,,,,一样假死呀!!!


是不是64位的系统,,不能正常享用flashplugin-nonfree呀~~~平时要接触很多FLASH的,用Gnash 或者 Swfdec 有很多FLASH都不正常的,,,,,

大家看如何解决???
头像
geoff
帖子: 22
注册时间: 2008-02-03 21:16
送出感谢: 0
接收感谢: 0

Re: amd64一直好好的flashplugin-nonfree出问题了!!大家帮帮忙好吗?(已解决)

#2

帖子 geoff » 2008-10-05 18:38

结果很不幸,,

元凶是 QQ preview2,是在这里下载的:

http://ftp.ubuntu.org.cn/home/xeoc/deb/

linuxqq更新到1.0 preview2

安装后就会使flashplugin-nonfree不能使用。

彻底删除后即可。
xeoc
帖子: 1994
注册时间: 2007-05-06 10:12
送出感谢: 0
接收感谢: 0

Re: amd64一直好好的flashplugin-nonfree出问题了!!大家帮帮忙好吗?(已解决)

#3

帖子 xeoc » 2008-10-05 19:19

geoff 写了:结果很不幸,,

元凶是 QQ preview2,是在这里下载的:

http://ftp.ubuntu.org.cn/home/xeoc/deb/

linuxqq更新到1.0 preview2

安装后就会使flashplugin-nonfree不能使用。

彻底删除后即可。
不是吧,我这一点问题都没有的...那个包里只是加上了32位输入法的so,别的动都没动,你再装上试试?不可能是linuxqq的原因的,和flash不相干啊...
头像
geoff
帖子: 22
注册时间: 2008-02-03 21:16
送出感谢: 0
接收感谢: 0

Re: amd64一直好好的flashplugin-nonfree出问题了!!大家帮帮忙好吗?(已解决)

#4

帖子 geoff » 2008-10-05 20:36

原来用preview1的,可能是升级preview2后出现的问题。
回复

回到 “系统架构支持”