当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 软件包“adobe-flashplugin”处于冲突状态
帖子发表于 : 2009-10-31 23:46 

注册: 2008-05-27 15:31
帖子: 49
地址: 西北工业大学
送出感谢: 0 次
接收感谢: 0 次
软件包“adobe-flashplugin”处于冲突状态,需要重新安装, 但是没能找到它的存档。请重新手动安装这个软件包或者将其从系统中删除。


现在删也不能删~~装其它东西也不行~~~

郁闷了~~不知该怎么办了~~~`


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 软件包“adobe-flashplugin”处于冲突状态
帖子发表于 : 2009-10-31 23:52 
头像

注册: 2009-05-14 14:06
帖子: 317
送出感谢: 0 次
接收感谢: 0 次
你是32位系统还是64的


_________________
That is in my life!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 软件包“adobe-flashplugin”处于冲突状态
帖子发表于 : 2009-10-31 23:59 
头像

注册: 2009-05-14 14:06
帖子: 317
送出感谢: 0 次
接收感谢: 0 次
如果是64的,可以用下面代码新建一个flash64.sh文件

代码:
               
               
                #!/bin/bash
# Script created by
# Romeo-Adrian Cioaba romeo.cioaba@spotonearth.com
echo "Stopping any Firefox that might be running"
sudo killall -9 firefox
echo "Removing any other flash plugin previously installed:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper
echo "Installing Flash Player 10"
cd ~
wget http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz
tar zxvf libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/
echo "Linking the libraries so Firefox and apps depending on XULRunner (vuze, liferea, rsswol) can find it."
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/
sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/xulrunner-addons/plugins/
# now doing some cleaning up:
sudo rm -rf libflashplayer.so
sudo rm -rf libflashplayer-10.0.32.18.linux-x86_64.so.tar.gz


然后在终端执行,完美解决.
当然 这不是我写,GOOGLE的


_________________
That is in my life!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 软件包“adobe-flashplugin”处于冲突状态
帖子发表于 : 2009-10-31 23:59 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
怎么不能个删法? :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 软件包“adobe-flashplugin”处于冲突状态
帖子发表于 : 2009-11-01 0:11 

注册: 2008-05-27 15:31
帖子: 49
地址: 西北工业大学
送出感谢: 0 次
接收感谢: 0 次
四张图~~

事情原由是因为FireFox不能显示Flash,然后我就找出原来下的
adobe-flashplugin_10-alpha-1_amd64.deb

然后就一直出错

提示说 可以用“sudo apt-get install -f”命令修复~~~

可是用了这个命令也没用


附件:
Screenshot-1.png
Screenshot-1.png [ 71.54 KiB | 被浏览 1061 次 ]

Screenshot.png
Screenshot.png [ 50.57 KiB | 被浏览 1061 次 ]

Screenshot-3.png
Screenshot-3.png [ 27.05 KiB | 被浏览 1062 次 ]

Screenshot-2.png
Screenshot-2.png [ 127.26 KiB | 被浏览 1062 次 ]

Screenshot-1.png
Screenshot-1.png [ 78.16 KiB | 被浏览 1062 次 ]

Screenshot.png
Screenshot.png [ 34.06 KiB | 被浏览 1062 次 ]

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 软件包“adobe-flashplugin”处于冲突状态
帖子发表于 : 2009-11-01 2:40 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
最后一个点是 还不行么?
aptitude 试试..


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译