[问题]64位的lumaqq在我的desktop-amd64-6.06上不能运行?[已解决]

包含64位CPU、PPC、龙芯等所有非i386芯片
回复
jiazhengw
帖子: 12
注册时间: 2006-09-17 9:57
送出感谢: 0
接收感谢: 0

[问题]64位的lumaqq在我的desktop-amd64-6.06上不能运行?[已解决]

#1

帖子 jiazhengw » 2006-10-05 19:43

下了lumaqq_2005-linux_gtk2_x86_64_no_jre.tar.gz 后,解压运行lumaqq,出现如下的错误:

代码: 全选

/usr/local/LumaQQ$ ./lumaqq
/usr/local/LumaQQ$ 0    [main] ERROR edu.tsinghua.lumaqq.IconHolder - i/o error (java.util.zip.ZipException: Deflated stream ends early.)
Exception in thread "main" java.lang.NoClassDefFoundError: edu.tsinghua.lumaqq.MessageQueue
   at java.lang.Class.initializeClass(libgcj.so.7)
   at edu.tsinghua.lumaqq.ui.MainShell.<init>(MainShell.java:174)
   at edu.tsinghua.lumaqq.LumaQQ.main(LumaQQ.java:117)
Caused by: java.lang.ClassNotFoundException: java.util.Queue not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/local/LumaQQ/lib/xerces.jar,
file:/usr/local/LumaQQ/lib/swt.jar,file:/usr/local/LumaQQ/lib/poifs.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.ui.workbench_3.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.osgi_3.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.jface_3.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.emf.ecore.xmi_2.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.emf.ecore_2.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.emf.common_2.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.core.runtime_3.1.0.jar,
file:/usr/local/LumaQQ/lib/org.eclipse.core.resources_3.1.0.jar,
file:/usr/local/LumaQQ/lib/lumaqq_xsd.jar,file:/usr/local/LumaQQ/lib/lumaqq.jar,
file:/usr/local/LumaQQ/lib/log4j-1.2.8.jar,
file:/usr/local/LumaQQ/lib/jql_protocol.jar,
file:/usr/local/LumaQQ/lib/jql_net.jar,
file:/usr/local/LumaQQ/lib/jdom.jar,
file:/usr/local/LumaQQ/lib/commons-logging.jar,
file:/usr/local/LumaQQ/lib/commons-codec.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(libgcj.so.7)
   at java.lang.ClassLoader.loadClass(libgcj.so.7)
   at java.lang.ClassLoader.loadClass(libgcj.so.7)
   at java.lang.Class.initializeClass(libgcj.so.7)
   ...2 more
不知大家有没有遇到这种情况,是什么原因?谢谢!!很想从32位转移到64位机了,希望能搞定。
上次由 jiazhengw 在 2006-10-05 21:13,总共编辑 1 次。
jiazhengw
帖子: 12
注册时间: 2006-09-17 9:57
送出感谢: 0
接收感谢: 0

#2

帖子 jiazhengw » 2006-10-05 21:13

原来是JAVA的设置问题!在~/.bash_profile中加入以下两行即可(也就是增加两个环境变量):

代码: 全选

export CLASSPATH="/usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre/lib"
export JAVA_HOME="/usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre/"
然后在终端下运行命令:
$. ~/.bash_profile
即可!
回复

回到 “系统架构支持”