[问题]Error opening/inintializing the selected video_out (-vo)

包含64位CPU、PPC、龙芯等所有非i386芯片
回复
crazy_pipi_lu
帖子: 25
注册时间: 2007-01-19 23:25
送出感谢: 0
接收感谢: 0

[问题]Error opening/inintializing the selected video_out (-vo)

#1

帖子 crazy_pipi_lu » 2007-01-24 0:57

我装的系统是edgy for amd64,
使用命令apt-get install mplayer安装了MPlayer,
但是播放时显示Fatal error!
Error opening/inintializing the selected video_out (-vo) device.

请问这是什么问题呢?
上次由 crazy_pipi_lu 在 2007-02-01 15:00,总共编辑 1 次。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2007-01-24 1:15

点我签名档
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
crazy_pipi_lu
帖子: 25
注册时间: 2007-01-19 23:25
送出感谢: 0
接收感谢: 0

#3

帖子 crazy_pipi_lu » 2007-01-25 18:57

Hi, 32 bit for x86是正常的,
我只是不明白
Fatal error!
Error opening/inintializing the selected video_out (-vo) device.
的意思......
头像
samuelt
帖子: 151
注册时间: 2006-12-19 0:02
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 samuelt » 2007-01-25 19:03

我的也有这问题,我的是32bit的
andrew_t
帖子: 614
注册时间: 2006-12-14 3:00
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 andrew_t » 2007-01-25 19:38

强烈推荐 vlc,感觉比mplayer好使,不过不能放rm系列文件,放dvdrip,高清视频都比mplayer好使
tdxm211
帖子: 6
注册时间: 2007-01-21 18:53
送出感谢: 0
接收感谢: 0

#6

帖子 tdxm211 » 2007-01-26 22:46

试了一下这个http://wiki.ubuntu.org.cn/64BitWin32VideoCodecs
还有试一下MPlayer->Preferences->Video 选一个试试

我一阵乱捣鼓 基本上各种格式都可以放了

现在还有个问题 有这样的错误:Requested audio codec family [mp3] (afm=mp3lib) not available.Enable it at compilation. 没有解决 不过还是能够播放 :lol: :lol:
sam821015
帖子: 31
注册时间: 2007-01-13 23:07
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 sam821015 » 2007-01-27 0:50

我的问题和楼主一样,没结局,一天到往GOOGLE来BAIDU去的,也没弄个顺心来,我不知道干什么。。。

楼上的你怎么就可以捏???教教偶行不?qq: 15787943
折腾吧,使劲折腾!
crazy_pipi_lu
帖子: 25
注册时间: 2007-01-19 23:25
送出感谢: 0
接收感谢: 0

#8

帖子 crazy_pipi_lu » 2007-02-01 14:59

Hi, Sam, 直接使用命令~$: mplayer example.file
就可以播放文件了, 我想不是codec的问题, 因为我已经安装过win32codec了.

不能双击播放的问题, 应该是显示设备不能被mplayer识别, 我还没装显卡驱动, 不知道是不是这个原因.
我用的9550.
crazy_pipi_lu
帖子: 25
注册时间: 2007-01-19 23:25
送出感谢: 0
接收感谢: 0

#9

帖子 crazy_pipi_lu » 2007-02-01 15:21

双击播放问题可以这样解决:

修改~/.mplayer/gui.conf中的vo_driver = "xmga"
改为vo_driver = "x11"

不过最好还是装显卡驱动比较好...
回复

回到 “系统架构支持”