当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]Error opening/inintializing the selected video_out (-vo)
帖子发表于 : 2007-01-24 0:57 

注册: 2007-01-19 23:25
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
我装的系统是edgy for amd64,
使用命令apt-get install mplayer安装了MPlayer,
但是播放时显示Fatal error!
Error opening/inintializing the selected video_out (-vo) device.

请问这是什么问题呢?


最后由 crazy_pipi_lu 编辑于 2007-02-01 15:00,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-01-24 1:15 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
点我签名档


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-01-25 18:57 

注册: 2007-01-19 23:25
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
Hi, 32 bit for x86是正常的,
我只是不明白
Fatal error!
Error opening/inintializing the selected video_out (-vo) device.
的意思......


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-01-25 19:03 
头像

注册: 2006-12-19 0:02
帖子: 151
送出感谢: 0 次
接收感谢: 0 次
我的也有这问题,我的是32bit的


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-01-25 19:38 

注册: 2006-12-14 3:00
帖子: 614
送出感谢: 0 次
接收感谢: 0 次
强烈推荐 vlc,感觉比mplayer好使,不过不能放rm系列文件,放dvdrip,高清视频都比mplayer好使


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-26 22:46 

注册: 2007-01-21 18:53
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
试了一下这个http://wiki.ubuntu.org.cn/64BitWin32VideoCodecs
还有试一下MPlayer->Preferences->Video 选一个试试

我一阵乱捣鼓 基本上各种格式都可以放了

现在还有个问题 有这样的错误:Requested audio codec family [mp3] (afm=mp3lib) not available.Enable it at compilation. 没有解决 不过还是能够播放 :lol: :lol:


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-01-27 0:50 

注册: 2007-01-13 23:07
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
我的问题和楼主一样,没结局,一天到往GOOGLE来BAIDU去的,也没弄个顺心来,我不知道干什么。。。

楼上的你怎么就可以捏???教教偶行不?qq: 15787943


_________________
折腾吧,使劲折腾!


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-02-01 14:59 

注册: 2007-01-19 23:25
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
Hi, Sam, 直接使用命令~$: mplayer example.file
就可以播放文件了, 我想不是codec的问题, 因为我已经安装过win32codec了.

不能双击播放的问题, 应该是显示设备不能被mplayer识别, 我还没装显卡驱动, 不知道是不是这个原因.
我用的9550.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-01 15:21 

注册: 2007-01-19 23:25
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
双击播放问题可以这样解决:

修改~/.mplayer/gui.conf中的vo_driver = "xmga"
改为vo_driver = "x11"

不过最好还是装显卡驱动比较好...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译