在Feisty amd64上成功安装Quake 4

包含64位CPU、PPC、龙芯等所有非i386芯片
回复
subpepper
帖子: 4
注册时间: 2005-11-11 20:21
送出感谢: 0
接收感谢: 0

在Feisty amd64上成功安装Quake 4

#1

帖子 subpepper » 2007-04-27 23:05

心血来潮,想试一下linux版的quake4。由于我现在使用的是amd64版的feisty,所以必须动一些手脚了。

代码: 全选

sudo apt-get install ia32-libs linux32 lib32asound2
下载linux版的quake4安装文件quake4-linux-beta-1.4.1.x86.run,直接安装后不能启动,按照提示信息,我把ia32版的feisty中相应的deb手工下载解压,把里面的库文件复制到/usr/lib32中,一共下了下面几个文件:

代码: 全选

libaa1_1.4p5-30_i386.deb
libartsc0_1.5.6-0ubuntu1_i386.deb
libaudiofile0_0.2.6-6ubuntu3_i386.deb
libdirectfb-0.9-25_0.9.25.1-5ubuntu2_i386.deb
libesd-alsa0_0.2.36-3ubuntu4_i386.deb
libgpmg1_1.19.6-23build1_i386.deb
libsdl1.2debian-all_1.2.11-7ubuntu1_i386.deb
libslang2_2.0.6-4build1_i386.deb
它还需要ncurses,这个可以直接apt-get。

我在windows下安装了quake4,直接把quake4安装目录下的pak*.pk4和zpak_english.pk4链接到/usr/local/game/quake4/q4base里,quake4就算是基本安装好了。

由于quake4运行需要网站验证,下载来的cd-key不能通过。一个小把戏可以欺骗一下quake4,在/etc/hosts中加入一行

代码: 全选

127.0.0.1       q4master.idsoftware.com
也就是把id的验证服务器指向本机,再输入网上搜索到的cd-key,可以玩了。

效果不错,和windows版差不多。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-04-27 23:13

对。用32的跑就是。

打倒q4。支持doom3。
● 鸣学
db_lobster
帖子: 168
注册时间: 2006-10-11 19:30
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 db_lobster » 2007-04-28 12:53

D3 太黑了, 还是 Q4 好
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2007-04-28 13:00

一起打倒这些我机器玩不了的游戏。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
依窗吻风
帖子: 85
注册时间: 2006-04-20 12:12
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 依窗吻风 » 2007-05-04 19:02

谁给发个截图看看撒~~ :lol:
回复

回到 “系统架构支持”