AMD64 Ubuntu7.04下IC5141出现如下错误

包含64位CPU、PPC、龙芯等所有非i386芯片
回复
holddreams
帖子: 198
注册时间: 2007-05-06 0:53
送出感谢: 0
接收感谢: 0

AMD64 Ubuntu7.04下IC5141出现如下错误

#1

帖子 holddreams » 2007-05-21 22:18

/opt/IC5141/tools/dfII/bin/icfb.exe: relocation error: /opt/IC5141/tools/dfII/bin/icfb.exe: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

该怎么办?

谢谢
yeahsoso
帖子: 13
注册时间: 2006-09-27 9:00
送出感谢: 0
接收感谢: 0

#2

帖子 yeahsoso » 2008-01-04 23:07

试试.bashrc中填入如下信息:
export LD_ASSUME_KERNEL = 2.4.1

不过,不知道7.04的kernel是否还支持LD_ASSUME_KERNEL = 2.4.1。支持的话,应该能解决问题,IC5141可用。
如果不支持的话,凡是在终端中执行命令,都会报错,什么“/bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory”之类的,要不就是libc.so.6libdl.so.2
我试过7.10,是不支持LD_ASSUME_KERNEL = 2.4.1的,所以还没有办法安装IC5141.
6.06是可以的,能够正常运行IC5141.

以上是不考虑AMD64的前提下进行,(我的机器是IBM X31,工作用PC P4 2.4G),AMD64没有机会尝试,不知道会否存在问题。
回复

回到 “系统架构支持”