当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 7.10 64位安装ati 7.11(8.43.2)显卡驱动成功,支持3D桌面,8.04hardy支持ati8.4驱动
帖子发表于 : 2007-11-23 21:05 

注册: 2007-05-23 23:53
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
我现在都搞不懂有时候能装上有时候不能装上是什么原因了,这个ati显卡驱动我装得郁闷
ati从8.42.3开始支持aiglx,不过我没有把它在64位下安装成功,直接和编译都不行,现在的8.4也不好搞定。怎么就没windows下 简单呢,一路下一步。闭着眼睛也能装,就跟以前有个笑话说的现在闭着眼睛就能把xp装上,重装次数多了吧,好了,8.4也可以根据下面的办法安装,本办法适用于64位和32位,也适用8.04。
8.42.3安装编译的时候我连
引用:
bash *.run --buildpkg Ubuntu/gutsy
创建deb包都不行,郁闷。
后来到google上找了半天,才知道要打什么补丁才能,太麻烦了,还是等下一个版本吧。

今天没事到ati上看了看,出新版本了,7.11,赶紧下来安装。好了,现在开始说具体操作。
我电脑用的是ATI MOBILITY RADEON X700,直接sudo sh *.run还是没有安上。

下面我用编译的方法才搞定:

1,安装编译所必须的工具

引用:
sudo apt-get update
sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-$(uname -r)


2,创建deb包 不能创建deb包的话你就别弄了,用系统硬件驱动里自带的吧。注意就是你首先要在shell里面cd到你下载的驱动的当前目录,一般我下到桌面 cd 桌面 就ok了
hardy 8.04
引用:
bash *.run --buildpkg Ubuntu/hardy

gusty 7.10
引用:
bash *.run --buildpkg Ubuntu/gutsy
*号 我不用解释了吧,懒人的好办法,懒得敲全文件名
Feisty 7.04
引用:
bash *.run --buildpkg Ubuntu/feisty


3,屏蔽fglrx核心模块 这个好像对我没啥用,跟着照做也无妨
注意,如果你已经安装了linux-restricted-modules的话,那么此步必做。否则可以跳过(一般都要做)。
引用:
sudo gedit /etc/default/linux-restricted-modules-common

将里面的
引用:
DISABLED_MODULES=""

改成
引用:
DISABLED_MODULES="fglrx"


4,安装deb包 也就是前面步骤2创建的deb包
引用:
sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source*.deb fglrx-amdcccle*.deb


5,移除旧的fglrx 这个很重要,免得以前的驱动捣乱,要装就装最新的
如果你是第一次做,那么会提示你这个文件找不到。别管他,继续往下做就是。主要是为了防止旧的fglrx干扰。
引用:
sudo rm /usr/src/fglrx-kernel*.deb
sudo apt-get -f install


6,编译内核模块并安装 这个才是重点,显卡驱动不能正确安装就是这一步的原因,直接安装为什么安上驱动不正确,fglrxinfo 显示的是带 Mesa project: www.mesa3d.org之类字符就,明明是ati显卡驱动关Mesa什么事。是因为这一步恩。自己编译驱动才能装正确
引用:
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
cd /usr/src
sudo dpkg -i fglrx-kernel-*.deb
sudo depmod -a


说明
如果sudo module-assistant prepare命令不起作用可能是没有安装module-assistant,
sudo apt-get install module-assistant就可以搞定。
还有就是sudo module-assistant build fglrx可能会出错,弄不成功,编译不出来fglrx-kernel-*.deb包。遇到这种情况我也还没有解决办法,可能下面办法能行吧。
试试彻底卸载驱动
代码:
sudo apt-get remove --purge fglrx-control
sudo apt-get remove --purge fglrx-kernel-source
sudo apt-get remove --purge xorg-driver-fglrx
代码:
sudo lrm-manager
并把原来装过的4个包彻底删除。
代码:
sudo apt-get autoremove --purge fglrx*

再重新按上面的方法安装的1-6步,如果不行,请放弃。

7,配置驱动 这个是往xorg.conf里面写驱动信息。
引用:
sudo aticonfig --initial -f

引用:
sudo aticonfig --ovt=Xv


8,我门要实现3D桌面,就应该把以前xorg.conf里不支持aiglx的语句删掉或者修改。

我直接把下面的删掉了
引用:
Section "Extensions"
Option "Composite" "0"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

要不改成
引用:
Section "Extensions"
Option "Composite" "1"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection


9,重启系统或者用Ctrl+Alt+Backspace重新进入图形界面,确认驱动是否安装好。有问题的话参照下面我列举的常见错误。我装上不能启动fglrxinfo 好好修改下问题几下就解决了
确认驱动是否正确安装(可以类似于)
引用:
$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.1.7059 Release


引用:
$ glxinfo | grep render
direct rendering: Yes #如果开启了xgl,那么这里一定是No,还有其他一些信息。


我们需要的是看到类似上面两条的内容。

10,开启3D桌面,让Compiz Fusion工作

输入
引用:
SKIP_CHECKS=yes compiz

看看你的桌面特效有没有,最大化最小化看看是不是有3D的效果呢,有呢说明支持3D桌面了恩,恭喜你恩。

然后再输入
引用:
mkdir -p ~/.config/compiz && echo SKIP_CHECKS=yes >> ~/.config/compiz/compiz-manager


重启一下看看是不是开机自动开启了桌面特效,应该这样就可以了。如果不行的话,手动点击桌面特效里面的选项,把桌面特效给打开(这个我不再罗嗦了吧)。

参考文章:http://forum.ubuntu.org.cn/viewtopic.php?t=26188
http://forum.ubuntu.org.cn/viewtopic.php?t=83802


最后由 byunix 编辑于 2008-05-01 2:53,总共编辑了 6 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-24 21:58 

注册: 2007-11-05 23:37
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
还是不行…… X1300


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-26 11:14 

注册: 2007-05-23 23:53
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
dmxixi 写道:
还是不行…… X1300

你的是出错在那里呢?64位的没有32位的好装。

一般出错问题你可以到http://forum.ubuntu.org.cn/viewtopic.php?t=26188
上参考。我顺便把他贴出来,我当初编译安装的时候也出了错,出错在第5个:执行fglrxinfo出现 libGL.so.1: cannot open shared object file

常见错误:

1。如果你碰到2D加速很慢的情况,在/etc/X11/xorg.conf 的 Device section(就是有fglrx的那段)中添上
代码:
Option "XaaNoOffscreenPixmaps"


2。如果没有3D加速,可尝试
代码:
sudo mkdir /lib/modules/$(uname -r)/volatile
sudo ln -sf /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko


3。另外,如果你想用图形化的工具配置显卡的话,比如双头显示,则可以
代码:
gksu fireglcontrol

如果是用方法二的用
代码:

gksu amdcccle

当然,图形界面的功能比较有限,最强大的还是aticonfig。最新版的控制中心有些新东西,大家可以试试。

4。如果说/usr/X11R6/lib/modules/dri/fglrx_dri.so缺失,则执行
代码:

sudo ln -s /usr/lib/ /usr/X11R6/lib/modules


5。如果执行fglrxinfo出现 libGL.so.1: cannot open shared object file,则
代码:

sudo ln /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-27 13:23 

注册: 2007-04-04 15:56
帖子: 277
送出感谢: 0 次
接收感谢: 0 次
放电影屏幕闪烁得厉害 搂主遇到过吗 ? 还有玩3d 游戏也闪烁的厉害


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-29 21:20 

注册: 2007-05-23 23:53
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
biosxjj 写道:
放电影屏幕闪烁得厉害 搂主遇到过吗 ? 还有玩3d 游戏也闪烁的厉害

这个我还没遇见过。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-02 3:48 
头像

注册: 2007-10-07 18:04
帖子: 143
送出感谢: 0 次
接收感谢: 0 次
2,创建deb包 注意就是你首先要在shell里面cd到你下载的驱动的当前目录
gusty 7.10
引用:
bash *.run --buildpkg Ubuntu/gutsy
我到了这一步就在也前进不了了,怎么cd的当前目录?我的驱动在/home/v/桌面 这个位置,麻烦告诉我怎么办。半夜四点上网就是为了文清楚。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-02 15:29 
头像

注册: 2007-10-07 18:04
帖子: 143
送出感谢: 0 次
接收感谢: 0 次
太感谢你了,你真是神阿,我的驱动装好了,字体清晰了不少,显示也正常了,就是还没试试特效。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-07 23:05 

注册: 2007-11-30 13:11
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
good!, Thanks! X1300!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-29 23:13 

注册: 2007-09-06 13:34
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
X1300 :shock: :shock: .。。。都是贵东西啊~~~


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-04-30 17:50 

注册: 2007-05-23 23:53
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
现在的驱动还是不好装,8.4也是直接装不好,还得用这个老办法


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-04-30 18:30 

注册: 2007-05-23 23:53
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
这里说明一下一些其他问题。

1,看电影玩,3d游戏等的时候闪屏(也就是老看见桌面背景)那是因为你的桌面开启了3D的原因,把视觉效果关了就ok了。
2,我觉得常用论坛-硬件列表里面的-ati官方驱动(非开源)的安装配置(08/01/19),compiz用户不推荐更新这个帖子些得不全,我这是对它的一个补充。他那没有提我些的第6步 编译内核模块并安装 这个很重要,是装好驱动的关键

3,如果第2步不能创建deb包,那你就放弃这个办法了,我也没办法。8.42.3就是死活弄不成deb包。只好放弃


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-01 2:57 

注册: 2007-05-23 23:53
帖子: 69
送出感谢: 0 次
接收感谢: 0 次
我这再附加个官方的安装过程
http://wiki.cchtml.com/index.php/Ubuntu
里面有5.10---8.04的安装方法
我这把UBUNTU8.04安装8.4驱动的贴上 我想不需要我翻译了吧
Download the installer: ati-driver-installer-8-4-x86.x86_64.run (this installer is for 32bit and 64bit systems)
Follow These Instructions Carefully

Switch to the directory you downloaded this into and the run the following. (Make sure universe and multiverse are enabled in your repository sources).

sudo apt-get update
sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r)

This installs the dependencies for the installer.


Using Synaptic, completely remove any packages containing "fglrx" in their name.

If using 64bit make sure to collect package "ia32-libs" and " libGL.so.1" before proceeding!


Remove any old fglrx .debs:

sudo rm /usr/src/fglrx-kernel*.deb


Now use the following command to create the .deb files you will be using for installation:

sudo sh ati-driver-installer-8-4-x86.x86_64.run --buildpkg Ubuntu/hardy

As an alternative, you can just use

sudo ./ati-driver-installer-8-4-x86.x86_64.run --buildpkg Ubuntu --autopkg


Now we have to blacklist the driver in Ubuntu's repository. This is so it doesn't ever overwrite our installation.

sudo gedit /etc/default/linux-restricted-modules-common

Add "fglrx" to the line "DISABLED_MODULES"
File: /etc/default/linux-restricted-modules-common

DISABLED_MODULES="fglrx"


Please note that after the modification above, the "Restricted Driver Manager" will signal "ATI accelerated graphics driver" not enabled (unticked). This is perfectly correct. At the end of the installation procedure it will signal in Status: "in use" (green light), but NOT enabled. It simply means that the fglrx module contained in the linux-restricted-modules package is not enabled, but another fglrx module (8.4) is in use.

You may also need to edit the file (if it exists):

sudo gedit /etc/modprobe.d/blacklist-restricted

Put a # in front of the line "blacklist fglrx", if it is present. Otherwise, the kernel module will not load automatically, and you will not get 3D acceleration.

Install .debs:

sudo dpkg -i xorg-driver-fglrx_8.476*.deb fglrx-kernel-source_8.476-0*.deb fglrx-amdcccle_8.476-0*.deb


[edit] Additional 64-bit instructions

If you have a 64 bit install, the above dpkg command will likely complain that "Errors were encountered while processing: fglrx-amdcccle". This is because of a dependency of the amdccle package on 32 bit libraries. If you receive this error, issue the following command after the above dpkg command, which will force the installation of all of the 32 bit dependencies, and then the amdccle package:

sudo apt-get install -f

Catalyst 8.4 on 64-bit systems requires the --force-overwrite command in the above dpkg command:

sudo dpkg -i --force-overwrite xorg-driver-fglrx_8.476*.deb fglrx-kernel-source_8.476-0*.deb fglrx-amdcccle_8.476-0*.deb

When installing the packages, if xorg-driver-fglrx_8.476 fails to install due to a diverted file conflict, you can fix the package with this procedure.


[edit] Finishing the Install: Configuration

Now you'll have to edit your xorg.conf

sudo gedit /etc/X11/xorg.conf

and add the following line to the Device section (if it does not already exist):

Section "Device"
[...]
Driver "fglrx"
[...]
EndSection

Save and exit, then run

sudo aticonfig --initial -f

in a terminal. If it does not error you should be fine. Finally, reboot the computer and type

fglrxinfo

into the terminal. If the vendor string contains ATI, you have installed the driver successfully.


Please note: Depending on the particular ATI card that you own, you may or may not automatically have all of the relevant driver features enabled. R5000 and R600 cards (X1xxx, HD seris, and newer) in particular will need TexturedVideo enabled in Xorg.conf (rather than the traditional VideoOverlay) in order to support Xv accelerated video playback.


[edit] Removing Mesa drivers

If fglrxinfo reports that Indirect rendering by Mesa is in place, even though you have installed ATI driver, check:

* Remove the package xserver-xgl.

Explanation: If you installed this previously in order to make compiz work, it will not allow direct rendering on your display. You can check out if this is what it causing the problem by running

DISPLAY=:0 glxinfo | grep render

If it returns an ATI renderer, it means that xgl is being displayed indirectly on the display 1. (Taken from [1])
Warning: This might make your compiz stop working as it is configured to use XGl. A solution might be to run the Envy script in order to configure compiz.
Also, if Compiz stopped working due to "Composite" problem, check that

Section "Extensions"
Option "Composite" "Enable"
EndSection


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译