当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 82 篇帖子 ]  前往页数 1, 2, 3, 4, 5, 6  下一页
作者 内容
1 楼 
 文章标题 : [教学]64位安装32位包.[更新]
帖子发表于 : 2007-12-21 21:02 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
昨天,帮同学安装了64位的ubuntu,发现安装i386的deb包时显示架构不支持,无法安装.当时感到很奇怪,我今年暑假安了一次suse64位,完全可以安装32位包,当时suse源上的firefox,openoffice都是i586包.查看了论坛找到如下方法:
首先安张32位库
sudo apt-get install ia32-libs*
sudo apt-get install getlibs #如果没有,到这个地址下http://frozenfox.freehostia.com/cappy/
然后就可以安装32位包
安装时加--force-architecture
然后用getlibs安装依赖库
,如
sudo dpkg -i --force-architecture cairo-dock*.deb
sudo getlibs cairo-dock


终于又可以用32位的软件了. :wink:
mplayer 安装w64看下贴:
http://forum.ubuntu.org.cn/viewtopic.php?t=94488


反安装用 sudo dpkg -P 软件名

sudo dpkg -P cairo-dock


最后由 syrano 编辑于 2008-05-11 9:11,总共编辑了 6 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-01 16:18 
头像

注册: 2007-07-02 20:53
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
昨天刚换成64位的
学习中
谢谢了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-08 12:46 
头像

注册: 2008-01-07 16:53
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
楼主帮大忙啦QQQ
有了64位的处理器安装32位的操作系统是在浪费计算资源啊。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-09 18:09 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
用新立得的怎么办?


_________________
Titainium


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-09 18:15 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
titainium 写道:
用新立得的怎么办?

源里的好像都有64位的吧,


最后由 syrano 编辑于 2008-01-10 18:27,总共编辑了 1 次

页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-10 14:31 
头像

注册: 2008-01-10 14:03
帖子: 223
送出感谢: 0 次
接收感谢: 0 次
我的amd的64位处理器安装的red hat 32位就是i686的包,用起来感觉一般才换成这个ubuntu的,应该比那个要好吧


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-10 17:56 
头像

注册: 2006-12-02 12:25
帖子: 689
送出感谢: 0 次
接收感谢: 0 次
不是说
引用:
sudo apt-get install ia32-libs*
然后就可以安装32位包
安装时加--force-architecture
,如
sudo dpkg --force-architecture -i opera_9.25-20071214.6-shared-qt_en_i386.deb

这样吗?
我要是通过新立得安装32位软件怎么玩?可以选上--force-architecture吗?


_________________
Titainium


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-02-01 19:48 
头像

注册: 2008-01-25 9:55
帖子: 285
地址: 深圳中學高中部
送出感谢: 0 次
接收感谢: 1
经典啊 :!:


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-02-05 19:14 

注册: 2007-12-03 22:49
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
成功运行Opera9.50,谢谢楼主


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-02-07 1:55 
头像

注册: 2008-01-07 16:53
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
flying.space 写道:
成功运行Opera9.50,谢谢楼主
我运行OPERA提示找不到libqt-mt.so.3后来我安装了EVA有了这个kde的库成功运行OPERA9.50B。同样QQQ楼主


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-02-23 3:57 

注册: 2007-02-09 23:36
帖子: 90
地址: China
送出感谢: 0 次
接收感谢: 0 次
dr_liu 写道:
flying.space 写道:
成功运行Opera9.50,谢谢楼主
我运行OPERA提示找不到libqt-mt.so.3后来我安装了EVA有了这个kde的库成功运行OPERA9.50B。同样QQQ楼主

\
Opera9.50已有64的了


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-14 22:56 

注册: 2008-03-14 22:54
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
太感谢楼主了 ,这个很实用阿!


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-21 16:54 
头像

注册: 2007-08-11 16:33
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我用了楼主说的办法
怎么显示这种情况?


123@123-laptop:/media/disk-2$ sudo dpkg --force-architecture -i opera_9.50b-20071024.6-shared-qt_en_i386.deb
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
软件包的体系架构(i386)与本机系统的架构(amd64)不符
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 102620 个文件和目录。)
正在解压缩 opera (从 opera_9.50b-20071024.6-shared-qt_en_i386.deb) ...
正在设置 opera (9.50-20071024.6) ...

123@123-laptop:/media/disk-2$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.50-20071024.6/opera: error while loading shared libraries: libqt-mt.so.3: wrong ELF class: ELFCLASS64


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-21 17:03 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
Mutial 写道:
我用了楼主说的办法
怎么显示这种情况?


123@123-laptop:/media/disk-2$ sudo dpkg --force-architecture -i opera_9.50b-20071024.6-shared-qt_en_i386.deb
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
软件包的体系架构(i386)与本机系统的架构(amd64)不符
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 102620 个文件和目录。)
正在解压缩 opera (从 opera_9.50b-20071024.6-shared-qt_en_i386.deb) ...
正在设置 opera (9.50-20071024.6) ...

123@123-laptop:/media/disk-2$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.50-20071024.6/opera: error while loading shared libraries: libqt-mt.so.3: wrong ELF class: ELFCLASS64

opera依赖libqt3-mt
sudo apt-get install libqt3-mt
不过opera已经有64位的了,可以直接安装64位的opera


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-04-22 5:51 
头像

注册: 2007-08-30 5:39
帖子: 1670
送出感谢: 0 次
接收感谢: 0 次
谢谢,试试星际译王现。


_________________
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 82 篇帖子 ]  前往页数 1, 2, 3, 4, 5, 6  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译