当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2012-11-18 12:37 

注册: 2012-10-06 21:03
帖子: 6
系统: edubuntu 12.10
送出感谢: 0 次
接收感谢: 0 次
打开ubuntu 12.10 的时候,右上角总是提示检查更新时发生了错误,无法打开软件中心,图标亮几下就没反应了。
但是在 系统设置--详细信息里面却说系统已是最新。
这个问题困扰我很久了,之前用ubuntu 12.04的时出现了这个问题,于是就换成12.10了,但是不知道怎么的还是这样。

输入/usr/bin/software-center时,显示如下:

File "/usr/bin/software-center", line 140
print time.time()
^
SyntaxError: invalid syntax

希望各位能够帮忙解决这个问题,在下感激不尽。


附件:
菜单_003.png
菜单_003.png [ 10.33 KiB | 被浏览 5794 次 ]
页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2012-11-18 12:51 
头像

注册: 2009-07-31 18:56
帖子: 1670
地址: 广东阳江
系统: windows、ubuntu
送出感谢: 7
接收感谢: 20
首先,备份一下Ubuntu 12.10 原来的源地址列表文件

代码:
sudo cp /etc/apt/sources.list /etc/apt/sources.list.old


然后进行修改
代码:
sudo gedit /etc/apt/sources.list


打开sources.list后删除文档内的所有内容 将以下的内容直接复制进去
代码:
#网易的源(163源,无论是不是教育网,速度都很快)
deb http://mirrors.163.com/ubuntu/ quantal main universe restricted multiverse
deb-src http://mirrors.163.com/ubuntu/ quantal main universe restricted multiverse
deb http://mirrors.163.com/ubuntu/ quantal-security universe main multiverse restricted
deb-src http://mirrors.163.com/ubuntu/ quantal-security universe main multiverse restricted
deb http://mirrors.163.com/ubuntu/ quantal-updates universe main multiverse restricted
deb http://mirrors.163.com/ubuntu/ quantal-proposed universe main multiverse restricted
deb-src http://mirrors.163.com/ubuntu/ quantal-proposed universe main multiverse restricted
deb http://mirrors.163.com/ubuntu/ quantal-backports universe main multiverse restricted
deb-src http://mirrors.163.com/ubuntu/ quantal-backports universe main multiverse restricted
deb-src http://mirrors.163.com/ubuntu/ quantal-updates universe main multiverse restricted

然后终端中运行
代码:
sudo apt-get update
即可。
想使用回官方源就打开系统设置-软件源,在里面设置一下就可以了。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2012-11-18 13:28 

注册: 2012-10-06 21:03
帖子: 6
系统: edubuntu 12.10
送出感谢: 0 次
接收感谢: 0 次
你好,我按照你的方法试了下,结果还是不行,不过还是谢谢你了。
我怀疑是不是我Python的原因,那个错误好像是Python中的错误。
之前我按照自己想法以及参考别人的方法安装了Python3.3
如下:
代码:
sudo rm /usr/bin/python
sudo cp /home/sunmo/Python-3.3.0/python /usr/local/python
sudo ln /usr/local/python* /usr/bin/python


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2012-11-18 13:30 

注册: 2012-10-06 21:03
帖子: 6
系统: edubuntu 12.10
送出感谢: 0 次
接收感谢: 0 次
你好,我按照你的方法试了下,结果还是不行,不过还是谢谢你了。
我怀疑是不是我Python的原因,那个错误好像是Python中的错误。
之前我按照自己想法以及参考别人的方法安装了Python3.3
如下:
代码:
sudo rm /usr/bin/python
sudo cp /home/sunmo/Python-3.3.0/python /usr/local/python
sudo ln /usr/local/python* /usr/bin/python


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2012-11-18 23:17 

注册: 2012-10-06 21:03
帖子: 6
系统: edubuntu 12.10
送出感谢: 0 次
接收感谢: 0 次
原来就是python的问题,我将python3又改回py2.7了,然后就正常了,万幸。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2013-01-20 22:28 

注册: 2012-05-11 21:37
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
sunmo 写道:
原来就是python的问题,我将python3又改回py2.7了,然后就正常了,万幸。

同问,怎么改回py2.7了


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu 12.10检查更新发生了错误,软件中心也无法打开
帖子发表于 : 2018-04-13 14:54 

注册: 2018-04-13 14:52
帖子: 1
系统: ubuntu
送出感谢: 0 次
接收感谢: 0 次
就是Python 的锅==

将默认的Python改回原来系统自带的就好了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Exabot [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译