当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]重装XP、DOS后无法进入ubuntu了
帖子发表于 : 2008-01-11 18:00 

注册: 2008-01-09 21:16
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
起初只有xp系统

两块硬盘,第一块硬盘分区为C、D、E
第二块硬盘分区为G、H、I、J
均为NTFS分区

安装ubuntu时,删除了G和I区,

只用其中的一个装ubuntu,分了/、/boot、/swap
另一个空闲(状态free)

后对xp进行了修复安装,并将空闲的空间格式化为FAT32格式,盘符为G
这时直接进入xp

之后安装maxdos v6,
重启进入xp、maxdos选择菜单

用live cd运行ubuntu
find /boot/grub/stage1 提示 not found ,
上网查询得知有 /boot 直接运行find /grub/stage1
得知 hd(1,6)

root (hd1,6)
setup(hd1)

提示 find /boot/grub/stage1 no
其他是yes,success

但是重启后仍然无法进入ubuntu,
只能选择xp或maxdos

请大虾帮忙,谢谢了

感激,感激

我按的是7.10


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-12 0:27 

注册: 2007-12-25 10:41
帖子: 313
送出感谢: 0 次
接收感谢: 0 次
你是否将UBUNTU装在了I盘?
如果是这样,你把FREE的空间格成FAT32盘符为G,那改变了分区顺序,LINUX引导会出现问题。
你可以安装GRUB4DOS,启动修复UBUNTU启动菜单。使用方法见论坛。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-12 11:37 

注册: 2008-01-09 21:16
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
不行啊
我在menu.lst加入

rootnoverify (hd1,6)
makeactive
chainloader +1

提示
error 13:Invalid Device Requested


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-13 16:13 
头像

注册: 2006-08-27 11:50
帖子: 418
送出感谢: 0 次
接收感谢: 0 次
这样的问题有很多人问过。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-13 16:14 
头像

注册: 2006-08-27 11:50
帖子: 418
送出感谢: 0 次
接收感谢: 0 次
楼主好好搜一下,一定能得到答案。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译