[分享]AMD64位无法安装flash的解决方案

为当前最终发行版之前的所有版本提供支持
回复

你成功了吗?

成功了!
18
90%
失败,还是安装不上
2
10%
 
总计票数: 20
xianyuhui
帖子: 75
注册时间: 2007-11-12 20:41
送出感谢: 0
接收感谢: 0

[分享]AMD64位无法安装flash的解决方案

#1

帖子 xianyuhui » 2008-01-13 2:46

我以前安装flash总是安装不上,无论是用firefox自己找插件安装或者用新立得,安装完上flash网站还是提示没有安装flash.
可能64位的有点麻烦,找了好长时间终于找到了方法,我的是7.10,刚成功就写个帖子,不感独享

首先下载flash player 9
http://fpdownload.macromedia.com/get/fl ... nux.tar.gz

解压得到install_flash_player_9_linux文件夹(不会用命令解压的,右键“用归档管理器“解压)

把里面的“libflashplayer.so” 和 “flashplayer-installer”2个文件复制到 /usr/lib/mozilla/plugins 目录下

代码: 全选

sudo cp flashplayer-installer libflashplayer.so  /usr/lib/mozilla/plugins
然后执行下面的命令

代码: 全选

nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
如果没有返回任何错误信息就说明这步成功了

然后


代码: 全选

cd ~/.mozilla/plugins/
查看一下有没有npwrapper.libflashplayer.so这个文件

代码: 全选

ls
把这个文件复制到/usr/lib/mozilla/plugins/和/usr/lib/mozilla-firefox/plugins/ 下面
命令如下

代码: 全选

sudo cp npwrapper.libflashplayer.so /usr/lib/mozilla/plugins/ /usr/lib/mozilla-firefox/plugins/

最后重启浏览器,试试能不能看flash了
http://www.youtube.com/


如果不成功,参考一下这个帖子,我只是用了他的第二种方法,原文是E文,我简单翻译了一下
文中还提到用rpm包转换成deb包的,没注意看

http://ubuntuforums.org/showthread.php?t=341727
头像
lwaterl
帖子: 379
注册时间: 2007-08-24 17:46
送出感谢: 14 次
接收感谢: 2 次

#2

帖子 lwaterl » 2008-01-23 20:45

呵呵,第一个使用者,成功!! :P
头像
jobinson99
帖子: 1169
注册时间: 2007-04-28 15:14
系统: NixOS+虚拟机各种系统
送出感谢: 0
接收感谢: 5 次
联系:

#3

帖子 jobinson99 » 2008-01-25 16:02

成功了!
建议楼主再编辑一下:首先,怎么定位那个下下来的压缩包:打开终端,cd 下载的文件路径,然后再执行你的第一条命令。——像我这种菜鸟,就经常搞不明白,导致第一步就进行不了了。
然后,最后那个命令里面,那后面那个cp /user/mozila-firefox/plugin那个文件夹我没有,但也成功了!这个是不是必须的?

ps:楼主的方法是我见过的类似的解决方法中最简单可行的!赞下。
头像
zebrattt
帖子: 629
注册时间: 2007-11-12 14:27
来自: 地球的角落
送出感谢: 0
接收感谢: 2 次

#4

帖子 zebrattt » 2008-09-12 11:26

非常感谢。 我说我怎么有时会有问题,以前没有意识到我amd64的机器装flash plugin for firefox需要特别的方法。

我是ubuntu 8.04
头像
cat650
帖子: 382
注册时间: 2009-05-18 13:51
送出感谢: 2 次
接收感谢: 2 次

Re: [分享]AMD64位无法安装flash的解决方案

#5

帖子 cat650 » 2009-06-07 16:56

ubuntu9。04 amd64
很不幸,我失败了。不过使用了其他方法,最终还是成功了。
分享如下:首先,更新 firefox的 flash插件为10 。进入opera配置中,查看flash插件指向位置。把firefox已经安装好的插件,复制过去。完成
我目前,可以收看所有flash,不再提示版本不够。除了土豆网 的
另外,adobe公司已经推出 linux -amd64-flash10 插件(含opera)。只是很奇怪,地址是在其官网,不过从主页找不到相关连接。大家只有搜搜了
活着谁不像一场炼狱,已经没有什么可以放弃……

http://cat650.iok.la:650我们唯一的自由就是我们的大脑。
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

Re: [分享]AMD64位无法安装flash的解决方案

#6

帖子 hcym » 2009-06-07 17:03

cat650 写了:ubuntu9。04 amd64
很不幸,我失败了。不过使用了其他方法,最终还是成功了。
分享如下:首先,更新 firefox的 flash插件为10 。进入opera配置中,查看flash插件指向位置。把firefox已经安装好的插件,复制过去。完成
我目前,可以收看所有flash,不再提示版本不够。除了土豆网 的
另外,adobe公司已经推出 linux -amd64-flash10 插件(含opera)。只是很奇怪,地址是在其官网,不过从主页找不到相关连接。大家只有搜搜了
主页http://labs.adobe.com/downloads/flashplayer10.html
插件为
libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz
安装通用Flash:
tar -xzvf libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz
sudo mkdir /usr/lib/mozilla/plugins
sudo mkdir ~/.mozilla/plugins
sudo mkdir -p /usr/lib/firefox/plugins
sudo mkdir -p /usr/lib/mozilla/plugins
sudo cp ~/libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so
链接:
sudo ln -s /usr/lib/mozilla/plugins/libflashplayer.so ~/.mozilla/plugins/libflashplayer.so
sudo ln -s /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox/plugins/libflashplayer.so
头像
mm740
帖子: 300
注册时间: 2009-08-09 17:34
送出感谢: 0
接收感谢: 0

Re: [分享]AMD64位无法安装flash的解决方案

#7

帖子 mm740 » 2009-10-10 16:04

程序 'nspluginwrapper' 尚未安装。
淡定,不要听风就是雨。淡定是一种境界,是一种超然世外的意识。只有修养达到一定阶段,才能产生并拥有。拥有了淡定,就拥有了风度。于是淡定便成了一种气质,让我辈无论如何努力和奋斗,始终难望其项背。淡定需要时间和实践的积淀和净化,是一种拨云见日,是一种豁然开朗!君子坦荡荡,小人长戚戚。愿我们除了自卑多了自由,少了忙乱多了从容,去了怨恨多了温煦,戒了偏激多了沉着。一切在淡定中发展,在淡定中凯旋。
头像
keyce
帖子: 77
注册时间: 2009-03-26 12:32
送出感谢: 0
接收感谢: 0

Re: [分享]AMD64位无法安装flash的解决方案

#8

帖子 keyce » 2010-04-10 21:47

mm740 写了:程序 'nspluginwrapper' 尚未安装。
nspluginwrapper
is not install!!!

代码: 全选

[b]a reply from keyce.[/b]
回复

回到 “老旧版本支持”