how to install scim?

为当前最终发行版之前的所有版本提供支持
回复
头像
ct
帖子: 2201
注册时间: 2005-04-06 21:15
来自: 安徽黄山
送出感谢: 0
接收感谢: 0
联系:

how to install scim?

#1

帖子 ct » 2006-02-22 15:26

It have scim ,but no scim-pinyin and so on.
because of no scim ,can't install full language support.
linux_lyb
帖子: 38
注册时间: 2005-08-30 14:36
送出感谢: 0
接收感谢: 0

#2

帖子 linux_lyb » 2006-02-22 21:08

apt-get install scim-pinyin
zigzed
帖子: 267
注册时间: 2006-02-27 10:32
送出感谢: 0
接收感谢: 0

Re: how to install scim?

#3

帖子 zigzed » 2006-03-15 15:21

ct 写了:It have scim ,but no scim-pinyin and so on.
because of no scim ,can't install full language support.
dapper默认安装了 scim 的某些模块, 但是没有包含中文输入法. 你需要在 /etc/apt/sources.list 中打开源 (我使用的是 cn.archive.ubuntu.com 的源). 然后安装 scim-pinyin 和其他没有安装的依赖包.
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-03-15 20:32

只要安装scim-chinese就可以了。pinyin会自动带上的。比breezy安装可以省己几个了。
● 鸣学
头像
HYBOO_QIU
帖子: 84
注册时间: 2005-12-05 14:52
送出感谢: 0
接收感谢: 0

#5

帖子 HYBOO_QIU » 2006-03-18 16:34

~$ apt-get install scim-pinyin
E: 无法打开锁文件 /var/lib/dpkg/lock - open (13 权限不够)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
why?wht's wrong?
头像
firingstone
帖子: 336
注册时间: 2005-07-11 17:37
来自: 浙江
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 firingstone » 2006-03-18 17:04

光盘上没有完全的中文支持所以要执行下面的命令

代码: 全选

sudo apt-get install language-pack-gnome-zh language-pack-gnome-zh-base language-pack-zh language-pack-zh-base language-support-zh
与breezy不同的是,在执行上面命令时也会附带安装输入法的中文支持,如scim-pinyin

还有5楼的朋友在命令前要加上sudo

代码: 全选

sudo apt-get install scim-pinyin
ubuntu 5.10 +windowsxpsp2
HP NX6120
PM1.6+512M DDR333+915GM+40G HD+Combo

Life is Struggle!
bonnei
帖子: 13
注册时间: 2006-01-31 14:13
送出感谢: 0
接收感谢: 0

#7

帖子 bonnei » 2006-03-23 0:38

I have the same question.
axl@ubuntu:~$ sudo apt-get install scim-chinese
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
scim-chinese: 依赖: scim (>= 1.0.2) 但是它将不会被安装
依赖: scim (< 1.1) 但是它将不会被安装
E: 无法安装的软件包
install scim-pinyin,but....
axl@ubuntu:~$ sudo apt-get install scim-pinyin
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
现在没有可用的软件包 scim-pinyin,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 scim-pinyin 还没有可供安装的候选者
Could you help me?Thanks!
[/quote]
头像
nmvr2600
帖子: 215
注册时间: 2005-11-01 18:23
送出感谢: 0
接收感谢: 0

#8

帖子 nmvr2600 » 2006-03-23 14:11

记得安装的时候没装全中文支持是没有什么问题的,在系统语言选择里重新选下中文,系统会自动检查的,然后提示你要不要安装。点个是就好了。系统自己搞定。不用自己apt。
懒人的方法 :wink:
We are both God and devil.
----------------------------------
Oracle 11G SG PPT下载
回复

回到 “老旧版本支持”