当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 硬盘安装XP和UBUNTU双系统,怎么引导UBUNTU
帖子发表于 : 2008-01-16 13:14 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
硬盘安装~~前面引导安装的过程还顺利下来,
但是到最后(“97% 正在清理” 之后)有个提示框,关于grub的,大概内容如下:
——————————————————————————————————————————————-——
安装程序在这台计算机上探测到了以下其他操作系统 Microsoft Windows XP Professional
如果以上列出您所有的操作系统那么您应该可以安全地将启动引导器安装到第一块硬盘的引导记录(MBR)上。
但计算机启动时,您应该可以选择以上任意一种操作系统或者您的新系统。

将GRUB启动引导器安装到主引导记录(MBR)上吗?
返回 是 否

——————————————————————————————————————————————————

我第一次装的选择 是
然后重启就出现提示如下:
GRUB Loading stage1.5
GRUB loading ,please wait...
Error 5

然后机子就不动了

重新还原之后,ubuntu没了,进入XP,再次重装UBUNTU,
这次还是到这里我选择 否,再填写安装在 /dev/hda8上 ,重启,之后没有ubuntu的启动项,我想先进XP来网上查查到底怎么设置,
但是查了半天也没有什么结果,

第三次还是到那里我选择返回
然后选择: 不安装GRUB,继续
重启,没UBUNTU启动项,进XP,来到了这里,
有没有高手帮我看看怎么解决,
郁闷死了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-16 13:15 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
安装过程有这个提示,但是我看其他的说明解释等等,都没提到这个提示,


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-16 14:26 

注册: 2008-01-16 10:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我通过硬盘的iso安装时也遇到过类似的情况...而且还因为修复不了引导区只能连xp一起重装...

LZ可以参考一下我回的另一个帖子:
[问题]准备在Ubuntu系统下全新安装XP双系统……求高人指点Grub设置


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-16 15:02 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
关键是UBUNTU都进不了,怎么在UBUNTU下设置呢........


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-16 15:14 

注册: 2008-01-16 10:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
...不是在ubuntu下设置啊...我说的那个menu.lst文件是在我的c盘的...

你不是也是在硬盘通过iso安装的么? 我是用grub for dos引导的, 修改的menu.lst是for dos那个, 不是ubuntu里面那个...我连ubuntu的grub引导都没有安装...所以/boot分区里面连grub目录都没有, 更别说有menu.lst了...


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-16 16:20 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
root (hd0,5)
kernel /vmlinuz root=/dev/sda7 ro quiet splash vga=769
initrd /initrd


原来C盘里有menu.lst文件了,我打开然后把这三行加后面,还是清空了只写这三行?


n -s initrd.img-2.6.22-14-generic initrd
ln -s vmlinuz-2.6.22-14-generic vmlinuz
这两行加在前面?

(hd0,5)
在哪里可以查看啊,
我估计我的是 (hd0,7) //sda8
但是不确定,想确定一下,


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-16 16:47 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
我乱设置了几次,都进不了,唉,人太笨了没办法啊,
那个boot.ini怎么写呢?

我改了menu.lst,
boot.ini是安装引导时写的: c:\grldr="instal ubuntu"
我重启时,只有windows xp和instal ubuntu
选择instal ubuntu后竟然提示windows缺失什么文件,要重新拷贝
之后重启,进XP,回到这里等高人指点......


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-01-16 17:47 

注册: 2008-01-16 10:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
vollanu11 写道:
root (hd0,5)
kernel /vmlinuz root=/dev/sda7 ro quiet splash vga=769
initrd /initrd


原来C盘里有menu.lst文件了,我打开然后把这三行加后面,还是清空了只写这三行?


n -s initrd.img-2.6.22-14-generic initrd
ln -s vmlinuz-2.6.22-14-generic vmlinuz
这两行加在前面?

(hd0,5)
在哪里可以查看啊,
我估计我的是 (hd0,7) //sda8
但是不确定,想确定一下,


或者你把分区表述一下吧, 例如c盘, d盘.../, SWAP等

sda8是(hd0,7), hd0指第1个硬盘, 如果2个硬盘或以上则hd1, hd2类推

刚才用apt-get更新完, 马上进不了系统...原因是手动添加到link被删掉了...其实不是删掉, 是我/boot分区的格式有ext3变成ext2了...刚刚确认了一下, 不是分区格式变了, 是initrd这个link被删掉了...可能是做upgrade时被rm initrd*了...

之后我把这2行

kernel /vmlinuz root=/dev/sda7 ro quiet splash vga=769
initrd /initrd

改回

kernel /vmlinuz-2.6.22-14-generic root=/dev/sda7 ro quiet splash vga=769
initrd /initrd.img-2.6.22-14-generic

又可以启动了...

menu.lst好像不是c盘那个吧, 我记得是c盘boot\grub目录下的那个menu.lst

不是只加这3行, 我是把

Title Ubuntu xxx(忘了...)
find xxx
kernel xxx
initrd xxx

复制了一次, 然后上面

<前面其他内容保留>
Title Ubuntu xxx(忘了...) //这个就换成ubuntu, 只是选择时显示的标题而已, 无啥用处
find xxx //改成: root (hd0,5) //请根据实际情况再修改
kernel xxx //改成: kernel /vmlinuz-2.6.22-14-generic root=/dev/sda7 ro quiet splash vga=769 //root=/dev/sda7 也根据实际需要改
initrd xxx //改成: initrd /initrd.img-2.6.22-14-generic

//在menu.lst里粘贴多一份
Title Install Ubuntu //我把复制出来的直接跟在原来的后面, 然后名字改成install ubuntu, 因为还能用他来引导iso文件的
find xxx
kernel xxx
initrd xxx
<后面其他内容保留>

然后再xp的选单(就是boot.ini)里选ubuntu那个东东, 就会多了一个选项, 原来的第1个被替换成启动硬盘ubuntu的命令了...


最后由 mudinlove 编辑于 2008-01-16 18:02,总共编辑了 1 次

页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-16 18:01 

注册: 2008-01-16 10:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
vollanu11 写道:
我乱设置了几次,都进不了,唉,人太笨了没办法啊,
那个boot.ini怎么写呢?

我改了menu.lst,
boot.ini是安装引导时写的: c:\grldr="instal ubuntu"
我重启时,只有windows xp和instal ubuntu
选择instal ubuntu后竟然提示windows缺失什么文件,要重新拷贝
之后重启,进XP,回到这里等高人指点......


没有遇到过需要重新拷贝文件呢...或者你把网上download下来的压缩包再解压一次, 再拷贝去c盘一次吧...

那个grldr我一直用得好好的...就拷贝了一次而已...还在用...


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-01-16 20:05 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
进入的是booting画面

booting 'Ubuntu'
_


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-01-16 20:11 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
我本来是C,D,E,F盘,
分F两份,一份SWAP,剩下的安装UBUNTU,(SWAP在前,实际装UBUNTU在最后)

进入booting 'Ubuntu'
下面有个光标闪动,然后就一直没什么反应
然后就没什么反应了,
我以前装的时候是跳过,GRUB安装的,

现在是想在XP下看有什么办法可以设置装好GRUB,引导 Ubuntu,
要是不行那就给他默认安装看看咯,
两个系统都进不了,也只好再修复了,
如此反复反复


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-01-16 21:45 

注册: 2008-01-16 10:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
vollanu11 写道:
我本来是C,D,E,F盘,
分F两份,一份SWAP,剩下的安装UBUNTU,(SWAP在前,实际装UBUNTU在最后)

进入booting 'Ubuntu'
下面有个光标闪动,然后就一直没什么反应
然后就没什么反应了,
我以前装的时候是跳过,GRUB安装的,

现在是想在XP下看有什么办法可以设置装好GRUB,引导 Ubuntu,
要是不行那就给他默认安装看看咯,
两个系统都进不了,也只好再修复了,
如此反复反复


这是我修改后使用的menu.lst文件(c盘boot/grub目录下的那个)

<文件开始, 这行不用拷贝>
timeout 5
default 0

find --set-root /boot/grub/fonts.chs

splashimage /boot/grub/bj2008.xpm.gz
fontfile /boot/grub/fonts.chs

title Ubuntu 7.10
root (hd0,5)
kernel /vmlinuz-2.6.22-14-generic root=/dev/sda7 ro quiet splash vga=769
initrd /initrd.img-2.6.22-14-generic

title Install Ubuntu 7.10
find --set-root /boot/grub/fonts.chs
kernel /boot/gutsy/vmlinuz boot=gnix_oag ramdisk_size=1048576 root=/dev/ram rw quiet splash debian-installer/locale=zh_CN fd_dir=gutsy vga=769
initrd /boot/gutsy/initrd.gz

title One Key Ghost
find --set-root /boot/grub/fonts.chs
kernel /boot/grub/mem_disk.gz c=120 h=2 s=36 floppy
initrd /boot/grub/ghost_1.gz c=120 h=2 s=36 floppy

title Start DOS
find --set-root /boot/grub/fonts.chs
kernel /boot/grub/mem_disk.gz c=64 h=8 s=36 floppy
initrd /boot/grub/dos98.gz c=64 h=8 s=36 floppy

title Return
rootnoverify (hd0,0)
makeactive
chainloader +1
<文件结束, 这行不用拷贝>

就是原来的那个menu.lst增加了几行而已...


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-01-16 21:56 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
OK,搞定了 ,
刚刚我自己想了一下整个安装过程,
我想起了我第一次安装的时候的错误提示,
GRUB Loading stage1.5
GRUB loading ,please wait...
Error 5
觉得是因为安装GRUB和LOADING的时候路径有问题,
才发现我之前是用PM分硬盘的,并且提前定义了文件系统,
以及分区,所以出现分区混乱问题,
然后和安装UBUNTU最后默认安装的引导不符,
现在解决了,
安装到最后重启的时候我都没敢看,关上门,跑客厅看电视去了,
最后从窗口发现闪黄光,兴奋的跑进卧室,
现在就在UBUNTU下回复的,嘿嘿嘿嘿......

一个偷懒 害我弄了几天,唉,



另外多谢mudinlove,真是个热心人,好人好运哈,


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-01-16 21:58 

注册: 2008-01-15 23:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
不过弄了这么些日子,
让我认识了引导的一堆东西,
算是塞翁失马焉知祸福啊


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-01-16 22:06 

注册: 2008-01-16 10:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
呵呵, LZ客气了, 我也只是菜鸟一个, 只是碰巧也在安装而已, 而且遇到的问题正巧类似呵呵, 大家一起研究探讨一下也无坏啊...


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译