当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : NTFS 分区无法显示中文
帖子发表于 : 2008-01-22 18:57 

注册: 2007-07-26 10:50
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
版本:7.10
安装了ntfs-3g、ntfs-config,挂载了XP的C盘、D盘,但是无法显示中文文件名,用ntfs-config设置后,正常显示,但重启后又无法显示,每次都要设置一下。奇怪得很!!!

/etc/fstab相关内容如下:

# Entry for /dev/sda1 :
UUID=CEA8767DA87663BD /media/sda1 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda5 :
UUID=5290F86190F84D4B /media/sda5 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1

各位看看是怎么回事。7.4版没有这个问题。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-22 20:57 
头像

注册: 2006-08-20 11:26
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
代码:
# Entry for /dev/sda5 :
UUID=137FC8E0CF5CC0C1 /media/sda5 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda6 :
UUID=328CB83F8CB7FF81 /media/sda6 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda7 :
UUID=5228BC1C28BC00D1 /media/sda7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1

把我的文件给你写上来,参考一下吧,我也用GUSTY,安装完成后就可以用了。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-22 21:00 
头像

注册: 2006-08-20 11:26
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
还有啊,你说的那个ntfs-config只是配置“启用内部设备写支持”啊,和显示不显示中文有没有什么关系呢?


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-23 8:58 

注册: 2007-07-26 10:50
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我也不清楚,反正每次修改一下ntfs-config就可以显示中文,好象是要刷新一下似的。为了能写入,我现在不得不每次先取消“启用内部设备写支持”,然后再打开。反正是很烦!!!!!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-24 1:23 

注册: 2007-12-25 10:41
帖子: 313
送出感谢: 0 次
接收感谢: 0 次
cheertree 写道:
代码:
# Entry for /dev/sda5 :
UUID=137FC8E0CF5CC0C1 /media/sda5 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda6 :
UUID=328CB83F8CB7FF81 /media/sda6 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda7 :
UUID=5228BC1C28BC00D1 /media/sda7 ntfs-3g defaults,locale=zh_CN.UTF-8 0 1

把我的文件给你写上来,参考一下吧,我也用GUSTY,安装完成后就可以用了。


的确是系统装好就已经有NTFS的读写加中文支持,看来楼主喜欢独立显卡独立声卡独立网卡拒绝捆绑。。。。。。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-25 11:31 

注册: 2007-07-26 10:50
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
看看我的fstab:
代码:
# /etc/fstab: static file system information.
#
#  -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc /proc proc defaults 0 0
# Entry for /dev/sda3 :
UUID=7702fe49-6dd0-4b2d-ac8b-5ba623295985 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/sda4 :
UUID=09048c20-fa7a-4108-ab3d-24aa30a890c6 /boot ext3 defaults 0 2
# Entry for /dev/sda8 :
UUID=a6c199ed-5240-427d-bad7-22e6069c15e3 /home ext3 defaults 0 2
# Entry for /dev/sda1 :
UUID=CEA8767DA87663BD /media/C ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda5 :
UUID=5290F86190F84D4B /media/D ntfs-3g defaults,locale=zh_CN.UTF-8 0 1
# Entry for /dev/sda6 :
UUID=a71e9326-29c1-4626-969d-c5a835e25136 /usr ext3 defaults 0 2
# Entry for /dev/sda7 :
UUID=ce8465f6-9969-4cb7-822d-3a6445e4963d none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0


好像没啥问题阿


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-02-19 18:44 
头像

注册: 2007-10-14 16:06
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
到底咋搞哦?
我也不显示的,每次开机都要先卸载,再重新挂载的.
也好烦哦. :(


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-04-14 22:27 
头像

注册: 2008-04-04 11:22
帖子: 17
地址: 广东 揭阳
送出感谢: 0 次
接收感谢: 0 次
进etc找到fstab把里面的
# /dev/sda15
UUID=e5d2d8c7-679f-4bfc-936a-7d583d540615 /usr ext3 defaults 0 2
提到所有的NTFS之前。。或者你装ubuntu的时候不要分usr这个区就行了。。。。


_________________
菜鸟的梦想就是飞,总有一天,阳光会平洒在翅膀上……


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译