当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]求解:u盘安装系统,结果grub写到了u盘上
帖子发表于 : 2008-01-24 19:59 

注册: 2005-12-07 21:42
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
HP DL380 g5的机器,使用了raid,硬盘是cciss/c0d0。不带光驱
用这上面的方法来安装:http://blog.csdn.net/linyt/archive/2007/10/22/1837879.aspx

启动安装都没有问题,但最后发现写grub启动的时候,把u盘认为硬盘了,写到了这上面。

害的u盘也不能启动了,只出现GRUB,大于号>都没有。只有用usbboot重新做了才能用

现在没有办法去把grub写到硬盘上


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-24 20:59 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
估计那方法,少了chroot的步骤,就安装grub了。而且u盘,缺省被认成了sda1了的。一般是这样。

搞一个live启动,grub-install就是。搜索下。一般就是chroot先。


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-24 22:14 

注册: 2007-12-04 11:28
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
我还想把grub写到U盘上呢 可惜写不上啊 呵呵 你到是成功了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-25 10:32 

注册: 2005-12-07 21:42
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
经过多次实验后,手工一步步安装,最后跳过写grub,而是写lilo。
lilo的时候,给我选择了,写/dev/cciss/c0d0上。
grub的时候,就是怎么都不给选择的机会,郁闷。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-25 10:33 

注册: 2005-12-07 21:42
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
估计那方法,少了chroot的步骤,就安装grub了。而且u盘,缺省被认成了sda1了的。一般是这样。

搞一个live启动,grub-install就是。搜索下。一般就是chroot先。


没有光驱,而我在u盘上做live-cd,总是不成功。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [问题]求解:u盘安装系统,结果grub写到了u盘上
帖子发表于 : 2008-01-25 14:43 
头像

注册: 2006-09-13 23:59
帖子: 56
送出感谢: 0 次
接收感谢: 0 次
grub>
>root (hd1,0) #"root" 命令告诉 GRUB 到哪里查找辅助文件 stage1 和 stage2,如果默认u盘 启动的话 ,则u盘 为 hd0,机器内硬盘为 hd1#
>set(hd1) #将 告诉 GRUB 将引导装入器安装到硬盘的引导记录上#

>quit

restart


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译