谁可以教我装HD Audio CODECs阿

为当前最终发行版之前的所有版本提供支持
回复
尿不湿
帖子: 25
注册时间: 2006-02-01 11:07
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

谁可以教我装HD Audio CODECs阿

#1

帖子 尿不湿 » 2006-02-26 6:08

我把README贴出来
谁教我操作步骤阿
我的电脑是ASUS A6VM ALC880型号的声卡

下面是介绍的内容

谢谢拉

The source code copy from www.alsa-project.org. ver:3.3-4
Linux Source Code for ALC audio codec
Support Codec list:
====AC97 Codec=====
ALC100,100P
ALC200,200P
ALC650D
ALC650E
ALC650F
ALC650
ALC655
ALC653
ALC658
ALC658D
ALC850
ALC101
ALC202
ALC250
ALC203

====HD Audio codec ====
ALC260
ALC262
ALC880
ALC882
ALC883

Installation:
This Source Code is from www.alsa-project.org.
For driver installation, please follow below steps.

Automatic install:
execute

./install

Manual install:
Step 1. unzip source code
tar xfvj alsa-driver-1.0.9b_1.tar.bz2

Step 2. Turn on sound support (soundcore module, default turn on)

Step 3. Complied source code
a. cd alsa-driver-1.0.9b_1.
b. ./configure
c. make
d. make install
e. ./snddevices

Step 4. Edit your /etc/modules.conf or conf.modules depending on the distribution
(Please refer to the attached modules.conf)

snd-xxxx is the card ID.

-- Azalia controller --ALC880 ALC882 ALC260 ALC262
--- Intel ICH6 ICH7 ---------
snd-hda-intel
--- ATI chipset -----
snd-atiixp

-- AC97 controller --ALC655 ALC650 ALC250 ALC255
--- Intel ICH6 ICH7 , SiS 7012 and NVidia----------
snd-intel8x0
--- Via8233 Via686a -------------------------------
snd-via82xx
--- ATI Chipset -------------------------------
snd-atiixp

Copy and paste this to the bottom of your /etc/modules.conf or /etc/modprobe.conf file.
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-xxxx
# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Step 5. reboot your machine

Step 6. Use the alsamixer the disable mute (All audio line default is mute)
*Must to compile and to install the ALSA library and utility. (Use automatic install is already install)
excute alsamixer

Note: 1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt in the azx-021705.tar.bz2.
2. Kernel Version must be 2.2.14 or later.
3. All mixer channels are muted by default. You must use a native
or OSS mixer program to unmute appropriate channels.
4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.
5. The driver added to support the SPDIF functoin.
6. a. You can download the alsa-lib-1.0.9 and alsa-utils-1.0.9a form the www.alsa-project.org, then unzip and install them.
b. Suggest use "alsamixer" to control mixer function.
c. Used "alsaconf" can autodetect which drive you need to install (step 4).
7. SUSE Distribution must install the ncurses package.
秀发去无踪,头屑更出众
尿不湿
帖子: 25
注册时间: 2006-02-01 11:07
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 尿不湿 » 2006-02-27 15:34

已经解决了
ASUS A6VM 集成ALC880声卡发声了
秀发去无踪,头屑更出众
mahm
帖子: 3
注册时间: 2005-04-25 11:37
送出感谢: 0
接收感谢: 0

#3

帖子 mahm » 2006-02-28 20:00

尿不湿 写了:已经解决了
ASUS A6VM 集成ALC880声卡发声了
我也遇到了这个问题,能分享一下你的经验?谢谢。
tanhitzq
帖子: 10
注册时间: 2006-03-12 16:29
送出感谢: 0
接收感谢: 0

#4

帖子 tanhitzq » 2006-03-12 16:44

如何解决啊?
头像
dragonguy
帖子: 12
注册时间: 2006-04-29 11:36
送出感谢: 0
接收感谢: 0

#5

帖子 dragonguy » 2006-05-05 10:02

我也想知道如何解决!我的到现在都不能装上 :(
回复

回到 “老旧版本支持”