[问题]UBUNTU 8.04 ALPHA4,如何安装VM WORKSTATION6.02

为当前最终发行版之前的所有版本提供支持
回复
头像
Zeal0t
帖子: 95
注册时间: 2007-11-18 21:19
送出感谢: 0
接收感谢: 0

[问题]UBUNTU 8.04 ALPHA4,如何安装VM WORKSTATION6.02

#1

帖子 Zeal0t » 2008-02-08 1:10

安装到最后出了一大堆错,是不是6.02不支持8.04???sudo apt-get install linux-headers-`uname -r`已经安装了

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.24-5-rt/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config1/vmmon-only'
make -C /lib/modules/2.6.24-5-rt/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.24-5-rt'
CC [M] /tmp/vmware-config1/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config1/vmmon-only/./include/vmware.h:25,
from /tmp/vmware-config1/vmmon-only/linux/driver.c:83:
/tmp/vmware-config1/vmmon-only/./include/vm_basic_types.h:170: 错误: 与‘uintptr_t’类型冲突
include/linux/types.h:40: 错误: ‘uintptr_t’的上一个声明在此
在包含自 /tmp/vmware-config1/vmmon-only/./include/x86.h:23 的文件中,
从 /tmp/vmware-config1/vmmon-only/linux/driver.h:15,
从 /tmp/vmware-config1/vmmon-only/linux/driver.c:84:
/tmp/vmware-config1/vmmon-only/./include/x86cpuid.h:383:1: 警告: “BIT_MASK”重定义
在包含自 include/linux/kernel.h:15 的文件中,
从 /tmp/vmware-config1/vmmon-only/linux/driver.c:11:
include/linux/bitops.h:7:1: 警告: 这是先前定义的位置
在包含自 /tmp/vmware-config1/vmmon-only/./include/vmci_kernel_defs.h:26 的文件中,
从 /tmp/vmware-config1/vmmon-only/./common/vmciContext.h:19,
从 /tmp/vmware-config1/vmmon-only/linux/driver.h:21,
从 /tmp/vmware-config1/vmmon-only/linux/driver.c:84:
/tmp/vmware-config1/vmmon-only/./include/compat_wait.h:37:5: 警告: “VMW_HAVE_EPOLL”未定义
/tmp/vmware-config1/vmmon-only/./include/compat_wait.h:43:5: 警告: “VMW_HAVE_EPOLL”未定义
In file included from /tmp/vmware-config1/vmmon-only/./include/vmci_kernel_defs.h:26,
from /tmp/vmware-config1/vmmon-only/./common/vmciContext.h:19,
from /tmp/vmware-config1/vmmon-only/linux/driver.h:21,
from /tmp/vmware-config1/vmmon-only/linux/driver.c:84:
/tmp/vmware-config1/vmmon-only/./include/compat_wait.h:60: 错误: 与‘poll_initwait’类型冲突
include/linux/poll.h:65: 错误: ‘poll_initwait’的上一个声明在此
/tmp/vmware-config1/vmmon-only/linux/driver.c:198: 警告: 从不兼容的指针类型初始化
make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/driver.o] 错误 1
make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.24-5-rt'
make: *** [vmmon.ko] 错误 2
make: Leaving directory `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.
头像
Zeal0t
帖子: 95
注册时间: 2007-11-18 21:19
送出感谢: 0
接收感谢: 0

#2

帖子 Zeal0t » 2008-02-08 13:13

自己顶一下- -
头像
Zeal0t
帖子: 95
注册时间: 2007-11-18 21:19
送出感谢: 0
接收感谢: 0

#3

帖子 Zeal0t » 2008-02-08 17:13

用的是ANY0ANY0UPDATE115的补丁,貌似不行....
回复

回到 “老旧版本支持”