当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:硬盘安装ubuntu7.10,出现安装GRUB错误,详细如下
帖子发表于 : 2008-02-13 22:11 

注册: 2008-02-13 21:57
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
DELL INSPIRON 1501
AMD64 Athlon64

下载了ubuntu-7.10-desktop-amd64.iso
安装本论坛的安装方法,进行硬盘安装

进入了LIVECD的体验部分,然后点击install,进行安装
开始一切顺利,知道安装进度条的 94%左右,就是安装 grub_install(hd0)时发生 ERROR 17错误Cannot mount selected partition (重点在这)


没办法,然后手动
#GRUB
#ROOT (HD0,7)
setup (hd0)

还是发生error17错误

实在么办法了,希望各位老鸟们 指点一下明路啊

不胜感激。。。。。。。。。。。。。。。。。!!!

是品牌机的原因,还是BIOS?


页首
 用户资料  
 
2 楼 
 文章标题 : 分区选错了
帖子发表于 : 2008-02-14 13:08 

注册: 2007-12-23 19:14
帖子: 35
送出感谢: 0 次
接收感谢: 0 次
root (hd0,7),你要保证你的启动文件/boot/grub/stage1 等等文件在这个分区
root的意义也就在此,你也可以用命令帮助你找grub的文件
sudo -i
grub
find /boot/grub/stage1
然后就会返回你所要找的分区,我敢保证不是hd0,7,good luck!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 分区选错了
帖子发表于 : 2008-02-14 19:18 

注册: 2008-02-13 21:57
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
gwxzzlyzq 写道:
root (hd0,7),你要保证你的启动文件/boot/grub/stage1 等等文件在这个分区
root的意义也就在此,你也可以用命令帮助你找grub的文件
sudo -i
grub
find /boot/grub/stage1
然后就会返回你所要找的分区,我敢保证不是hd0,7,good luck!



的确没有,那是因为我的GRUB根本装不上

执行find /boot/grub/stage1时 file not found!


用WINDOWS 查看LINUX的工具却能看到有这个文件 在SDA5下,直接执行shell #cd /boot #ls -al grub*返回是空..............`


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-02-16 1:00 

注册: 2008-02-06 3:53
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
sudo -i 之后变成管理员,再执行这些命令就好了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译