问题:安装所以软件几乎都会出现警告warning......请问这是为什么

为当前最终发行版之前的所有版本提供支持
回复
admaliu
帖子: 12
注册时间: 2008-03-06 16:16
送出感谢: 0
接收感谢: 0

问题:安装所以软件几乎都会出现警告warning......请问这是为什么

#1

帖子 admaliu » 2008-03-07 1:31

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "zh_CN:zh:en_US:en",
LC_ALL = (unset),
LC_CTYPE = "zh_CN.UTF-8",
LANG = "zh_CN.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
请问这是为什么,如何解决。详细点本人菜鸟,谢谢!!
头像
windwiny
帖子: 2254
注册时间: 2007-03-13 17:26
送出感谢: 0
接收感谢: 1 次

#2

帖子 windwiny » 2008-03-07 8:13

sudo dpkg-reconfigure locales 重新配置试下
admaliu
帖子: 12
注册时间: 2008-03-06 16:16
送出感谢: 0
接收感谢: 0

#3

帖子 admaliu » 2008-03-07 9:40

windwiny 写了:sudo dpkg-reconfigure locales 重新配置试下
输入sudo dpkg-reconfigure locales后出现以下提示:
Password:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "zh_CN:zh:en_US:en",
LC_ALL = (unset),
LC_CTYPE = "zh_CN.UTF-8",
LANG = "zh_CN.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
zh_CN.UTF-8... up-to-date
zh_HK.UTF-8... up-to-date
zh_SG.UTF-8... up-to-date
zh_TW.UTF-8... up-to-date
Generation complete.
Current default timezone: 'Asia/Shanghai'.
Local time is now: Fri Mar 7 09:47:06 CST 2008.
Universal Time is now: Fri Mar 7 01:47:06 UTC 2008.
Run 'tzconfig' if you wish to change it.
不过这样好象还是不行
不知道我这个显示的对不对
xautofzx
帖子: 315
注册时间: 2005-05-11 20:14
来自: 西安理工大学
送出感谢: 0
接收感谢: 0

#4

帖子 xautofzx » 2008-04-02 10:03

删除 LANGUAGE 中的en_US:en应该就好了。
回复

回到 “老旧版本支持”