安装build-essential 失败?

为当前最终发行版之前的所有版本提供支持
回复
peehar
帖子: 6
注册时间: 2008-03-15 15:41
送出感谢: 0
接收感谢: 0

安装build-essential 失败?

#1

帖子 peehar » 2008-03-15 16:49

安装失败,出现以下提示信息。

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: g++ (>= 4:4.1.1) 但是它将不会被安装
依赖: dpkg-dev (>= 1.13.5) 但是它将不会被安装

谁能帮忙?
先谢谢了!
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#2

帖子 dbzhang800 » 2008-03-15 16:59

先检查你的源设对了没?
peehar
帖子: 6
注册时间: 2008-03-15 15:41
送出感谢: 0
接收感谢: 0

#3

帖子 peehar » 2008-03-16 3:29

刚接触ubuntu
设置了源,可以安装了mplayer和xmms
不知道这样是不是源设置对了
peehar
帖子: 6
注册时间: 2008-03-15 15:41
送出感谢: 0
接收感谢: 0

#4

帖子 peehar » 2008-03-16 3:56

我使用的是Ubuntu 8.04 amd64
安装build-essential
不知道应该用什么源
请教了
谢谢
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#5

帖子 dbzhang800 » 2008-03-16 9:32

头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#6

帖子 leeaman » 2008-03-16 10:08

lz不你的员额文件贴出来啊,源用哪个看你的网络用过那个快了,但是源文件里面的单词dapper edgy feisty gutsy hardy是对应你用的版本号来着,装什么版本用哪个单词的
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
sevk
帖子: 2059
注册时间: 2007-05-08 16:26
系统: arch
来自: 火星内核某分子内某原子核内
送出感谢: 20 次
接收感谢: 6 次
联系:

#7

帖子 sevk » 2008-03-16 10:21

源不要换错.
update时不要出错.
sudo apti<按tab> install build-essential
听说apti<tab>这个会自动修复一些怪问题的.
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387
peehar
帖子: 6
注册时间: 2008-03-15 15:41
送出感谢: 0
接收感谢: 0

#8

帖子 peehar » 2008-03-16 11:06

ok
使用以下源已经解决
谢谢大家关心

代码: 全选

deb http://ubuntu.cn99.com/ubuntu/ hardy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-backports main restricted universe multiverse
spank
帖子: 47
注册时间: 2007-10-29 15:46
来自: 长沙
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 spank » 2008-04-15 9:10

peehar 写了:ok
使用以下源已经解决
谢谢大家关心

代码: 全选

deb http://ubuntu.cn99.com/ubuntu/ hardy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-backports main restricted universe multiverse
多谢兄弟!帮了我的大忙,我也是build-essential装不上,g++也装不上,包依赖问题耽误了好长时间。
看来是源选择问题。我以前用的源是feisty的。
不知道你是从哪找的源,怎么知道这个源能够自动处理依赖问题呢?!
女朋友爱上了我,我爱上了linux,linux爱上了ubuntu,ubuntu征服了女朋友!Loving you!
dbzhang800
帖子: 3182
注册时间: 2006-03-10 15:10
来自: xi'an China
送出感谢: 0
接收感谢: 2 次
联系:

#10

帖子 dbzhang800 » 2008-04-15 12:03

spank 写了:
peehar 写了:ok
使用以下源已经解决
谢谢大家关心

代码: 全选

deb http://ubuntu.cn99.com/ubuntu/ hardy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ hardy-backports main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-updates main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-security main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-proposed main restricted universe multiverse
deb-src http://ubuntu.cn99.com/ubuntu/ hardy-backports main restricted universe multiverse
多谢兄弟!帮了我的大忙,我也是build-essential装不上,g++也装不上,包依赖问题耽误了好长时间。
看来是源选择问题。我以前用的源是feisty的。
不知道你是从哪找的源,怎么知道这个源能够自动处理依赖问题呢?!
好好补补课,这是最最基本的常识。而且前面的帖子中我给出了所有的源列表的链接
回复

回到 “老旧版本支持”