系统升级后,cron服务出错,要死人了快帮帮我!

为当前最终发行版之前的所有版本提供支持
回复
头像
zshmail
帖子: 270
注册时间: 2006-07-03 9:12
送出感谢: 0
接收感谢: 0
联系:

系统升级后,cron服务出错,要死人了快帮帮我!

#1

帖子 zshmail » 2008-03-18 23:42

系统用的是7.10server版,安装后用spy更新成testing版的源。gonme等安装后,因为安装mplayer所需的一些包源里没有,就把源换成了WIKI里的源,然后顺便update和upgrade后,使用apt-get install 任意软件都提示cron出错,提示如下:

# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up cron (3.0pl1-100ubuntu1) ...
usage: update-rc.d [-n] [-f] <basename> remove
update-rc.d [-n] <basename> defaults [NN | SS KK]
update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
-n: not really
-f: force
dpkg: error processing cron (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
cron
E: Sub-process /usr/bin/dpkg returned an error code (1)

=============================================================
后卸载了cron后,apt-get正常了,但影响了其它软件,比如ntp,samba等要用到cron的所有软件都不能用了。
然后我下载了cron的deb包,想通过dpkg强制安装,但也是如上提示,不能安装。

谁有修复的好办法,请速告知,谢谢!
否则我真的又得重装系统了(已经装过N遍ubuntu了,已经烦透了)
tg8866
帖子: 471
注册时间: 2008-02-01 7:16
送出感谢: 0
接收感谢: 0

#2

帖子 tg8866 » 2008-03-19 6:04

试试 aptitude install -f
头像
zshmail
帖子: 270
注册时间: 2006-07-03 9:12
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 zshmail » 2008-03-19 14:09

tg8866 写了:试试 aptitude install -f
试过了,就是上面的提示.
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2008-03-19 14:16

装回 cron 的Ubuntu版本
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
zshmail
帖子: 270
注册时间: 2006-07-03 9:12
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zshmail » 2008-03-19 18:35

BigSnake.NET 写了:装回 cron 的Ubuntu版本
已经试过了,装不上.
头像
zshmail
帖子: 270
注册时间: 2006-07-03 9:12
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 zshmail » 2008-03-20 22:03

没人知道吗
头像
flies
帖子: 167
注册时间: 2005-11-10 21:20
来自: 广西南宁
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 flies » 2008-03-21 14:08

源换来换去估计是依赖性乱了,要加新的源不用替换,加到后面就是了,你把两个源都写上,然后再装呢
其实一直在用gentoo…………
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#8

帖子 eexpress » 2008-03-21 14:16

Setting up cron (3.0pl1-100ubuntu1) ...
usage: update-rc.d [-n] [-f] <basename> remove
update-rc.d [-n] <basename> defaults [NN | SS KK]
update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
-n: not really
-f: force
dpkg: error processing cron (--configure):
你的这包,内部问题啊。update-rc.d的语法错误了?你的源不正常吧。corn的版本倒是一样的。是哪个源啊。
● 鸣学
头像
zshmail
帖子: 270
注册时间: 2006-07-03 9:12
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 zshmail » 2008-03-22 12:46

eexpress 写了:
Setting up cron (3.0pl1-100ubuntu1) ...
usage: update-rc.d [-n] [-f] <basename> remove
update-rc.d [-n] <basename> defaults [NN | SS KK]
update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
-n: not really
-f: force
dpkg: error processing cron (--configure):
你的这包,内部问题啊。update-rc.d的语法错误了?你的源不正常吧。corn的版本倒是一样的。是哪个源啊。
一直用CN99的源
头像
zshmail
帖子: 270
注册时间: 2006-07-03 9:12
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 zshmail » 2008-03-22 12:49

根据提示应该是在设置cron时出错了,但这设置全部是内部自动的,人为的又不能修改,自己编译一个去试试看了。
回复

回到 “老旧版本支持”