升级到8.04了!有问题!高手帮帮我呀

为当前最终发行版之前的所有版本提供支持
回复
头像
zszzd
帖子: 156
注册时间: 2007-12-12 22:54
送出感谢: 0
接收感谢: 0

升级到8.04了!有问题!高手帮帮我呀

#1

帖子 zszzd » 2008-03-21 9:48

昨天晚上升级到8.04,无线网卡不能用了!
7.10还是正常的!
郁闷!

在网上找到 一个解决8.04无线网上问题的文章:
---------------------------------------------------------------------------------------------------
$ ls -l /lib/modules/`uname -r`/ubuntu/wireless/iwlwifi/iwlwifi/compatible
总用量 316
-rw-r--r-- 1 root root 145472 2008-03-02 00:36 iwl3945.ko
-rw-r--r-- 1 root root 166744 2008-03-02 00:36 iwl4965.ko
$ ls -l /lib/modules/`uname -r`/ubuntu/wireless/iwlwifi/mac80211/compatible/net/mac80211
总用量 360
-rw-r--r-- 1 root root 349760 2008-03-02 00:36 iwlwifi_mac80211.ko
-rw-r--r-- 1 root root 12192 2008-03-02 00:36 iwlwifi_rc80211_simple.ko

上面两个命令,说明驱动里面有iwl3945的驱动,以及运行这个驱动所需的mac80211子系统。注意看iwlwifi_mac80211.ko,这个驱动说明iwlwifi和mac80211的驱动是放在一起编译出来的。目前iwl3945有两种编译方式,一种是单独编译mac80211、 ieee80211、ipw3945(iwl3945)并放在一起用,另外一种就是iwlwifi_mac80211.ko这种从一开始就是放在一起编译的。这两种方法产生的驱动不能混着用,会有冲突,我遇到的问题就是这种冲突。
----------------------------------------------------------------------------------------------------

我按着上面的查,显示 的文件什么的都一样的,但后来怎么做我就搞不成了.......
oldsheep35
帖子: 4
注册时间: 2007-04-20 22:57
送出感谢: 0
接收感谢: 0

#2

帖子 oldsheep35 » 2008-04-21 1:04

我的无线网卡在8.04也不行。等待高手解答
回复

回到 “老旧版本支持”