[问题]自己尝试编译内核,结果linux-restricted-modules不好用了

为当前最终发行版之前的所有版本提供支持
回复
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

[问题]自己尝试编译内核,结果linux-restricted-modules不好用了

#1

帖子 nbdxkfq » 2008-03-26 17:57

自己尝试编译内核,结果linux-restricted-modules不好用 ,打开受限制驱动管理器时说

需要安装软件包

linux-restricted-modules-2.6.24.4nbdxkfq2

以使软件正常工作。.

然后去源里面找 linux-restricted-modules相关的包 ,只能找到 2.6.22-14的,更新的找不到了,请问各位哪里有更新的包下,源代码也可以,谢谢
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-03-26 18:19

那当然了, 你内核变了

试试安装内核头文件后把 linux-restricted-modules 也编译安装
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

#3

帖子 nbdxkfq » 2008-03-26 18:23

哦 ,试试看 ,谢谢
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2008-03-26 18:31

看了一下, 貌似很麻烦
我建议自己编译的内核就不要用这个了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

#5

帖子 nbdxkfq » 2008-03-26 19:23

你的意思是不要用受限制驱动管理器了 ?

我 刚才把内核的头文件kernel_headers也编译并且安装了,问题依旧存在,为什么呢?

怎么编译 linux-restricted-modules呢 ,找不到源文件下载的说

我看了一下,在/lib下面有linux-restricted-modules这个文件夹,文件夹里面有原来最早一个内核名字命名的文件夹,但是没有新的内核作为名字的文件夹,是不是因为配置内核的之后没有把这个模块选上去啊?但是又没有发现哪里可以选择相关模块的,谢谢~~~~
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2008-03-26 19:38

你的意思是不要用受限制驱动管理器了


^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
nbdxkfq
帖子: 144
注册时间: 2007-01-10 23:56
送出感谢: 0
接收感谢: 0

#7

帖子 nbdxkfq » 2008-03-26 19:49

那请问你知道和linux-restricted-modules相关的最新版本的源文件哪里有下载吗?谢谢
louisbadbad
帖子: 3
注册时间: 2008-03-27 7:35
送出感谢: 0
接收感谢: 0

#8

帖子 louisbadbad » 2008-03-27 7:50

更新你的/etc/apt/source.list
加上这个
deb http://archive.ubuntu.com/ubuntu/ hardy main restricted universe


nbdxkfq 写了:那请问你知道和linux-restricted-modules相关的最新版本的源文件哪里有下载吗?谢谢
头像
syrano
帖子: 4313
注册时间: 2007-10-06 18:40
送出感谢: 0
接收感谢: 5 次

#9

帖子 syrano » 2008-03-27 21:01

貌似可以安装apt-build后
sudo apt-build install linux-restricted-modules
回复

回到 “老旧版本支持”