当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装好后正常启动黑屏
帖子发表于 : 2008-03-27 3:34 

注册: 2007-02-12 8:51
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
机器环境:
显卡:ATI RADEON HD 2400PRO
CPU:AMD Athlon(TM) 64X2 双核处理器 4400+

安装Redhat一切正常。

安装Ubuntu遇到了问题,运行Live CD正常,但安装好后,就无法正常启动,用recovery模式是可以进入字符模式的;但正常的模式就黑屏了,没有任何错误信息。

不知道是什么原因,装了3个晚上了,7.10Amd64和32的两个版本都装了,都是一样的问题,实在是郁闷。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装好后正常启动黑屏
帖子发表于 : 2008-03-27 7:39 

注册: 2008-03-27 7:35
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
这个问题可能是因为XFree86和你的显卡支持的问题,
现尝试使用ctrl+alt+backspace关闭X11, 如果不成功,尝试使用ctrl+alt+F1 进入virtual terminal, 建议修改grub的启动选项
/boot/grub/menu.lst 看一下你的vga是不是正常,设置参数和你的显卡有关系,设置nosplash
看一下/var/log下的x11的log,看到底是有什么原因引起的。
你提供的信息不够全面,所以剩下的工作只有你自己去作了。

chenjiangwu 写道:
机器环境:
显卡:ATI RADEON HD 2400PRO
CPU:AMD Athlon(TM) 64X2 双核处理器 4400+

安装Redhat一切正常。

安装Ubuntu遇到了问题,运行Live CD正常,但安装好后,就无法正常启动,用recovery模式是可以进入字符模式的;但正常的模式就黑屏了,没有任何错误信息。

不知道是什么原因,装了3个晚上了,7.10Amd64和32的两个版本都装了,都是一样的问题,实在是郁闷。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-27 12:01 

注册: 2007-02-12 8:51
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
ctrl+alt+F1 不行的,我试过的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-27 16:59 

注册: 2008-03-26 16:54
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我是菜鸟一个
我的是ATI 移动 X2300 显卡,安装好以后没有合适的驱动,后来随便选了个ATI的,结果黑屏,后来还是用的VGA通用驱动,现在还没有解决驱动问题,不过网上已经有解决办法,我看到过,用的是2月份发布的一个驱动,吼吼,楼主的问题也可能是驱动的问题。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-29 10:49 

注册: 2007-02-12 8:51
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
把/boot/grub/menu.lst 中splash改成nosplash,同时将/etc/X11/xorg.conf 不支持的分辨率去掉后可以启动了。但我显卡和显示器支持1440x900的(vista下),在ubuntu下只能支持1024×768不知道是什么原因?还有桌面3D怎么开启的。
我到Amd网站下了ati radeon hd 2400的8.3的驱动装了也没有用(还是不会装?),装完就黑了,还非得将/etc/X11/xorg.conf中的driver从ati改vesa,否则启动不了;
不过amd的安装手册上说:
The latest version of the ATI Proprietary Linux Graphics Driver is designed to support the following Linux distributions:
Red Hat Enterprise Linux suite
Novell/SuSE product suite

言下之意不支持ubuntu的。

各位大虾有什么好的解决办法?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-04-06 14:15 

注册: 2008-03-21 19:11
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
sudo dpkg-reconfigure xserver-xorg 重新配置


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-04-14 10:49 

注册: 2008-04-13 13:58
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
安装ubuntu不用第三方驱动,就用ubuntu自带就可以了。我的也是ati,但没有必要去下载ati的驱动程序。按照一下步骤:系统管理->受限驱动程序,把第一项也够上,安装;打开新立得,查找xlg,安装xserver-xgl;查找compiz,安装compizconfig setting manager;把以上步骤完成了,系统管理->startup-manage,设置像素和色点,重启,ok


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 安装好后正常启动黑屏
帖子发表于 : 2009-02-11 20:06 

注册: 2009-02-09 14:55
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
recovery模式是什么,做什么用的?
怎么用,俺是一个菜鸟,
能解决俺的启动黑屏吗


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译