8.04的libgtk2.0-dev怎么装不上阿...!

为当前最终发行版之前的所有版本提供支持
回复
Frente
帖子: 15
注册时间: 2008-04-04 0:44
送出感谢: 0
接收感谢: 0

8.04的libgtk2.0-dev怎么装不上阿...!

#1

帖子 Frente » 2008-04-05 21:47

sudo apt-get install libgtk2.0-dev
下列的软件包有不能满足的依赖关系:
libgtk2.0-dev: 依赖: libatk1.0-dev (>= 1.6.1-2) 但是它将不会被安装
依赖: libcairo2-dev 但是它将不会被安装
依赖: libglib2.0-dev (>= 2.12.0) 但是它将不会被安装
依赖: libgtk2.0-0 (= 2.12.5-1) 但是 2.12.9-2ubuntu1 正要被安装
依赖: libpango1.0-dev (>= 1.10.0-2) 但是它将不会被安装


换用sudo aptitude install libgtk2.0-dev结果还是不行...

下列软件包是“破损”的:
libcairo2-dev libglib2.0-dev libgtk2.0-dev libpango1.0-dev
下列新软件包将被自动安装:
libatk1.0-dev
下列“新”软件包将被安装。
libatk1.0-dev
0 个软件包被升级,新安装5 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 4440kB 的存档。 解包后将要使用 15.6MB。
下列软件包存在未满足的依赖关系:
libglib2.0-dev: 依赖: libglib2.0-0 (= 2.15.3-0ubuntu1) 但是 2.16.1-1ubuntu3 已安装
libpango1.0-dev: 依赖: libpango1.0-0 (= 1.19.3-1ubuntu1) 但是 1.20.0-1 已安装
libcairo2-dev: 依赖: libcairo2 (= 1.5.6-1ubuntu1) 但是 1.5.12-0ubuntu2 已安装
libgtk2.0-dev: 依赖: libgtk2.0-0 (= 2.12.5-1) 但是 2.12.9-2ubuntu1 已安装
Resolving dependencies...
打开:5181;关闭;4999;defer: 0; 冲突;22 .在限定的时间内没能找到解决方案。加把劲再试试?[Y/n]y

请问 是怎么回事?难道想装个emacs23也不行...-_-~
头像
aric286
帖子: 943
注册时间: 2007-12-03 9:54
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 aric286 » 2008-07-20 0:36

我也是,郁闷
rectange
帖子: 39
注册时间: 2009-03-28 14:45
送出感谢: 0
接收感谢: 0

Re: 8.04的libgtk2.0-dev怎么装不上阿...!

#3

帖子 rectange » 2010-01-01 18:50

我的是Ubuntu 9.10;
可以通过把libcairo2强制版本到1.8.8-2ubuntu1(karmic)而非1.8.8-2ubuntu1.1(now)解决。
回复

回到 “老旧版本支持”