[原创]一键搞定装机基本过程

为当前最终发行版之前的所有版本提供支持
回复
fno
帖子: 17
注册时间: 2006-03-12 11:49
送出感谢: 0
接收感谢: 0

[原创]一键搞定装机基本过程

#1

帖子 fno » 2006-03-17 22:42

只需要 一个 environment 文件、一个 sources.list、一个脚本,你就可以一键搞定官方所提到的基本装机过程了。

在一个新文件夹中,

新建一个 environment 文件,写入(我的本地系统编码是 UTF8的,不喜欢的话你自己改):
LANGUAGE="zh_CN:zh:en_US:en"
LC_CTYPE=zh_CN.UTF-8
LANG=zh_CN.UTF-8
GST_ID3_TAG_ENCODING=GBK

新建一个 sources.list 文件,写入:
deb http://archive.ubuntu.org.cn/ubuntu/ breezy main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu/ breezy-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu/ breezy-updates main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu/ breezy-backports main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu-cn/ breezy main restricted universe multiverse
deb http://archive.ubuntu.org.cn/backports/ breezy-extras main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ breezy-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ breezy main restricted universe multiverse
deb http://ubuntu.cn99.com/backports/ breezy-extras main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy-security main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy-updates main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/archive/ breezy-backports main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/ubuntu-cn/ breezy main restricted universe multiverse
deb http://mirror.lupaworld.com/ubuntu/backports/ breezy-extras main restricted universe multiverse

新建一个脚本文件,随便起名成 01,给它运行权限,写入:
sudo cp /etc/apt/sources.list sources.list_backup
sudo cp sources.list /etc/apt/sources.list
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get -y install build-essential
sudo apt-get -y install gcc-3.4
sudo apt-get -y install g++-3.4
sudo apt-get -y install libstdc++5-3.3-dev
sudo dpkg-reconfigure locales
sudo apt-get -y install language-pack-gnome-zh
sudo apt-get -y install language-pack-gnome-zh-base
sudo apt-get -y install language-pack-zh
sudo apt-get -y install language-pack-zh-base
sudo apt-get -y install language-support-zh
sudo apt-get -y install ttf-arphic-ukai
sudo apt-get -y install ttf-arphic-uming
sudo apt-get -y install install scim
sudo apt-get -y install scim-modules-socket
sudo apt-get -y install scim-modules-table
sudo apt-get -y install scim-pinyin
sudo apt-get -y install scim-tables-zh
sudo apt-get -y install scim-input-pad
sudo sh -c " echo 'export XMODIFIERS=@im=SCIM ; export GTK_IM_MODULE="scim" ; scim -d ' > /etc/X11/Xsession.d/95xinput "
sudo chmod +755 /etc/X11/Xsession.d/95xinput
sudo cp /etc/environment environment_backup
sudo apt-get -y install sun-j2re1.5
sudo ln -sf /usr/lib/j2re1.5-sun/bin/java /usr/bin/java
sudo apt-get -y install beep-media-player
sudo apt-get -y install totem-xine
sudo apt-get -y install w32codecs
sudo apt-get -y install gstreamer0.8-plugins
sudo apt-get -y install stardict
sudo apt-get -y install stardict-common
sudo apt-get -y install stardict-cdict-gb
sudo apt-get -y install stardict-cedict-gb
sudo apt-get -y install stardict-hanzim
sudo apt-get -y install stardict-langdao-ce-gb
sudo apt-get -y install stardict-langdao-ec-gb
sudo apt-get -y install stardict-oxford-gb
sudo apt-get -y install stardict-xdict-ce-gb
sudo apt-get -y install stardict-xdict-ec-gb
sudo apt-get -y install flashplayer-mozilla
sudo apt-get -y install linux-686

运行脚本就能搞定装机基本过程了,注意我的机器是 英特尔CPU,如果是AMD,不要使用 sudo apt-get -y install linux-686 行,我选用的输入法是 SCIM,如果你不喜欢,自已除去相关脚本,至于显卡、应用软件、其它字体等的安装过程,你自己向脚本中增加吧。

你看以上最简单的脚本就可以实现很多操作,Linux的脚本功能真是强大啊!
蓝蜗牛
帖子: 193
注册时间: 2005-11-26 18:27
送出感谢: 0
接收感谢: 0

#2

帖子 蓝蜗牛 » 2006-03-17 23:05

支持原创 我顶
谢谢楼主分享,体现了linux的精神
学习中。。。。。。
原来sources。list文件要这样写啊?试试。。
回复

回到 “老旧版本支持”