求助~这个该死的sun-j2re1.5究竟怎么弄!

为当前最终发行版之前的所有版本提供支持
jentin
帖子: 6
注册时间: 2005-12-04 18:54
送出感谢: 0
接收感谢: 0

求助~这个该死的sun-j2re1.5究竟怎么弄!

#1

帖子 jentin » 2006-03-18 17:52

郁闷死拉,不管是网站还是论坛,只要是有关安装QQ和sun-j2re1.5的文章都看拉。就是解决不了问题~每次都是“E: 无法找到软件包 sun-j2re1.5sudo”究竟要怎么搞才能顺利的用上QQ阿!真***郁闷!真是忍不住骂人~~~~~~~~~
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-03-18 17:55

确认你都认真看过吗?安装的命令明明是下面这样的。

sudo apt-get install sun-j2re1.5
sudo ln -sf /usr/lib/j2re1.5-sun/bin/java /usr/bin/java
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
the_owl
帖子: 190
注册时间: 2006-02-18 20:42
送出感谢: 0
接收感谢: 0

#3

帖子 the_owl » 2006-03-18 17:58

不装java也可以用qq的,你去下载一下lumaqq的含jre版本的就可以了,这样的话,它自己带java环境,不用你自己安装了 :D

另外这个软件包好像一叶贴过下载地址,你可以下载jre和sdk两个deb包,然后用dpkg命令安装
jentin
帖子: 6
注册时间: 2005-12-04 18:54
送出感谢: 0
接收感谢: 0

#4

帖子 jentin » 2006-03-18 19:54

楼上的能给出具体的操作吗?我实在是太菜了.请说清楚点~~~~
the_owl
帖子: 190
注册时间: 2006-02-18 20:42
送出感谢: 0
接收感谢: 0

#5

帖子 the_owl » 2006-03-18 20:06

下载:
http://lumaqq.linuxsir.org/download/200 ... jre.tar.gz

然后解压缩到一个目录下

再下载:
http://lumaqq.linuxsir.org/download/pat ... .15.00.zip

解压缩到刚才你解压缩的目录下,可能会覆盖掉部分文件

然后进入目录,运行就可以了:

./lumaqq
liu
帖子: 108
注册时间: 2006-03-19 11:20
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 liu » 2006-03-19 11:27

代码: 全选

l@liu:~$ sudo apt-get install sun-j2re1.5
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
现在没有可用的软件包 sun-j2re1.5,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 sun-j2re1.5 还没有可供安装的候选者
l@liu:~$
“这个该死的sun-j2re1.5”我确实拿它没办法。
想问个事情望高手不要取笑:不知道含jre版本的lumaqq,其中的jre是不是能用于其他软件?

(因为还想装freemind……)
头像
内存不足
论坛版主
帖子: 3277
注册时间: 2005-08-18 18:43
送出感谢: 0
接收感谢: 1 次
联系:

#7

帖子 内存不足 » 2006-03-19 12:53

终端里先
sudo apt-get install sun-j2re1.5
完成后再
sudo ln -sf /usr/lib/j2re1.5-sun/bin/java /usr/bin/java
应该就可以了 怎么会不好用? 源设置的不对?
໌→ iCookie Gtk Theme
໌→DropPlusBluetheme
กรัก กรัก`菠萝
liu
帖子: 108
注册时间: 2006-03-19 11:20
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 liu » 2006-03-19 14:05

我用的是网通线路,所以源sources.list文件是这样写的。

代码: 全选

deb http://cncmirror.vmmatrix.net/ubuntu/ dapper main restricted universe multiverse
deb http://cncmirror.vmmatrix.net/ubuntu/ dapper-security main restricted universe multiverse
deb http://cncmirror.vmmatrix.net/ubuntu/ dapper-updates main restricted universe multiverse
deb ftp://ftp.sjtu.edu.cn/sites/archive.ubuntu.com/ dapper main restricted universe multiverse
deb ftp://ftp.sjtu.edu.cn/sites/archive.ubuntu.com/ dapper-security main restricted universe multiverse
deb ftp://ftp.sjtu.edu.cn/sites/archive.ubuntu.com/ dapper-updates main restricted universe multiverse
我也在怀疑是不是该在什么地方加上no-free的定义,但这只是在suse和debian里的经验,这里就不敢乱动了。

麻烦大侠帮我看看这个列表有什么问题?
蓝蜗牛
帖子: 193
注册时间: 2005-11-26 18:27
送出感谢: 0
接收感谢: 0

#9

帖子 蓝蜗牛 » 2006-03-19 15:05

反正这儿的人很奇怪

我怀疑他们故意忽悠我们这些菜鸟

太过分
蓝蜗牛
帖子: 193
注册时间: 2005-11-26 18:27
送出感谢: 0
接收感谢: 0

#10

帖子 蓝蜗牛 » 2006-03-19 15:11

关于qq的安装
小弟不长。。。略知一二。。。

下载带jre版的lumaqq
把他考到你想要的目录种
比如常见的/usr/local
然后tar jxvf luma*.tar.gz
你还要下一个zip的path文件(lumaqq主业上都有提供)
用unzip luma*.zip 解压
把 解压出来的那2个文件覆盖lumaqq.tar.gz  tar出来的LumaQQ中的lib目录下的相应文件

然后在usr/local中执行:
chmod a+x -R LumaQQ

在desktop上键一个启动器指向lumaqq就可以了
也可以在lumaqq安装目录中:。/lumaqq就ok 了
liu
帖子: 108
注册时间: 2006-03-19 11:20
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 liu » 2006-03-20 23:41

还是顶一个,实在不知道为了能装到j2re(包括其他众多的如chmsee,w32codecs,stardict-cdict-gb,xpdf-chinese-simplefied...等等的默认源里没有的包),安装源应该怎么设置。。
头像
leal
帖子: 1119
注册时间: 2005-08-29 14:49
来自: 杭州
送出感谢: 0
接收感谢: 3 次
联系:

#12

帖子 leal » 2006-03-21 7:47

从你的源里看,只包含Ubuntu官方支持的软件包,因此没有你要的那些软件也很正常

http://wiki.ubuntu.org.cn/%E6%B7%BB%E5% ... %BB%5Cb%29

可以参看这篇文章里的源设置,对电信用户肯定没问题,但网通就不太清楚了,just try
用心×恒 | 豆瓣 | 门户 | Blog
liu
帖子: 108
注册时间: 2006-03-19 11:20
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 liu » 2006-03-21 15:31

谢谢leal大侠的提示…… :)

怪我没有表达清楚,也没有即时补充 :oops: 。其实我也是对照指南来的,后来也尝试过cn99的源:按指南的标准写法,而将里面的breezy全部替换为dapper。

但是测试后发现像ubuntu-cn这样的目录下,根本就没有dapper子目录;这就导致sources.list中后面几行会带来报错信息,而根本没用,所以只好把它们删掉了。

后来我在breezy的目录下翻到了一些我期待已久的包,但实在不知道怎么用上,也不敢在sources.list轻举妄动——因为对我这样的新手来说,linux简直是太“脆弱”了,一个不小心就会彻底崩溃那。

dapper下应该怎么安装非官方支持的包呢? 如果能解决这个问题,我就可以说基本解脱困境了。。 :)
xubuntu dapper + T30
http://liuxun.googlepages.com
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 karron » 2006-03-21 15:45

不知道混用breezy的源行不行.
全部改成breezy,只apt-get update,不apt-get dist-upgrade
然后在安装软件试试. 安装完成在改成dapper的源,再apt-get update.

不过对于新手来说,还是不要去用dapper这样还是测试状态的系统,出问题的可能性太大了,出了问题,又不好解决,很打击信心的.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#15

帖子 yang119345 » 2006-03-21 15:48

对头,混用源比较麻烦。呵呵。挫折感可不是很好的东东哦。呵呵
回复

回到 “老旧版本支持”