[讨论]!!!!紧急通知: 对于vista和ubuntu双启动的朋友必看!!!!

为当前最终发行版之前的所有版本提供支持
头像
iriccis
帖子: 39
注册时间: 2008-04-09 21:24
送出感谢: 0
接收感谢: 0
联系:

[讨论]!!!!紧急通知: 对于vista和ubuntu双启动的朋友必看!!!!

#1

帖子 iriccis » 2008-04-14 12:57

Vista SP1不支持Vista/Linux双启动!

目前微软已经承认,当用户拥有Vista Enterprise/Ultimate和Linux双系统,且Linux的引导被安装至MBR的情况,在升级Vista至SP1版时会遇到麻烦.
据悉微软的SP1补丁包KB935509具有新版的bootloader,在升级SP1时,原系统中的bootloader可能已经被开源版的 bootloader程序所取代,例如Grub.目前微软已经解释了该问题出现的原因,Vista SP1补丁包中包含了BitLocker功能的更新,更换开机引导程序bootloader的目的是为了让系统能在引导时加载驱动器加密和 BitLocker技术.
目前更新SP1时“信任链”平台的完整启动顺序如下,首先从机器上的TPM芯片读取信息,然后通过MBR和操作系统进行引导.而双启动的情况下,Vista中的Bootloader如果被替代,系统完整性检查会失败,该SP1安装也会失败,同时系统也将无法正常开机.

微软技术顾问Michael Kleef解释说:“BitLocker不仅关系到加密和系统验证,也关系到数据的完整性.BitLocker按照顺序进行检查,如果它发现了一些不匹配的东西,它将拒绝访问.安装Lilo或是其他引导程序将破坏原有的引导信任体系,因为这些Bootloader会替代微软的Bootloader,这也意味着加密分区将无法引导."

对于用户来说,如果Linux和Vista分区安装到同一个驱动器,用户必须恢复Vista的Bootloader然后才能进行SP1升级.如果操作系统不是在同一块硬盘,那么问题就小的多,用户只需要在BIOS中改变硬盘开机顺序即可.

另外,Vista SP1安装失败并不取决于你是否打开BitLocker特性,只要操作系统安装了BitLocker你就避免不了这种情况.默认情况下,也只有Vista Enterprise和Ultimate两个版本自动安装了BitLocker特性,所以,目前仅有这两种操作系统的用户会受到影响.[/b]
有什么办法呢,苦中作乐吧,人生就是在不断的update,upgrade后共赴黄泉
头像
冲浪板
论坛版主
帖子: 7466
注册时间: 2007-05-06 8:19
送出感谢: 0
接收感谢: 5 次

#2

帖子 冲浪板 » 2008-04-14 14:39

我不怕,因为根本就没装grup,仅仅有文件在根上
头像
caijiamx
帖子: 86
注册时间: 2008-03-28 19:20
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 caijiamx » 2008-04-14 15:42

还好我的是XP,我已经搞定了双系统啊
呵呵
:P
头像
Xusually
帖子: 242
注册时间: 2006-11-03 21:20
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 Xusually » 2008-04-14 19:44

已经知道了,在CB上已经被骂的不行了
Never had a dream come ture!
============================
Lenovo E42LT2390
CPU:T2390
RAM:1G DDRII 667*2
VGA:X3100
HD:Seagate 160G SataII
CD:Combo
Wireless:Intell 3945abg
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 karron » 2008-04-14 19:45

我的是oem集成的sp1, 和linux共存没有任何问题.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
tlhl28
帖子: 474
注册时间: 2006-09-02 18:58
来自: 深圳
送出感谢: 0
接收感谢: 0

#6

帖子 tlhl28 » 2008-04-14 19:53

LS的您重装一次看看!
------
ThinkPad·R60i-0657LN1
Ubuntu 8.04 . Hardy Heron+XP
------
头像
七彩云南
帖子: 135
注册时间: 2008-04-03 22:51
送出感谢: 0
接收感谢: 0

#7

帖子 七彩云南 » 2008-04-15 1:59

Vista当死,Linux当立。
holylina
帖子: 24
注册时间: 2008-04-13 10:10
送出感谢: 0
接收感谢: 0

#8

帖子 holylina » 2008-04-15 3:15

还好还没装ubuntu..不过ms搞得复杂来
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#9

帖子 carbont » 2008-04-15 4:08

看不懂……
和我也没有关系--单ubuntu。呵呵哈
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont
yupp
帖子: 28
注册时间: 2007-07-06 9:04
送出感谢: 0
接收感谢: 1 次

#10

帖子 yupp » 2008-04-15 11:15

Linux和windows分在两台电脑,这样总打不起来了吧 :twisted:
头像
zhaoyannian
帖子: 226
注册时间: 2008-03-07 12:32
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 zhaoyannian » 2008-04-15 15:13

我的是U版的VISTA 番茄花园的XP和ubuntu7.10.是不是vista就不能升级sp1了。如果先卸载ubuntu再升级sp1,然后再安装ubuntu如何?有没有问题?本人是菜鸟唉,希望高手指点。
头像
isflyer
帖子: 58
注册时间: 2008-03-21 15:45
送出感谢: 0
接收感谢: 0

#12

帖子 isflyer » 2008-04-16 15:38

已经告别windos需要虚拟一个,让它做小的
头像
gdzhljw
帖子: 314
注册时间: 2007-05-19 23:18
来自: 广东珠海
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 gdzhljw » 2008-04-16 22:26

好在装了vista企业版可以装系统呵呵。。。。。。
凡事都可行.但不都有益处。凡事都可行.但不都造就人。(哥林多前10:23)

my blog : http://gdzhljw.blog.163.com/
http://gdzhljw.blog.ubuntu.org.cn/
militia200
帖子: 75
注册时间: 2007-12-28 21:09
送出感谢: 0
接收感谢: 0

#14

帖子 militia200 » 2008-04-17 15:05

看来麻烦了 本来还打算升级SP1的 看来微软在垄断的路上又迈进了一大步
头像
sevk
帖子: 2059
注册时间: 2007-05-08 16:26
系统: arch
来自: 火星内核某分子内某原子核内
送出感谢: 20 次
接收感谢: 6 次
联系:

#15

帖子 sevk » 2008-04-17 15:48

很简单,
1,使用第三方引导程序.
2,复制ntldr和boot.ini.
3,安装grub for win.
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387
回复

回到 “老旧版本支持”