dpkg was interrupted

为当前最终发行版之前的所有版本提供支持
回复
diyself
帖子: 84
注册时间: 2005-12-25 1:42
送出感谢: 0
接收感谢: 0

dpkg was interrupted

#1

帖子 diyself » 2006-03-19 22:37

命中 http://mirror.lupaworld.com breezy-extras/universe Packages
命中 http://mirror.lupaworld.com breezy-extras/multiverse Packages
下载 4B,耗时 0s (4B/s)
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
farley@ubuntu:~$ dpkg --configure -a
dpkg: 该操作需要超级用户权限
farley@ubuntu:~$ sudo dpkg --configure -a
dpkg: 解析错误,在“/var/lib/dpkg/status”文件的第“12461”行附近 软件包“openoffice.org-core”:
“Conflicts”字段,无效的软件包名“openoffice.org2-l10n-1.9.1cription:”:不允许有字符“:” - 只能用字符、数字和 -+._
farley@ubuntu:~$
jaex
帖子: 190
注册时间: 2006-02-14 21:05
送出感谢: 0
接收感谢: 0

#2

帖子 jaex » 2006-03-20 11:39

打开新立得,然后修复一下就好了!!
diyself
帖子: 84
注册时间: 2005-12-25 1:42
送出感谢: 0
接收感谢: 0

#3

帖子 diyself » 2006-03-20 12:06

kubuntu没有新立得,打不开 adept

换了一个源还是不行哦!
之前,apt-get安装Adobe Reader,下载完后在配置的时候停电了,然后启动电脑,发现:Adobe Reader可以用,但出现上述问题
diyself
帖子: 84
注册时间: 2005-12-25 1:42
送出感谢: 0
接收感谢: 0

#4

帖子 diyself » 2006-03-20 14:22

环境 : 5.10-》 6.04 kubuntu
解决过程:
dpkg --configure --pending

/var/lib/dpkg/updates/0000

dselect 然后选up (U) 。。。
头像
avauntage
帖子: 570
注册时间: 2005-09-22 10:15
来自: 北京
送出感谢: 0
接收感谢: 0

#5

帖子 avauntage » 2006-03-23 9:11

试试
$ sudo dselect update
空手把锄头,步行骑水牛;人在桥上过,人流水不流。
头像
oneleaf
论坛管理员
帖子: 10227
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#6

帖子 oneleaf » 2006-03-23 9:45

“/var/lib/dpkg/status”文件的第“12461”行附近 软件包“openoffice.org-core”:
“Conflicts”字段,无效的软件包名“openoffice.org2-l10n-1.9.1cription:”:不允许有字符“:” - 只能用字符、数字和 -+._
那就手工修改一下 /var/lib/dpkg/status 将 12461 行的 openoffice.org2-l10n-1.9.1cription: 修改为 openoffice.org2-l10n-1.9.1cription 试试?

如果还不行,强制删除所有的OO2,然后再重新安装。
diyself
帖子: 84
注册时间: 2005-12-25 1:42
送出感谢: 0
接收感谢: 0

#7

帖子 diyself » 2006-03-23 23:23

多谢楼上各位,已经OK了

环境 : 5.10-》 6.04 kubuntu
解决过程:
dpkg --configure --pending

/var/lib/dpkg/updates/0000

dselect 然后选up (U) 。。。
回复

回到 “老旧版本支持”