当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 怎样让 apt-get 忽略损坏的包?
帖子发表于 : 2008-04-15 16:21 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
比如 wine-doors 这个包依赖 wine 包,但是我用自己编辑的 wine 软件,不想安装 源里的 wine 包,
我自己到源里下载了 wine-doors 这个包,用 sudo dpkg -i --force-all 忽略依赖关系来安装了它。

这样,这个软件能用了,但是在 apt-get dist-upgrade 或者做其它什么事的时候总是提示有损坏的包,
新立得也不能升级, 这要怎么办? 让 apt-get 忽略这个包的状态
sudo apt-get -f install 是不行的,它会要求安装 wine 包


最后由 windwiny 编辑于 2008-04-15 16:29,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-04-15 16:23 
头像

注册: 2006-09-04 21:38
帖子: 1073
地址: 中国沙大
送出感谢: 0 次
接收感谢: 0 次
试试
代码:
sudo apt-get install -f


_________________
ArchLinux,你让我不得不放弃,等着我,我还会回来!
不要总是让我玩系统!我要用它来工作!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-04-15 23:19 
头像

注册: 2007-09-29 7:36
帖子: 416
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get clean


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-15 23:24 
头像

注册: 2007-09-29 7:36
帖子: 416
送出感谢: 0 次
接收感谢: 0 次
上面的是清楚缓存 我上次是那么做的 这么可以把出错的软件包删掉


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译